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Copyright. 
 
This manual and software are.. 
© Andrew Voller Lighting Design Limited 2012, All Rights Reserved. 
 

Version. 
 
Version 1.0 
9th  September 2012. 
 

Trademarks. 
 
Mac, Macintosh and Mac OS are trademarks of Apple Inc., registered in 
the United States and other countries. 
Windows is a registered trademark of Microsoft Corporation in the United 
States and other countries. 
Lightwright is a registered trademark of John McKernon. 
 

Gobo Copyright Notices. 
 
Gobo artwork used in the application is copyrighted and owned by the 
relevant manufacturers. Permission has been granted by the 
manufacturers for the artworks inclusion in the gobo library for the 
purpose of generating production documentation only.  
 
Vari-Lite gobo images are © Vari-Lite. Gobo images used with permission 
from Philips Var-Lite. Unauthorised use is prohibited. 
 
Martin gobo images and designs are © Martin Professional A/S. 
Reproduced with permission from Martin Professional A/S. 
 
Rosco gobo images and designs are © Rosco Laboratories, All Rights 
Reserved. 
 
Apollo gobo images and designs are © Apollo Design Technology, Inc. All 
Rights Reserved. 
 
Clay Paky gobo images and designs are © Clay Paky SpA. All Rights 
Reserved. 
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Software Components. 
 
The application has been written using Real Studio by Real Software Inc.. 
The application includes third party components by… 
Einhugur Software, Figa Software, Jérémie Leroy, Roth Soft, Christian 
Schmitz Software GmbH. 
 

Acknowledgements. 
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Special thanks go to David Arch, Erik-Jan Berendsen, Martin Chisnall, Matt 
Daw, Chris Hirst, John Mckernon, Matthias Strobel and Tom Young. 
Toolbar icons were designed by Dave Newton of Potion Pictures Ltd. 
 

This Manual. 
 
For comments on this manual; errors, omissions or suggestions, please 
email manual@movinglightassistant.com. 
 
This user guide was written by Martin Chisnall. 
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SOFTWARE LICENSE AGREEMENT 
 
ANDREW VOLLER LIGHTING DESIGN LIMITED 
LICENCE AND SUPPORT AGREEMENT 
 
IMPORTANT NOTICE: PLEASE READ CAREFULLY BEFORE INSTALLING THE 
SOFTWARE:  
THIS LICENCE AGREEMENT (LICENCE) IS A LEGAL AGREEMENT BETWEEN YOU 
(LICENSEE OR YOU) AND ANDREW VOLLER LIGHTING DESIGN LIMITED A 
COMPANY REGISTERED IN ENGLAND AND WALES UNDER REGISTRATION NUMBER 
07312325 WHOSE REGISTERED OFFICE IS AT UNIT 12A, AKEMAN BUSINESS PARK, 81-
82 AKEMAN STREET, TRING HP23 6AF (LICENSOR OR WE) FOR THIS MOVING LIGHT 
ASSISTANT SOFTWARE PRODUCT (SOFTWARE).  
THIS SOFTWARE REQUIRES WORKSTATIONS WITH INTEL PROCESSORS AND 
APPLE MAC OSX VERSION 10.6.8 OR LATER OR MICROSOFT WINDOWS 7 
OPERATING SYSTEMS (MINIMUM REQUIREMENTS). BY CLICKING ON THE 
"ACCEPT" BUTTON BELOW YOU AGREE TO THE TERMS OF THIS LICENCE WHICH 
WILL BIND YOU. IF YOU ARE ACCEPTING THESE TERMS ON BEHALF OF YOUR 
EMPLOYER YOU ACKNOWLEDGE THAT YOUR EMPLOYER AGREES TO BE BOUND 
BY THIS AGREEMENT AND YOU WARRANT THAT YOU ARE AUTHORISED TO BIND 
THE COMPANY TO THE TERMS OF THIS LICENCE. IF YOU (OR YOUR EMPLOYER) 
DO NOT AGREE TO THE TERMS OF THIS LICENCE WE ARE UNWILLING TO 
LICENSE THE SOFTWARE TO YOU AND YOU MUST DISCONTINUE THE 
INSTALLATION OR APPLICATION LAUNCH PROCESS NOW.  IN THIS CASE THE 
INSTALLATION OR APPLICATION LAUNCH PROCESS WILL TERMINATE. 
WHEREAS IT IS HEREBY AGREED AS FOLLOWS: 
 
DEFINITIONS 
 
“Demo/Reader Licence” means a licence of the Software as more 
specifically described in clauses 3.1 and 3.2; 
 “Documentation” means the electronic user manual supplied on the 
media on which the Software is supplied; 
“Effective Date” means the date of this Agreement; 
“Institutional  Licence” means a licence of the Software as more 
specifically described in clauses 3.5 and 3.6; 
“Licence” means this licence agreement (including any Demo/Reader 
Licence, Personal Licence, Institutional  Licence and Student Licence) and 
any Schedule; 
“Licence Key” means the encrypted code supplied to the Licensee by the 
Licensor to access the Software; 
“Licence Fee” means the one off licence fee payable by the Licensee to 
the Licensor, as specified in the Schedule;  
“Maintenance Release” means any correction of the current version of 
the Software issued by the Licensor from time to time; 
 “New Version” means upgraded versions of the Software, which may 
include new features and functionality, as released from time to time at 
the Licensor’s discretion;  
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“Personal Licence” means a licence of the Software as more specifically 
described at clause 3.3 and 3.4; 
“Schedule” means the schedule attached hereto; 
“Software” means the object code form of the software licenced on the 
terms of a Demo/Reader Licence, Personal Licence, Institutional  Licence 
or Student Licence and as set out in the Schedule to this Licence, together 
with any Maintenance Releases provided to Licensee; 
“Student Licence” means a licence of the Software as more specifically 
described at clauses 3.7 and.3.8; 
“Support” means the provision of support and maintenance by the 
Licensor in respect of the Software in accordance with clause 5; 
“Users” means, in an Institutional  Licence, each individual user whom 
the Licensee permits to use the Software in accordance with the terms 
and conditions hereof; 
“Workstation” means a single computer the Software is installed on. 
 
LICENCE KEY  
 
Following Licensor’s receipt of the Licence Fee and Licensee’s installation 
of the Software, the Licensee may activate the Software by obtaining the 
Licence Key. The Licence Key is available by connecting the Software to 
the internet or e-mailing support@movinglightassistant.com.  
 
GRANT OF RIGHTS 
 
Demo/Reader Licence  
 
In the event Licensee has selected a Demo/Reader Licence, in 
consideration for Licensee’s compliance with the terms and conditions of 
this Agreement, the Licensor hereby grants the Licensee a non-exclusive, 
limited, non assignable, non sub-licensable right to use the Software and 
Documentation on the terms hereunder.  
In respect of an Demo/Reader Licence:  
the Licensee may install the Software on an unlimited number of 
Workstations;  
the Licensee shall only use the Software for the purpose of reading 
lighting documentation created using the Software or creating new 
lighting documentation for the purpose of evaluating the Software. 
Licensee acknowledges that the Software is not a fully enabled version of 
the Software and contains limitations and restrictions to the usual 
functionality of the Software; 
the Demo/Reader Licence shall commence on the Effective Date and 
continue until terminated in accordance with clause 8 (“Demo/Reader 
Licence Term”);  
subject to clause 10.5, the Licensor shall not be liable for any direct, 
indirect, special, consequential or incidental damages or losses (including 
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but not limited to any data loss or corruption) arising under or in 
connection with this Demo/Reader Licence. 
 
Personal Licence 
 
In the event the Licensee has selected a Personal Licence and in 
consideration for the Licence Fee, Licensor hereby grants Licensee a 
perpetual, worldwide, non-exclusive, non-transferable, paid-up licence to 
use the Software and the Documentation on the terms hereunder. 
In respect of a Personal Licence: 
the Licensee may install the Software on up to two (2) Workstations but 
acknowledges that the Software may only be used on a single Workstation 
at any one time;  
the Licensee shall only use the Software for its own personal and own 
business purposes; and 
the Personal Licence shall commence on the Effective Date and continue 
indefinitely unless terminated in accordance with clause 8 below. 
 
Institutional Licence  
 
In the event the Licensee has selected an Institutional Licence and in 
consideration for the Licence Fee, Licensor hereby grants Licensee a 
perpetual, worldwide, non-exclusive, non-transferable, paid up licence to 
use the Software and the Documentation on the terms hereunder.  
In respect of an Institutional  Licence: 
the Licensee may install the Software on up to ten (10) Workstations, 
subject to use of the Software being limited to up to five (5) Workstations 
at any one time and may permit up to five (5) Users to use the Software; 
the Licensee may use the Software for the Licensee’s own internal 
business purposes only;  
use of the Software is by the Licensee only and no subsidiaries or holding 
company of the Licensee may use the Software; and 
the Institutional  Licence shall commence on the Effective Date and 
continue indefinitely until terminated in accordance with clause 8 below. 
 
Student Licence 
 
In the event the Licensee has selected a Student Licence and in 
consideration for the Licence Fee, Licensor hereby grants Licensee a 
perpetual, worldwide, non-exclusive, limited, non-transferable, paid-up 
licence to use the Software and the Documentation on the terms 
hereunder. 
In respect of a Student Licence: 
the Licensee may install the Software on up to two (2) Workstations, 
subject to use of the Software being limited to a single Workstation at any 
one time; 
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the Licensee shall only use the Software for its own personal and own 
business purposes;  
the Licensee acknowledges that the Software contains limitations and 
restrictions on use; 
the Licensee warrants, represents and undertakes that, as at the Effective 
Date, he or she is enrolled in full time education and will continue to be 
for no less than 12 months following the Effective Date. For the avoidance 
of doubt, a breach of this clause will be deemed a material breach, 
terminable in accordance with clause 8.1.1;  
the Student Licence shall commence on the Effective Date and continue 
for a period of three (3) years, unless terminated earlier in accordance 
with this Licence.  
 
RESTRICTIONS 
 
Except as expressly permitted in this Licence, Licensee shall not, and shall 
not permit others to: (i) modify, translate, create derivative copies of or 
copy the Software (other than one backup copy which reproduces all 
proprietary notices), in whole or in part; (ii) reverse engineer, decompile, 
disassemble or otherwise reduce the object code of the Software to source 
code form; (iii) distribute, sublicence, assign, share, timeshare, sell, rent, 
lease, grant a security interest in, use for service bureau purposes, or 
otherwise transfer the Software or Licensee’s right to use the Software; 
(iv) remove or modify any copyright, trademark, or other proprietary 
notices of Licensor affixed to the media containing the Software or 
contained within the Software; or (v) use the Software in any manner not 
expressly authorised by this Licence. 
The Software contains (and Licensor may modify the Software to add) 
technical measures that are intended to (i) restrict; or (ii) notify Licensor; 
of any unauthorised use of the Software. In the event that Licensee’s use 
of the Software exceeds the number permitted under this Licence, 
Licensor shall be entitled to revoke licence in respect of the Software and 
to terminate this Licence.  
 
SUPPORT 
 
In consideration for payment of the Licence Fee, Licensor shall provide the 
Support, which shall comprise: 
responding to requests for advice on the use of the Software by Licensee 
by electronic mail or the Licensor’s online forum located at 
www.movinglightassistant.com; and 
 the provision of New Releases and Maintenance Releases where available, 
in accordance with clause 5.2.  
Licensor may provide Licensee with Maintenance Releases from time to 
time at its sole discretion. Licensee shall promptly follow all instructions 
provided by Licensor in respect of the Maintenance Releases. 
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Nothing in the Agreement shall oblige the Licensor to provide New 
Releases to the Licensee free of charge.  
 
PROPRIETARY RIGHTS 
 
Licensor has sole and exclusive ownership of all right, title, and interest in 
and to the Software, including all copyright and any other intellectual 
property rights therein.  This Licence conveys a licence to use the 
Software and shall not be construed to convey title to or ownership of the 
Software to Licensee.  All rights in and to the Software not expressly 
granted to Licensee are reserved by Licensor. 
 
LICENCE FEE 
 
In consideration for the Personal Licence, Institutional Licence or Student 
Licence granted to Licensee hereunder, Licensee shall pay Licensor (or 
such other person, company or organisation as the Licensor may direct in 
writing) a onetime non-refundable Licence Fee. For the avoidance of 
doubt, no Licence Fee is payable in respect of a Demo/Reader Licence.  
The Licence Fee shall be due and payable on the Effective Date and is 
exclusive of VAT or other sales tax, which shall be added to the invoice 
and payable by the Licensee. If any applicable law requires Licensee to 
withhold amounts from any payments to Licensor hereunder, (i) Licensee 
shall effect such withholding, remit such amounts to the appropriate 
taxing authorities and promptly furnish Licensor with tax receipts 
evidencing the payments of such amounts, and (ii) the sum payable by 
Licensee upon which the deduction or withholding is based shall be 
increased to the extent necessary to ensure that, after such deduction or 
withholding, Licensor receives and retains, free from liability for such 
deduction or withholding, a net amount  equal to the amount Licensor 
would have received and retained in the absence of such required 
deduction or withholding.  
  
TERM AND TERMINATION 
 
This Licence may be terminated: 
forthwith by Licensor or Licensee if the other commits any material breach 
of any term of any of this Licence and which (in the case of a breach 
capable of being remedied) shall not have been remedied within 30 days 
of a written request to remedy the same. For the avoidance of doubt, a 
material breach shall include breach of clause 4 of this Licence; 
forthwith by Licensor or Licensee if the other shall convene a meeting of 
its creditors or if a proposal shall be made for a voluntary arrangement 
within Part 1 of the Insolvency Act 1986 or a proposal for any other 
composition scheme or arrangement with (or assignment for the benefit 
of) its creditors or if the other shall be unable to pay its debts within the 
meaning of section 123 of the Insolvency Act 1986 or if a trustee receiver, 



MOVING	
  LIGHT	
  ASSISTANT	
   9	
  
 

administrative receiver or similar officer is appointed in respect of all or 
any part of the business or assets of the other or if a petition is presented 
or a meeting is convened for the purpose of considering a resolution or 
other steps are taken for the winding up of the other or for the making of 
an administration order (otherwise than for the purpose of an 
amalgamation or reconstruction). 
Licensor shall be entitled to (a) immediately terminate this Licence upon 
written notice; and (b) permanently prohibit Licensee and/or the IP 
addresses used by Licensee from making any use of and/or accessing the 
Software in the event Licensee is or Licensor has reasons to be believe 
that Licensee is (i) using the Software to commit a criminal act or to cause 
nuisance or annoyance or inconvenience to or harass others including 
without limitation, to engage in hacking activities; and/or (ii) using the 
Software and/or doing an act or series of acts that shall or may 
reasonably be deemed to infringe any patents, copyrights, trademarks, 
design rights or any other intellectual property rights or other rights of 
any third parties. 
Upon any termination of this Licence, (a) the rights and licences granted 
to Licensee herein shall terminate; (b) Licensee shall cease all use of the 
Software; (c) Licensee shall return to Licensor all copies of the Software 
and Documentation in Licensee’s possession or under its control; and 
(d) Licensee shall certify in writing to Licensor its compliance with the 
foregoing.  Clauses 1, 6, 7 (to the extent of unpaid obligations), 8.3, 9.3, 
10 and 11 shall survive any termination of this Licence. 
 
REPRESENTATIONS AND WARRANTIES 
 
Licensor warrants that the Software will function materially in accordance 
with the Documentation for a period of ninety (90) days from the Effective 
Date.  
The above warranty is conditional upon the Licensee complying with the 
Minimum Requirements and subject to any limitations in the use of the 
Software imposed by the Demo/Reader Licence and Student Licence.  
The warranties set forth in this clause 9 are exclusive and in lieu of all 
other warranties, express or implied, including without limitation the 
implied warranties of satisfactory quality, fitness for a particular purpose, 
and any warranties arising by statute or otherwise in law or from course 
of dealing, course of performance, or use of trade, all of which are hereby 
excluded and disclaimed.  
Licensee hereby represents that it: (i) is legally capable of entering into 
binding contracts; (ii) shall comply with all applicable local and foreign 
laws and regulations which may govern the use of the Software, and (iii) 
use the Software only for lawful purposes and in accordance with the 
terms of this Licence. 
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LIMITATION OF LIABILITY 
 
Subject to clause 10.5, the maximum aggregate liability of the Licensor 
with respect to any claims arising out of or in connection with this Licence 
whether arising in contract, tort (including negligence) or otherwise shall 
be limited to the Licence Fee paid by Licensee to Licensor. For the 
avoidance of doubt, the foregoing limitation shall not apply to a 
Demo/Reader Licence, such licence to be subject to the limitation at 
clause 3.2.4.   
In no event shall Licensor be liable for any special, indirect, incidental, or 
consequential damages, loss of profits or goodwill, business or business 
benefit, loss of any anticipated savings, or the cost of procurement of 
substitute products by the Licensee even if advised of the possibility of 
such damages.  
In no circumstances shall the Licensor be liable for any failure of the 
Software to perform in accordance with the Documentation, or at all, 
resulting from a failure by Licensee to: 
 comply with the Minimum Requirements; or  
comply with the instructions set out in the Documentation; or 
 implement any Maintenance Release.  
The Licensee acknowledges that whilst the Software may be used in 
combination with third party software, Licensor bears no liability, 
howsoever arising, for any loss, damage or cost that arises from a failure 
of the Software to integrate with Licensee’s or third party’s software. 
For the avoidance of doubt, nothing in this Licence Agreement shall be 
deemed to exclude, restrict or limit liability of either party (or their 
respective agents or sub-contractors) for death or personal injury 
resulting from their negligence or any liability for fraudulent 
misrepresentation. 
 
GENERAL 
 
Licensee shall not assign this Licence, in whole or in part, without the 
written consent of Licensor. 
Licensee consents to the use by Licensor of Licensee’s name in customer 
lists and other publicity, including interviews, case studies, and conference 
discussions, provided that such publicity accurately describes the nature 
of the relationship between Licensee and Licensor.   
This Licence and its performance shall be governed by and construed in 
accordance with English law and the parties hereby submit to the 
exclusive jurisdiction of the courts of England. 
Licensee agrees that because of the unique nature of the Software and 
Licensor’s proprietary rights therein, a demonstrated breach of this 
Licence by Licensee would irreparably harm Licensor and monetary 
damages would be inadequate compensation.  Therefore, Licensee agrees 
that Licensor shall be entitled to preliminary and permanent injunctive 
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relief, as determined by any court of competent jurisdiction to enforce the 
provisions of this Licence. 
Any notice request instruction or other document to be given hereunder 
shall be delivered or sent by first class post or by email or facsimile (in all 
cases to be confirmed by letter posted within 12 hours) to the address of 
the other set out or referred to in this Licence (or such other address as 
may have been notified) and any such notice or other document shall be 
deemed to have been served and deemed to have been received (if 
delivered) at the time of delivery (if sent by post) upon the expiration of 
48 hours after posting and (if sent by email or facsimile) upon the 
expiration of 12 hours after dispatch. 
If any provision of this Licence or the Software thereof is declared void, 
illegal, or unenforceable, the remainder of this Licence will be valid and 
enforceable to the extent permitted by applicable law.  In such event, the 
parties agree to use their best efforts to replace the invalid or 
unenforceable provision by a provision that, to the extent permitted by 
the applicable law, achieves the purposes intended under the invalid or 
unenforceable provision. 
Any failure by any party to this Licence to enforce at any time any term or 
condition under this Licence will not be considered a waiver of that party’s 
right thereafter to enforce each and every term and condition of this 
Licence. 
Neither Licensor or Licensee shall be liable for any breach of this Licence 
resulting from causes beyond its reasonable control including but not 
limited to fires, strikes (of its own or other employees) insurrection or 
riots, wrecks or delays in transportation, inability to obtain supplies and 
raw materials requirements or regulations of any civil or military authority 
(an “Event of Force Majeure”). Each of Licensor and Licensee agree to 
give notice forthwith to the other upon becoming aware of an Event of 
Force Majeure such notice to contain details of the circumstances giving 
rise to the Event of Force Majeure. If a default due to an Event of Force 
Majeure shall continue for more than 13 weeks then the party not in 
default shall be entitled to terminate this Licence. Neither Licensor nor the 
Licensee shall have any liability to the other in respect of such termination 
as a result of an Event of Force Majeure. 
This Licence (i) constitutes the entire agreement and understanding 
between the parties with respect to the subject matter hereof and 
supersedes all prior agreements, oral and written, made with respect to 
the subject matter hereof, and (ii) cannot be altered except by agreement 
in writing executed by an authorised representative of each party.  No 
purchase order and/or standard terms of purchase provided by Licensee 
shall supersede this Licence. Each of the parties acknowledges that in 
entering into this Licence on the terms set out herein it has not relied on 
or been induced to enter into this Licence by any representation, 
warranty, undertaking, promise or assurance made or given by any other 
party or any other person, whether or not in writing, at any time prior to 
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the execution of this Licence other than those expressly set out in this 
Licence. 
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FORWARD. 
 
Moving Light Assistant is designed for the complete documentation of 
primarily automated lighting rigs used within the entertainment industry. 
 
Its aim is to generate pre-production specification documents, automated 
lighting fixture configuration documents/cards/labels and console related 
moving light documentation including cue and preset/focus information. 
 
It is possible to import console data reports from the MA Lighting 
GrandMA (Series 1), ETC EOS/ION and to a limited degree High End 
Systems Whole Hog 2 consoles. The imported data can then be used to 
help document the cues and presets/palettes. It is also possible to analyse 
the console data to see how channels are used in a show. 
 
Moving Light Assistant is very modular in its design and operation. It is 
entirely possible to use each module in isolation, and different people may 
choose to do just this depending upon their individual needs. However, 
the different modules are tightly integrated, and  data entered in one 
module can interact with data in other modules. 
 
For example, an Electrician may choose to use only the Rig Data section in 
order to aid DMX patching. A Lighting Associate may elect to only use the 
Preset Documentation section to store photographs of cues, whilst a 
programmer may only be interested in examining Console Data for 
redundant moves. However, the Associate will quickly realise that he can 
use the Electricians Rig Data as a starting point for documenting focus 
presets, The Electrician will realise he can update his DMX patch from the 
Programmers console data, and the programmer will realise how useful 
the Associates photographs are when updating a focus preset. 
 
And Finally, 
 
Moving Light Assistant is a ‘true’ computer application, written from ‘the 
ground up’, in a real computer programming language, for both Mac and 
Windows operating systems. It does not require any other applications to 
be purchased or present on the user’s computer in order to function.
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INSTALLATION 

MAC OS 
 
Installation under MAC OSX 
 
Double click on the Disk Image File (.dmg) to launch the installer. 
 

 
 

Please read and agree to the End User Licence Agreement (EULA) 
 

 
 

If you disagree the installation cannot continue. 
 
The following window will appear. 
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To Install the application, drag the Moving Light Assistant folder to the 
Application Folder. 
 

 
 

Un-installing 
 
Moving Light Assistant can be uninstalled by dragging it’s folder to the 
trash bin. 
 

 
 

WINDOWS OS 
 
Installation under Windows 7. 
 
Run the application MLASetup. (MLASetup.exe) 
 
If the following window appears, click ‘Run’ to continue. 
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Depending upon your Windows User Account settings, you may see the 
following window: 
 

 
 
Click ‘Yes’. The Setup routine will begin. 
 

 
 

Click ‘Next’. 
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Please read the End User Licence Agreement. 
 

 
 

If you agree, select ‘I accept the agreement’ and click ‘Next’. 
If you do not accept the agreement the installation cannot continue. 
 

 
 
Select a location in which to install Moving Light Assistant. By default, 
C:\Program Files\Moving Light Assistant\ will be created. Unless you have 
good reason to change this, click ‘Next’. 
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Unless you have reason to change it, click ‘Next’ to accept the program 
shortcut. 
 

 
 

Unless you have reason not to, click ‘Next’ to create a desktop icon. 
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Setup is now ready to install Moving Light Assistant. 
Click ‘Install’. 
 

 
 

When the installation is complete you will have the option of launching 
Moving Light Assistant. Click ‘Finish’ 
 
Moving Light Assistant is now installed. 
 
Moving Light Assistant, by default, creates a folder within Program Files, 
and the following sub folders: 
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Un-installing 
 
Moving Light Assistant can be uninstalled via Control Panel, programs, 
Uninstall a program. 
 

Computer Requirements. 
 
Microsoft Windows Vista or later. 
 
MAC OS 10.6.8 (Snow Leopard) or later. 
 
4Gb RAM recommended. 
 
300Mb of free hard disk space minimum.  
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Licence/Registration. 
 
Once Moving Light Assistant has been successfully installed, launch the 
application.  
 
When it is first launched on a computer it has not been previously 
installed on, you will have to enter a license key if you want to enable all 
the features of the application. If no license key is entered, the application 
will default to Demo/Reader mode. 
 
License keys are not platform specific. 
 

Reader License. 
 
If no license has been purchased or entered, Moving Light Assistant will 
default to Reader mode. 
 
Reader mode allows any show file provided by another user to be opened 
and the full contents viewed. Reports may be generated and viewed on 
screen, but printing, either to a printer or pdf file is disabled. Wheel 
images may not be dragged in to other applications. 
 
It is not possible to edit the show file or to import console data. 
 

Student License. 
 
The student license enables all the features of Moving Light Assistant.  
 
Student licenses have an expiry date of 3 years from the date the license 
was issued. When this period has expired, the application will default to 
Reader mode. 
 
Reports may be printed wheel loads dragged in to other applications, but 
are watermarked to identify them as having been produced on a student 
licence.  
 
With a student licence, Moving Light Assistant may be registered on up to 
2 computers, but may only be used on 1 machine at any one time. 
 

Personal License. 
 
The personal license enables all the features of Moving Light Assistant. 
 
There are no fixture limits, expiry dates, or watermarks. 
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With a personal licence, Moving Light Assistant may be registered on up to 
2 computers, but may only be used on 1 machine at any one time. 
 
 
 

Institutional License. 
 
The institutional license enables all features of Moving Light Assistant. 
 
There are no fixture limits, expiry dates, or watermarks. 
 
With an institutional licence, Moving Light Assistant may be registered on 
up to 10 computers, and  may be used on 5 machine at any one time. 
 

Registration. 
 
To register the Moving Light Assistant you will need a serial number and a 
license key. 
 
When you purchase a license, you will be supplied with a ‘Registered 
Name’, and a ‘Serial Number’.  
Moving Light Assistant can be installed on multiple computers using the 
same serial number depending upon the licence bought. 
 

 
Registration Window 
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Enter the Registered User name and Serial Number exactly as they are in 
the email sent to you. Copying and pasting the entries is the easiest 
method.  
 
If the User Name and Serial Number are valid, then a message will appear 
in the bottom left of the dialog. If there are any issues then a message 
will indicate the problem. Issues that can occur are: 
 

• Invalid serial number. 
• Expired serial number. 
• Serial number is not valid for the application version. 

 
If you are expecting the serial number to be valid, check it has been 
entered correctly. 
 
If the User Name and Serial Number are valid, then a Computer ID will be 
generated and the buttons and License Key text field below will be 
enabled. The License Key is tied to a specific computer as a form of copy 
protection. 
 
There are two ways to obtain a license key: 
 

If you are connected to the internet then click the ‘Online Activation’ 
button. Moving Light Assistant will attempt to connect to the 
registration server and request a License Key. If this is successful, 
then a license key will appear in the License Key text field and a 
message to the left indicating the license key is valid. 

 
If you are not connected to the internet, or there is a problem with 
the license key request, then you can request a license key via 
email. 
Clicking on the ‘Email Activation’ will open your default email 
application and prepare an email with the information required to 
complete activation. Send the email generated and your request will 
normally be processed within 24 hours. When you receive a reply, 
copy and paste the License Key text into the License Key text field. 

 
Once registration and activation are complete, click the ‘OK’ button and 
the application is ready to go. If you already have a document open (i.e. 
you are in Reader/Demo mode), exit and re-launch Moving Light Assistant 
to ensure all features are fully enabled. 
 
Depending on your purchased license, you may only request a certain 
number of license keys for a specific serial number. For Student and 
Personal licenses, you may request 2 License keys, and for Institutional 
licenses, you may request up to 10 license keys. 
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Every installation of Moving Light Assistant requires a unique licence key 
to be fully enabled. 
 
If you wish to install Moving Light Assistant on another computer, and 
have already used your allotted number of licence keys then you must 
first de-register one of the existing installations. 
 
De-registration is achieved through File->Deregister this Computer. 
 
If your computer is stolen and you are therefore unable to deregister the 
application, contact your dealer, or support@movinglightassistant.com for 
assistance. 
 
If you have not purchased a license, there is no limit on the number of 
computers you may install and run the application on in Demo/Reader 
mode.  
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Installed Components. 
 
The Moving Light Assistant installation includes several files and folders 
within the Moving Light Assistant folder. Below is a brief explanation of 
their uses. 
 

FixtureProfiles.plib 
 
This file is the applications profile library. The library supplied includes a 
large selection of commonly used moving light fixtures. Any fixtures you 
create will be added to this file and the library is accessible in any show 
documents you open. 
 

ConsoleProfiles.clib 
 
This files is the applications console library. At Present the console profiles 
are not used by the application. 
 

GoboLibrary.glib 
 
This is the applications gobo library. The library contains the gobo artwork 
for use in the gobo and colour wheel graphics.  
 

Help Folder 
 
Any files in this folder will appear in the applications Help menu. This user 
guide, release notes, documentation etc. will be located in this folder. 
 

Lightwright Automated Actions 
 
In this folder are some automated actions that should be added the 
Automated Actions folder of your Lightwright installation if you wish to 
export and import data easily between Moving Light Assistant and 
Lightwright. 
 

Report Layout Templates 
 
In this folder are the templates used for generating reports to print ( or 
generate PDF documents ) within the application. 



MOVING	
  LIGHT	
  ASSISTANT	
   31	
  
 

LAUNCHING Moving Light Assistant. 
 
Click on the desktop icon to run Moving Light Assistant. 
 
The start up Window will be displayed. 
 

 
Start Up Window. 

 
Options exist to either start a new show, Load an existing show, or load 
the last show file used. Make a selection, or choose to exit the application. 
 
 
It is only possible to have one document open at a time, and one instance 
of Moving Light Assistant running at any time.   
The show file is self contained and does not save any extra files for 
different types of data. For example any photos used in the application are 
saved within the show document. The show document will also contain 
copies of the fixture profiles and gobos/colours used in the show, so that 
when the file is sent to another person, if they do not have the fixture 
profiles or gobos/colours used in the file, they will be added to the persons 
profile and gobo libraries automatically. 
 
The only exception to this is Report Layout Files. By default they are not 
included in the show file, but may optionally be so. 
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OVERVIEW. 

Document Window. 
 
The document window is the primary window for viewing and editing data 
within the application. It uses a regular ‘Menu Bar’ and a  ‘Ribbon Style’ 
toolbar, with a series of tabs to switch between views of the different 
views, functions and data types. Below the Tabs are a series if toolbar 
buttons which change depending upon which tab is selected. The Menus 
do not change, and are always available irrespective of which tab is being 
viewed. 
 

 
Menu Bar and Ribbon Toolbar. 

Rig Data. 
 
The Rig Data view is where you build and edit the physical details of your 
show’s lighting rig. Typical information may include hanging positions, 
fixture types, channels and DMX addresses, for example. There are six 
user definable fields for information over and above the 43 standard 
fields. (You don’t have to use them all!) 
 

Wheel Loads. 
 
The Wheel Load view is where you create and edit the gobo, colour and 
effect wheel loads. When you add new fixtures in Rig Data, a standard 
load for the fixture type will be added to this view. You can then modify or 
copy this load to suit the production you are working on. Within this view 
is the applications gobo and colour library to allow quick and easy editing 
of wheel loads. 
 

Preset Documentation. 
 
This view allows you to create and view documentation on moving light 
presets, or palettes. Each preset can have multiple pictures and graphics 
showing the contribution of each fixture to the preset as a whole. 
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Cue List. 
 
This view shows the cue list (or lists) imported from a lighting console. 
Moving Light Assistant can import cue lists from GrandMa series 1, ETC 
EOS and Flying Pig Whole Hog 2. Photographs may be added to each cue. 
Additionally, The cue list can track the lighting console in real time via 
Midi Show Control.  
 

Console Data. 
 
This view allows you to inspect what individual channels or fixtures, or a 
range of channels or fixtures, is doing in each cue based upon imported 
cue data from the lighting console. Information such as maximum and 
minimum intensity levels can be computed, and live and redundant moves 
can be easily identified. 
 

Reports. 
 
This view displays printable reports based upon any of the information 
existing in the previous views. Such reports may include, for example, 
Instrument Schedules, Gobo and Colour Wheel loads and focus presets. 
There is a report template editor which allows for the design of custom 
reports not already catered for. 
 

Menus. 
 
Across the top of the screen is the Menu Bar. These menus are static and 
do not change with the tabbed views. 
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RIG DATA. 
 
The Rig Data View is selected by clicking on the Rig Data Tab on the 
ribbon toolbar, or by pressing numeric key 1 on the keyboard. 
 

 
Rig Data main view. 

 
The Rig Data view is where information about the physical details and 
configuration of the lighting rig is entered, displayed and edited. In many 
ways  it is similar to a standard spreadsheet application. 
The toolbar contains buttons for adding, copying and removing fixtures. 
Fixtures can be added and patched manually, imported from other 
applications such as Lightwright, or via  imported console data.  
Finally, the data can be filtered and sorted as desired and the columns 
displayed can be adjusted to suit personal needs. 
 
 
 

Toolbar 
 

 
Rig Data Toolbar Buttons. 
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Add Fixtures. 
 

 
Add Fixtures Toolbar Button. 

 
Unless you are importing rig data from an external application such as 
Lightwright, or data from a lighting console, the rig data entry for every 
new show is begun by adding fixtures.  
To add a fixture or a range of fixtures, click on the Add Fixtures toolbar 
button. The following dialog will appear… 
 

 
Add Fixtures Window. 

 
Add Fixtures is also available under the menu Edit->Add Fixtures. 
 
Fixtures are selected from Moving Light Assistant’s library of fixtures. 
Moving Light Assistant comes with a large library of pre-defined fixtures 
from a wide variety of manufacturers. Existing fixtures can be edited, or 
new fixtures added via the menu Manage->Fixture Profile Library. 
 
The Add Fixtures window has 3 tabs, Fixture, Optical and Control. The 
Fixture tab is selected by default. 
 
At the very simplest level it is only necessary to select a fixture 
manufacturer, and then a specific fixture, and click ‘Add’, to add a fixture 
to the Rig Data. 
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All other options will either be left blank, or set to the default option as 
defined in the Fixture Profile Library. 
 
If it is desired, more information can be specified at the time of adding 
fixtures: 
 
DMX Mode. 
 

Once a fixture has been selected, the DMX Mode will be set to the 
default DMX mode defined by the fixture profile. You can select an 
alternate mode (if alternate modes are defined) from the list of 
available modes in the drop down list. The number of DMX Channels 
required (the ‘DMX footprint’) for the mode selected will be 
displayed for information. 
 

Position. 
 

This is the hanging position of the fixture being added.  
 
If hanging positions have already been defined then the position 
may be chosen from the drop down list of available positions. If 
positions have not been defined, or a new position is required, then 
type directly in to the text box. This new position will then be added 
to the positions library, and be available for future use. 
 
The Position library can be accessed from menu Manage->Positions. 
 

Channel and Fixture Numbers. 
 

The Channel or Fixture number may be entered in the appropriate 
field. If ‘Fixture Number is same as Channel’ is checked, the Fixture 
Number field will be automatically populated with the same number 
as the channel number. Alternatively, if you wish, you may enter a 
separate number for the fixture number, or leave it blank. 
 
The choice to use fixture numbers may be a personal one, or may 
be steered by the choice of lighting console used. Moving Light 
Assistant can support both, but will always use the Channel Number 
as the primary means of identifying fixtures. 
 
 

Adding Multiple Copies of a Fixture. 
 

It is possible to add multiple copies of a fixture, if required. Simple 
enter the number of copies required in the ‘Copies’ field. If a 
channel number has been entered for the first fixture, it is possible 
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to automatically assign channel numbers to the other copies by 
entering a value in the ‘Increment by’ field.  
 

Add Fixtures – Optical. 
 

 
Add Fixtures, Optical Tab. 

 
The fixture optical options defined in the fixture profile will determine 
which optical options are available. The default options defined in the 
profile will be selected by as standard, other options may be selected from 
the drop down lists. It is not possible to directly enter information in to 
these fields in this window. The optical options must first be defined in the 
fixture profile. 
For more information on fixture optical options, refer to the section on the 
fixture Profile Library. 
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Add Fixtures – Control. 
 
 

 
Add Fixtures, Control Tab. 

 
The control tab allows you to provide DMX patch information at the time 
of adding fixtures. Only the fixture DMX address can be entered here. (Not 
the Beam, Colour, Intensity or Supply address.) 
 
Specify the System that the fixtures are connected to. By default, the 
System will be specified as ‘Main’. If other systems have been defined in 
Menu Manage->Systems, they will be available from the drop down list. 
 
Specify the DMX Universe and DMX Address. These values can be entered 
in any format you wish, and will be converted to the default format as 
defined in menu File->Preferences->console. For example, a DMX 
universe entered s ‘3’ will be converted to ‘C’ when displayed in Rig Data if 
the preferred DMX format is to use letters for Universes. Universe 0 
cannot be entered unless it is first enabled in File->Preferences->console.  
 
When adding multiple fixtures, you can define how to increment the DMX 
Address, either by the number of fixture DMX slots (Fixture radio button) 
or manually enter the DMX Offset. (Offset radio button). The DMX offset in 
the offset field will be based upon the DMX mode selected under the 
Fixture tab. 
 

Copying Fixture Data from previous fixtures to new fixtures. 
 
If you wish to add an additional fixture with the same settings as the 
previously added fixture (i.e. Positions, Fixture Type etc), hold down the 
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‘Alt’ key when you click on the Add Fixture toolbar button. The Position, 
Manufacturer, Fixture Type, DMX Mode, Lens, Internal Lens, Lamp, Option 
Bay 1, Option Bay 2 and System will be set to the same choices as the 
previously added fixture. Note the Wheel Load will not be set the same 
but will be set to the fixtures Standard load if one exists. 
Use of this feature can greatly speed up rig data entry where many 
fixtures have identical configurations, with perhaps only the channel 
number and DMX address changing. 
 

Deleting Fixtures. 
 

 
Delete Fixture Toolbar Button. 

 
The Delete Fixtures toolbar button will delete the selected fixtures in the 
Rig Data spreadsheet. Fixtures are selected by clicking anywhere on their 
spreadsheet row. A range of fixtures can be selected by holding down the 
keyboard Shift key while selecting the first and last fixtures. A 
confirmation dialog will appear to confirm the fixture you wish to delete. 
 

Duplicating Fixtures. 
 

 
Duplicate Fixtures Toolbar Button. 

 
The Duplicate Fixtures toolbar button will allow you to either duplicate 
the selected fixtures in the Rig Data spreadsheet, or duplicate all the 
fixtures in a chosen position. 
 
The shrewd use of ‘Duplicate Fixtures’ can greatly speed up the initial 
inputting of rig data where sequences of fixtures are repeated many times 
in different positions. 
 
 After clicking the toolbar button, the following dialog will appear. 
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Duplicate Fixtures dialog 

 
If you wish to duplicate specific fixtures, select them in the Rig Data first 
then click the Duplicate Selected Fixtures radio button. If you wish to 
duplicate all the fixtures in a specific position, click the Duplicate Positions 
radio button, and select the position to be duplicated from the drop down 
list of positions. 
 
Channel/Fixture. 
 

Clear Channel/Fixture numbers. 
When this checkbox is checked, the channel and fixture number will 
be cleared for the duplicated fixtures. The default option.  
 
Offset new Channel/Fixture By 
If this checkbox is checked, the Clear Channel/Fixture numbers 
checkbox will be automatically unchecked It is not possible to set 
both options on. The edit field to the right of the checkbox will be 
enabled to allow you to enter an offset value. The offset value will 
be applied to each duplicated fixtures channel and fixture number 
(only if they have a channel or fixture number). The offset value will 
be added to each duplicated channel/fixture number if it is a positive 
value, while negative offset value will be subtracted from the 
channel/fixture number. 

 
For example… 
Source Channels 101, 102, 103 
With an offset of 10 
Duplicated Channels 111, 112, 113 
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Source Channels 101, 102, 103 
With an offset of -10 
Duplicated Channels 91, 92, 93 
 
This feature is useful if entering Rig Data with a systematic channel 
numbering scheme. For Example, top light on Truss 1 is channels 
11-15, on truss 2, channels 21-25 and truss 3, channels 31-35. 

 
Position. 
 

Assign Position 
With this checkbox checked, you can specify in the combo box to 
the right, the position you wish to assign to the duplicated fixtures. 
You can either type in the name of the position, or choose from the 
drop down list. With this option disabled, the duplicated fixtures will 
have the same position as the source fixtures. 
 
Reverse Unit Numbers 
When this checkbox is checked, the unit numbers of the duplicated 
fixtures will be the same range of unit numbers as the source 
fixtures, but in the reverse order. If this option is used in 
combination with the Renumber Unit Numbers starting at option, 
then the newly assigned unit numbers will be in the reverse order 
for the duplicated fixtures. 
 
Renumber Unit Numbers starting at  
This option allows you to specify a new starting unit number to be 
assigned to the duplicated fixtures. Each duplicated fixture will 
increment the unit number by 1. Remember you can use this option 
in combination with the Reverse Unit Numbers option.  

 
Patch. 
 

Clear Patch 
When this option is checked, all DMX addresses (fixture, intensity, 
colour, beam and supply) will be cleared (un-patched). Generally it 
is a good idea to check this option, otherwise you will end up with 
duplicated DMX addresses in the Rig Data. Duplicated or overlapping 
DMX addresses will be highlighted in red in the main Rig Data view. 
 
Assign to Universe 
When this option is checked, the text field to the right will be 
enabled to allow you to enter a universe identifier (i.e. ‘A’ or ‘1’) for 
the duplicated fixtures base DMX address. This option will clear the 
DMX patch for the Intensity, Colour, Beam and Supply. 
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This feature can be useful when entering Rig Data for shows where 
identically rigged positions have identical DMX addresses, but on 
different DMX Universes. For example, Universe 1 controls Truss 1, 
Universe 2 controls Truss 2 etc.. 

 

Menu/DIP. 
 

 
Menu/DIP Toolbar Button. 

 
The Menu/DIP toolbar button allows you to set and document the 
selected fixtures menu or, if the fixture uses them, DIP switch settings. 
Select one or more similar fixtures from the Rig Data Spreadsheet  and 
click on the Menu/DIP tool bar button. A warning dialog will appear if 
fixtures of different types are selected. 
The Configure Fixture Options window will take one of two forms, 
depending upon whether the fixture uses a menu system, or DIP switches, 
for configuration. 
 
Configure Fixture Options – Menu. 

 
Configure Fixture Option - Menu settings. 

 
The displayed menu options information is defined for each fixture in the 
‘options’ section in the Manage->Fixture Profile Library menu. 
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You can change an option by clicking the drop down menu for the option 
in the Setting column. The Option column shows the path (the sequence 
of menu button pushes) and the name of the option. The Description 
column will show a description for the currently chosen Setting. If the 
Setting chosen is not the default option then the whole row will be 
highlighted in magenta. Some options need a value entered. In that 
instance, the drop down menu will show Set Value which when selected 
allows you to enter text to define the setting. The Description column will 
usually display the range that is appropriate to the menu option. 
 
To reset the menu options back to the fixture profile defaults, click the 
Reset to Defaults button. 
 
Configure Fixture Options – DIP Switches. 
 
 

 
Configure Fixture Option – DIP switch settings 

 
The dialog will display the appropriate number of switches for the fixture. 
Each switch is labelled with its function. The displayed DIP switch options 
information is defined for each fixture in the ‘options’ section in the 
Manage->Fixture Profile Library menu. 
 
Click on the switches to ‘operate’ them and change the options. When 
options have been changed from the default settings, the text will be 
highlighted in  magenta as shown in the image above. 
To reset all the menu options back to the fixture profile defaults, click the 
Reset to Defaults button. 
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Patch. 
 

 
Patch Toolbar Button. 

 
 

The Patch toolbar button opens a dialog that allows you to patch or un-
patch fixtures. The part of the fixture that will be patched or un-patched 
will be determined by the column in which the fixtures cell is selected. 
Moving Light Assistant supports up to five different patches per fixture: 
 
Fixtures start DMX Address. 
An external Intensity DMX Address (as in the case of a Vari-Lite VL5). 
An external Colour DMX Address (i.e. a scroller). 
An external Beam DMX Address (i.e. a gobo rotator). 
Supply DMX Address (i.e. a switchable non-dim supply for the fixture). 
 

 
Patch Dialog 

 
Patch selected fixtures. 
  
Patch selected fixtures will patch either a single fixture, or a range of 
fixtures depending upon what has been selected in the Rig Data 
spreadsheet. Enter the DMX Universe and DMX Address for the first fixture 
It will then increment the address as it patches each selected fixture in 
the spreadsheet. It will patch fixtures in the order the fixtures appear in 
the spreadsheet, so using different  filtering and sorting can allow you to 
change the order the fixtures will be patched.  
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The Patch Reverse checkbox will start patching the first address to the last 
selected fixture and increment the address working towards the first 
selected fixture. 
 

 
             Patch Reverse Off         Patch Reverse On 
 
Increment by. 
 
The Increment by options allow to use choose if the address is 
incremented by the number of DMX slots for the fixture, or by a specified 
offset. Note that if the offset is less than the number of DMX slots taken 
by the fixture, you will end up with overlapping DMX addresses. 
 
Unpatch selected fixtures. 
  
Unpatch selected fixtures will simply un-patch the selected fixture part. 
 
Change Universe. 
 
This option allows you to change only the universe for the selected 
addresses. Enter the new universe ID in the DMX Universe edit field. 
 
Click Patch. 
  
Click Patch is a special mode where upon clicking OK to dismiss the dialog, 
you can patch a fixture (starting at the DMX Universe and DMX Address 
you specified) by clicking on the address cell of the fixture (or Intensity, 
Colour, Beam or supply address cell). The mouse cursor will change to a 
number to show the address the fixture will be patched to. This allows you 
to easily patch fixtures in a non sequential or an irregular order. While you 
are in Click Patch mode, at the bottom right of the window ‘Click Patch’ 
will be displayed in red. To exit Click Patch mode, hit the Escape key on 
the keyboard. 
 
An error message will pop up when you hit the OK button if you have 
entered any invalid values in the edit fields. 
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Update from Console Patch. 
 

 
Update from Patch Toolbar Button. 

 
The Update from Console Patch facility allows Channel and DMX address 
data to be updated from imported console data. Additionally, other data 
available from the imported console data may also be imported. This 
additional data will be console specific, but may typically include such data 
as Fixture Type, Console Fixture Profile and Channel Label etc. 
 

 
Update from Console Patch Dialog. 

 
Update ONLY DMX addresses. 
 

Checking Update ONLY DMX addresses will only update DMX 
addresses, and not any other data available from the console 
data. 
 

Do Not Add Fixtures. 
 

Checking Do Not Add Fixtures will only update fixtures that 
already exist in the Rig Data. New fixtures which are in the 
imported console data, and which are not currently in the Rig 
Data will be ignored. 
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It is possible to limit the  range of channel (or fixture) numbers to update 
by entering From and To values in the respective fields. To update all 
fixtures, leave these fields empty. 
 

Mapping Imported Console data in to Rig Data. 
 
Within the Console Data, there may be multiple DMX addresses attached 
to individual channel numbers, and depending upon what console the data 
has been exported from, they may appear in different formats. Moving 
Light Assistant can handle up to 5 separate addresses per fixture for 
Fixture, Intensity, Beam, Colour and Supply.  
Before Moving Light Assistant can successfully transfer information from 
imported Console Data in to Rig Data, the various imported DMX 
addresses must be mapped  to the correct DMX address fields in Rig Data.  
 
Additionally, to gain full advantage of the fixture information contained in 
the fixture library, the imported fixtures must also be mapped on to the 
corresponding fixtures in the library. 
This mapping is done by creating a console fixture profile for each fixture.    
 
For more information, refer to ‘Console Fixture Profiles’ in Console Data. 
 
 

Rig Data Columns. 
 

 
Columns Toolbar Button. 

 
The Columns toolbar button allows you to change which columns are 
displayed in the Rig Data view spreadsheet, and the order in which they 
appear. 
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Rig Data Columns Dialog 

 
 
On the left is a list of all the possible Available Columns. On the right are 
the columns you wish to display. The Displayed Columns will be populated 
with the columns that are currently displayed. You can add columns to the 
Displayed Columns list by clicking and dragging a column name from the 
Available Columns list to the Displayed Columns list. Alternatively, you 
can select a column name in the Available Columns list and click the Add 
button in the middle. Clicking the Add All button will add all the column 
names to the Displayed Columns list. 
 
You can re-order the displayed columns by clicking on a column name in 
the Displayed Columns list and dragging it to the position in the list you 
desire. 
 
The Remove button will remove the selected column name in the 
Displayed Columns list and return it to the Available Columns list. It is not 
possible to remove the Channel column name from the Displayed Columns 
list. 
 
The Remove All button will remove all the column names from the 
Displayed Columns list except for the Channel column name. 
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It is possible to store your favourite choice and order of displayed columns 
to allow quick and easy switching of the columns which are displayed in 
the Rig Data spreadsheet. After you have chosen and ordered your 
column names, click the ‘+’ button at the bottom of the dialog and give 
this selection of columns a name. You can then access this selection from 
the Custom drop down menu. To remove a column selection from the 
Custom drop down menu, click the ‘-‘ button and a dialog will appear that 
allows you to chose the name of the column layout you wish to remove. 
 
The Default Widths checkbox will reset the columns to the default column 
widths when you dismiss the dialog by clicking on OK. Column widths 
themselves may be dragged to any size you wish by dragging the column 
heading divider lines in the Rig Data view. 
 

Standard Column Definitions. 
 
There are 44 ‘standard’ columns and 6 user definable columns available 
within Rig Data. 
While some of the column’s are extremely obvious, others are more 
obscure, and may potentially have  multiple uses other than their 
intended use. 
 
Here is a list of columns and their intended use: 
 
Accessory 
 

A text field for anything that is added to a lighting fixture which is 
not a core feature of the fixture itself. For example, barn doors, top 
hats or iris’s. 

 
Address 
 

The base DMX address of a DMX fixture. Data must be in the format 
set in the File->Preferences->DMX format menu. If the fixture uses  
a DIP switch to set the address, double clicking the Address cell will 
popup an image showing the DIP switch with the correct switch 
settings. 

 
Channel 
 

A numeric field for the control channel number by which a lighting 
console controls individual fixtures. Decimal numbers are not 
supported. 
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Beam Address 
 

The DMX address for a beam changing device attached to, or part of 
a fixture where beam control is not part of its core functionality. For 
example, a DMX iris on a conventional fixture. Data must be in the 
format set in File->Preferences->DMX format. ‘Has External Beam 
Control’ must be checked in the Manage->Fixture Profiles Library 
menu for the fixture in question for the field to be active. 
 

 
 
Baffle 
 

A text field for describing an acoustic or sound baffle associated with 
a fixture. 

 
Option Bay 1 
 

A text field for describing drop in modules in modular lighting 
fixtures. Defined in the menu manage->fixture profiles. 
For example, an ETC Revolution has drop in shutter, iris and gobo 
modules. Can be selected at the time of adding the fixtures, or 
subsequently edited in the Rig Data spreadsheet. 

 
Option Bay 2 
 
 As Option Bay 1. 
 
Case Colour 
 

A text field describing the physical colour of a lighting fixture. 
 
Colour Address 
 

The DMX address for a colour changer attached to, or part of a 
fixture where colour control is not part of its core functionality. For 
example, a scroller on a conventional fixture, or a scroller attached 
to a lighting fixture which may already include internal colour 
changing. Data must be in the format set in the menu File-
>Preferences->DMX format. ‘Has External Colour Control’ must be 
checked in the menu Manage, Fixture Profiles Library for the fixture 
in question for the field to be active. 
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Circuit 
 

A text field to describe the electrical circuit powering a fixture. (See 
also, Multi-core and Multi-core way.) 

 
Console ID 
 

A text field for use where a console refers to fixtures other than via 
unique channel numbers. For example, a Whole Hog 2 can refer to a 
MAC2000 number 1, and a VL3500 number 1. 
 

Console Fixture Profile 
 

The fixture profile name used by the console when patching the 
fixture. May be derived from Rig Data. 

 
Filter 
 

Colour in a conventional lighting fixture, or applied additionally to a  
colour changing fixture. For example, colour correction applied to 
the front of a moving light fixture. This is not the place for 
describing a colour wheel in a moving light. 

 
Fixture Type 
 

The name of a lighting fixture as defined in the menu Manage-
>Fixture Profile Library, and chosen using ‘Add Fixtures’ 

 
Fixture ID 
 

A text field for a unique fixture reference number or other form of 
ID, maybe used as part of stock or inventory control. 

 
Fixture Number 
 

A number for identifying a fixture as an alternative to a channel 
number. 

 
Fixture Options 
 

Displays ‘Default’ or ‘Custom’  depending on whether the fixture 
menu or DIP options are the manufacturer defaults, or cutom user 
settings.. 

 
Frost 
 



52	
   MOVING	
  LIGHT	
  ASSISTANT	
  
 

Frost in a conventional lighting fixture, or frost applied additionally 
to another fixture. For example, frost taped to the front of a moving 
light fixture. This is not the place for describing frost in a colour 
wheel in a moving light. 
 

 
Gobo / Colour Load 
 

A field for the name of the gobo and colour load a fixture has 
installed. Intended to correspond with the load names used in the 
Wheel Loads section of Moving Light Assistant. 

 
 
Gate Gobo 
 

A single gobo in a conventional profile lighting fixture. This is not the 
place for describing gobos in a moving light gobo wheel. 

 
Mounting 
 

A text field describing how a fixture is rigged. Pre-defined options 
are: Hanging, Floor, Over Rigged, Vertical Left, Vertical Right, 
Vertical Front and Vertical Back. Can only be edited in the Rig Data 
spreadsheet 

 
Intensity Address 
 

The DMX address for a fixture which has an external dimmer, or 
other means of intensity control. Most commonly used for tungsten 
moving light fixtures which require an external dimmer. 
Data must be in the format set in the Menu Preferences->DMX 
format menu. ‘Has External Dimmer’ must be checked in the menu 
Manage, Fixture Profiles Library for the fixture in question for the 
field to be active. 
 

 
Instrument Type 
 

Included for compatibility with Lightwright. Lightwright defines 
Instrument types where as Moving Light Assistant defines Fixture 
types. The terms are generally interchangeable. 

 
Internal Lens 
 

A text field to document any internal lens a fixture may optionally 
have. E.g., a wide angle lens, or a condenser lens. Defined in the 
menu Manage->Fixture Profile Library. 



MOVING	
  LIGHT	
  ASSISTANT	
   53	
  
 

Lamp 
 

The lamp (sometimes called bulb or bubble) within a fixture. 
Lamp options for each fixture are defined in the menu Manage-
>Fixture Profile Library, and chosen at the time of adding Fixtures, 
under ‘Add Fixtures’ ‘Optical’ tab. 
The lamp type may be edited directly in the Rig Data spreadsheet. 

 
Lens 
 

The Front Lens of a fixture, where this is changeable. For example,  
a clear, stipple or lenticular lens in a Vari*lite VL5. Defined in the 
menu Manage->Fixture Profile Library. 
  

 
Location x 
 

The physical position of the fixture in the x axis (on and off stage), 
typically measured to a down stage centre reference point, used in 
WYSIWYG visualisers. 

 
Location y 
 

The physical position of the fixture in the y axis (up and down 
stage), typically measured to a down stage centre reference point, 
used in WYSIWYG visualisers. 
 

 
Location z 
 

The physical position of the fixture in the z axis (above or below 
stage level), typically measured to a down stage centre reference 
point, used in WYSIWYG visualisers. 
 

 
Label 
 

A field for use where a lighting console allows descriptive text to be 
attached to channel numbers. 

 
Match Flag 
 

Is included for compatibility with Lightwright. A Boolean value (True 
or False) used by Lightwright when exporting data to CAD packages. 
TRUE indicates a fixture in Lightwright can be matched with a fixture 
in the CAD drawing. FALSE indicates a fixture in Lightwright cannot 
be matched with a fixture in the CAD drawing.  
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DMX slots 
 

The total number of DMX ‘channels’ a lighting fixture uses in a given 
profile (DMX mode). Also known as a DMX footprint. For example, a 
VL2000 wash occupies 15 DMX slots in its Enhanced 16 bit DMX 
profile. This is not an editable field, but is defined in the menu 
Manage->Fixture Profile Library, under the control tab. Different 
profiles, or DMX modes are selected at the time of adding fixtures. 

 
Orientation 
 

A text field describing in which orientation a fixture is mounted. Pre-
defined options are: connector to SL, SR, US, DS, on stage or off 
stage. Display to SL, SR, US, DS, on stage or off stage. Arrow to SL, 
SR, US, DS, on stage or off stage.  It is also possible to enter your 
own text. 

 
Position 
 

A text field describing where a lighting fixture is physically rigged. 
Managed in the menu Manage->Positions. This is directly editable in 
the Rig Data spreadsheet, and may be defined at the time off 
adding fixtures. 

 
DMX Mode 
 

The DMX mode an intelligent DMX fixture is set to. DMX modes or 
profiles are defined in the menu Manage->Fixture Profile Library 
menu, and chosen at the time of adding fixtures. 
Typical examples: 3 channel mode, 8 bit mode, Enhanced 16 bit. 
 
 

Purpose 
 

A text field describing the purpose of a lighting fixture. Only editable 
in the Rig Data spreadsheet. Most commonly used to describe the 
purpose or focus of a conventional fixture, for example USL general 
cover, backlight special, door backing. 

 
Repeater 
 

A text field identifying a repeater. Typically used for moving lights 
which are powered or controlled via an external control unit, such as 
Vari*lite series 300 fixtures. Can only be edited in the Rig Data 
spreadsheet 
 



MOVING	
  LIGHT	
  ASSISTANT	
   55	
  
 

 
Repeater port 
 

A numeric field identifying which repeater port a fixture is plugged in 
to. Typically a number in the range 1 – 6. Can only be edited in the 
Rig Data spreadsheet 
 

 
Rotation x 
 

The physical rotation of the fixture in the x axis, measured in 
degrees, used in WYSIWYG visualisers.  

 
Rotation y 
 

The physical rotation of the fixture in the y axis, measured in 
degrees, used in WYSIWYG visualisers. 
 

Rotation z 
 

The physical rotation of the fixture in the z axis, measured in 
degrees, used in WYSIWYG visualisers. 

 
 
Serial number 
 

A text field containing the serial number, or any other unique 
identifier, of a fixture. Can only be edited in the Rig Data 
spreadsheet. 

 
Supply Address 
 

The DMX address controlling the hard (non-dim) power for a fixture. 
Used, for example, if a lighting fixture is powered through a relay or 
contactor which can itself be controlled by DMX.  
Data must be in the format set in the menu Preferences->DMX 
format menu.  
 

 
System 
 

Identifies which control system (usually which lighting console) a 
fixture is controlled by in large multi-console productions. Systems 
are defined in the menu Manage->Systems. 
The default is ‘main’. 
Other Examples: Audience lighting desk, Skytracker control 
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Multicore 
 

A descriptive text field identifying the name of the multi-core cable 
supplying power to a fixture. This is directly editable in the Rig Data 
spreadsheet. 
Examples: FOH 1, Back truss, FOH Spots, #3 Electric /4 

 
Multicore way 
 

A text field identifying a circuit within a multi-core cable. Typically a  
number in the range 1-6, or 1-8, depending upon the type of multi-
core.  This is directly editable in the Rig Data spreadsheet. 
 
 

Unit number 
 

A number identifying the location of a fixture within a hanging 
position. This is directly editable in the Rig Data spreadsheet. 
Decimal numbers are supported. (See also Fixture Number.) 
Provides compatibility with Lightwright. 
 

The six User Fields can be re-named in the menu File->Preferences. 
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The Rig Data Spreadsheet. 
 

Editing. 
 
Editing of cells in the Rig Data spreadsheet is handled through the Edit 
controls. 
 

 
Edit Controls 

 
The Edit controls will be enabled depending upon the data field selected in 
the Rig Data table. 
Some fields are freely editable directly from the Rig Data spreadsheet, 
whilst others will only allow options to be chosen from a drop down list. 
Other fields are not editable at all, and will only show information derived 
from the fixture profile library. 
Columns that are related to the fixture profile, DMX Profile for example, 
will only allow a choice from the popup menu, while other columns, 
Channel and Address for example, will only allow a text entry in the text 
field. A few columns will allow you to make a choice from a popup menu 
or type in text in the text field. When entering text, hitting the return key 
will enter the text to the selected fields. 
 
To edit fixture data, select the fields of the fixtures you wish to modify in 
the Rig Data table. Most edits will work with multiple fixture selections, 
but some won’t (and the Edit controls will be disabled). Then either select 
a choice from the popup menu if it is enabled, or type in the text field the 
data you wish to enter and press the return key. 
Normally after editing a fixture, the fixture selection will not change, but 
for some fields like Unit Number will select the next fixture after you hit 
the return key. 
 
DMX addresses must be entered and edited in the format set in File 
Preferences. For example, if the DMX format is set to letter with a ‘/’ as 
the separator, to enter a DMX address of 001 in DMX universe 1, you 
must enter A/1. However, even if 3 digit address mode is set, it is still 
acceptable to enter addresses with just 1 or 2 digits, and leading zero’s 
will be automatically inserted. 
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Filtering and Sorting. 
 
It is possible to modify what is displayed and the order it is displayed in 
by using the Filter and Sort controls. 
 

Filtering 
 
Filtering will change the Rig Data view to only display the fixtures that 
match the criteria set on the Filter controls. 
 

 
Filter Controls 

 
Pressing the Clear button will clear the display filter and display all 
fixtures.  
 
The popup menu at the top allows you to select type of filter to apply. 
Most of the choices in the popup menu are Rig Data column names. One 
of the special filter types is the Changed Flags choice that will alter the Rig 
Data view to only show fixtures that have Changed Flags set (so you can 
easily see which fixtures have recently been changed by an action). 
 
The combo box below the popup menu is used to specify the condition for 
the filter. For example, if you only wish to see all the fixtures mounted on 
position ‘LX 2’, set the filter type popup menu to ‘Position’, then type ‘LX 
2’ in the condition combo box and press return. For many of the Rig Data 
cell columns, the combo boxes popup menu will be populated with all the 
current fixture settings for the selection column in the filter type popup 
menu. 
 
When filtering by position, the order positions are displayed in the popup 
menu is determined in the menu Manage-> Positions. 

Sorting 
 
The Sort controls allow you to change the order in which the fixtures are 
displayed in the Rig Data view. 
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Sort Controls 

 
 
The Rig Data view will not re-sort as you make changes in the Rig Data 
view as this could lead to confusion. You can re-sort the view manually by 
clicking on the Re-Sort button. The popup menu allows you to specify the 
table column name by which the Rig Data view is sorted by. The majority 
of columns will sort alphabetically unless the column is specifically a 
number (as in the Channel column). The table will sort as soon as you 
make a choice from the popup menu. 
 

Data Change Flags. 
 
Every time an item of Rig Data is changed, Moving Light Assistant keeps 
track of who or what changed it, and can display a small coloured flag in 
the top left hand corner of the data cell concerned to show this 
information. The visibility of these flags is controlled via menu Edit->Hide 
Changed Field Flags, which will toggle their display on and off. 
All the flags can be reset by the menu Edit->Clear Changed Field Flags. 
This operation cannot be undone, and a dialog will ask for confirmation 
before continuing. 
 
 

 
Data change flag. 

 
Blue Flag. 
 

The data was changed by the user. 
 

Magenta Flag. 
 

The data was changed by imported text or Lightwright data. 
 

Green Flag. 
 

The data was changed by imported console data. 
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Cyan Flag. 
 

The data was changed by another user working on the show file 
from a computer connected via a network. 
 

It is possible to select Changed Field Flags as a display filter when viewing 
Rig Data. 
 

Undo and Redo. 
 
The majority of operations in Rig Data support Undo and Redo. 
Undo and Redo are in the Edit menu. The Undo function will reflect the 
last operation which it is able to undo, whilst the Redo function will reflect 
last function to be undone. Both Undo and Redo support multiple Undo 
and Redo operations. 
 

Printing Rig Data. 
 
Various Rig Data reports can be generated in the ‘Report Preview’ window 
by selecting different report templates. 
 
The pre-defined templates are: 
 

Instrument Schedule. 
Produces a basic Instrument Schedule. 

 
RigData_ConfigList. 

Produces a fixture configuration report detailing lens and 
wheel load options for fixtures. 

 
RigData_DipSheet. 

Produces a fixture configuration report showing DIP switch 
settings for fixtures. 

 
RigData_FixtureCards. 

Produces fixture configuration information in card label format 
suitable for laminating and attaching to each fixture. 
 

RigData_PatchList. 
Produces a simple patch list detailing fixtures, their channel 
number, DMX address and DMX mode. 
 

RigData_PatchList+Cover. 
As the above report, but with the addition of a simple cover 
sheet. 
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In all cases, upon selecting a report template, you will be given the option 
of defining a sort order and a filter to control the report generation. 
Alternatively, a check box allows you to select the same sort order and 
filter as used by the Rig Data spreadsheet. 

 

 
Rig Data Report Options. 

 
 
See the ‘Report Preview’ chapter for more information on printing reports. 
 
 

Exporting Rig Data. 
 
Rig Data can be exported to other applications such as Lightwright. 
 
The export functions are in the menu File->Export. 
 
See the relevant chapter for more details. 
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WHEEL LOADS. 
 
The Wheel Load View is where you view and edit the gobos, colours and 
effects  installed in the wheels of fixtures. It is selected by clicking on the 
Wheel Loads Tab on the ribbon toolbar, or by pressing numeric key 2 on 
the keyboard. 
 

 
 

Wheel Load View 
 
The Wheel Loads window is split into three main areas. On the left is the 
list of wheel loads, in the centre is an image of the selected wheel and the 
gobos and colours installed, and on the right is the gobo and colour 
library. There are drag handles dividing the three areas allowing them to 
be resized as necessary. 
 

Wheel Load Area. 
 
This area is divided vertically in to two halves. 
The top half Lists all the wheel loads for the fixtures in the rig which 
contain gobo, colour or effects wheels. This list of fixtures is derived from 
the Rig Data. If there are no fixtures listed in the Rig Data, this area will 
be empty. 
By default, there will be one load shown for each fixture type, and will be 
the default load for that fixture. 
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It is still possible to work with wheel loads even with no rig data present. 
Clicking the toolbar button ‘Add Load’ will create a new wheel load. (See 
Working with Wheel Loads.)  
 
It is important to understand that a fixture load defines all the wheels 
within that fixture, be they gobo, colour or effect. If just one gobo in one 
gobo wheel is changed, for example, this becomes a new load with not 
only the changed gobo, but also the unchanged other wheels. 
 
The number and type of wheels a fixture contains is defined in the 
Manage->Fixture Profiles Library menu for each fixture. 
Fixtures can be expanded to reveal their wheels, or collapsed to hide their 
wheels by clicking on the small ‘+’ or ‘–‘ button by its side (Windows OS) 
or the small disclosure triangles (MAC OS). 
 

 
Wheel Load List 

 
By clicking on a particular colour, gobo or effects wheel for an individual 
fixture type, a list of that wheel’s load will appear, and if a graphic of the 
wheel is available, it will be displayed in the Wheel Image area in the 
centre of the screen. 
There is a check box available to impose position numbers on to the 
graphic if desired. 
A text note describes from which side the wheel image is being viewed 
from. 
If the selected fixture contains more than one wheel of a particular type, 
the 3 tabs, Wheel1, Wheel2 and Wheel3  will change from wheel to wheel. 
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Wheel graphic with Gobo Wheel 1 selected. 

 
Wheel graphics are defined in the Manage->Fixture Profile Library menu 
for each fixture. 

Gobo Library. 
 
The Gobo Library occupies the right hand side of the screen and contains 
catalogs of gobos from leading gobo and moving fixture manufacturers. 
All gobo images are the copyright of the respective manufacturer, and 
reproduced with permission. 
 
Although it is called the Gobo Library, it also the central repository for 
colours, effects and animation discs. Anything that may go in a wheel of a 
fixture. 
 
Catalogs are organised by manufacturer. Gobos may be searched for 
within a particular catalog by entering either their reference number or 
their title in the search box. The Search is not case sensitive. 
 
It is not possible to search across all catalogs simultaneously. 
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Gobo Library, Clay Paky Catalog. 

 
 

Working with the Gobo Library. 
 
It is possible to add, edit and delete gobos from the library using the 
respective toolbar buttons. 

 

 
Gobo toolbar buttons 

Add Gobo 
 
When the ‘Add Gobo’ toolbar button is clicked, the Add Gobo / Colour 
window is displayed: 
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Add Gobo or Colour Window 

 
This window can be used to add new colours or effects  as well as gobos. 
 
Enter the gobo or colour details in to the relevant fields. Select a catalog 
name from the drop down list, or type a new catalog name directly in to 
the box. There are options to allot unique reference numbers for up to 6 
different gobo or colour sizes. (Alternatively, some gobo manufacturers 
use the same reference number irrespective of the gobo size, in which 
case, leave the size field blank.) At least one reference number must be 
included to successfully add a gobo to a wheel. If the particular size 
required isn’t available in the drop down list, enter a new size in to the 
size field, alternatively, leave the size field blank. 
 
Adding Gobo Graphics. 
 
The lower half of the Gobo Library window allows you to import an image 
of the gobo, or a colour swatch of the colour. 
 
Click the ‘Choose’ button to open a browser window and select an image 
file for the gobo. Alternatively, images can be dragged from other 
applications, or a web site, directly in to the image area. Image files 
supported are jpeg, png or bitmaps. 
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There are three check boxes which control how the  image is displayed 
within the gobo wheel positions. They are useful in instances where the 
shape or size of the graphic does not match the shape or size of the gobo 
slot, importing a circular gobo image in to a vari-lite trapezoidal gobo flag 
for example. 
 
Full Field 
 
Checking ‘Full Field’ will take a gobo image that by default doesn’t fill the 
entire gobo field area and expand the image so that it does. 
 

    
  Default    Full Field Checked 

 
 
Square Image 
 
This should be checked if a gobo image is square, not round, and affects 
how the image is displayed within the gobo field area. 
 

     
Square Gobo   Default  Square Image Checked 
 
It is sometimes necessary to select both Full Field and Square Image to 
get the gobo image to display correctly within the gobo wheel. 
 
 
 
Import Source Resolution. 
 
This box is unchecked by default. 
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When this box is unchecked, all imported images are scaled to a standard 
resolution of 200x200 pixels, which provides a good compromise between 
visual appearance and overall file size. 
 
When this box is checked the image is imported at its native resolution. 
No scaling is performed. This is useful when importing images with lots of 
very fine detail, or when building effects or animation disks, which will 
typically be as big as an entire gobo wheel, without losing image 
resolution. The down side is that high resolution images can lead to very 
large gobo library file and show file sizes. 
 
For general gobo images, it is recommended to leave this box unchecked.  
 
When all the gobo information has been entered, click ‘Add’ to add the 
gobo to the library. 
 
 

Deleting Gobos 
 
Selecting a gobo in the gobo library and clicking on the ‘Delete Gobo’ 
toolbar button will delete the gobo from the library, and from any wheels 
in which that gobo was installed. A warning window will ask for 
confirmation. Click ‘Delete’ to confirm. 
 

Editing Gobos 
 
Selecting a gobo in the gobo library and clicking on the ‘Edit Gobo’ toolbar 
button will allow the gobo details to be edited. The gobo edit window is 
the same as the gobo add window.  Click ‘Update’ to accept the changes. 
Double clicking on a particular gobo in the library will also enter the edit 
mode. 
There is a time stamp in the lower left hand corner of the edit window 
showing when the gobo or colour was added, or last edited. 
 

Gobo Catalog Conflicts and Updates. 
 
As gobos are created and edited, the users Gobo Library is updated with 
the latest changes. If a show created by another user is opened, any new 
gobos in the show file will be added to the users Gobo Library. If a gobo 
exists in both the users Gobo Library and the show file, then a gobo 
conflict may occur, and the following window will be displayed: 
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Gobo Conflict Window 

 
Choose which of the conflicting gobos to keep, either the gobo in the 
existing Gobo Library, or the gobo used in the show file. Both gobos 
include a time stamp to enable you to see which is the most recent 
version. By default, the gobo with the most recent time stamp will be 
imported in to the library, over writing the previous version if necessary. 
There is a check box to apply the chosen action to all future gobo 
conflicts. 
 
From time to time new Gobo Libraries may be made available. These can 
be imported via the File->Import->Gobo Library menu. 
Gobos in the new library will be added to the users existing library. Any 
gobos that already exist in the library will trigger a gobo library conflict. 
 

Working With Wheel Loads. 
 
Gobo, Colour and Effects wheels are initially presented with their ‘default’ 
loads as defined for each fixture under the Gobos tab in the Manage-> 
Fixture Library Profiles menu. 
 
If no custom gobos or colours are to be used it may not be necessary to 
make any changes to these default loads. If changes need to be made to 
the default loads, then custom wheel loads will need to be created. 
 
Wheel loads can be created, deleted, copied and renamed using the Wheel 
Load toolbar buttons. 
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Wheel Load Toolbar Buttons 

 

Add Load 
 
Clicking on ‘Add Load’ results in the Add Load window being displayed: 

 

 
Add Load Window 

 
Enter a name for the new load, and select the fixture manufacturer and 
the fixture type from the drop down lists. Finally, select an existing load to 
copy the new load from. 
The new load will be created and displayed in the left hand wheel load 
area. It may then be edited to your requirements. 
 

Delete Load 
 
With an existing load selected in the left hand wheel load area, Clicking 
‘Delete Load’, will delete the load, after confirming your intent. 
 

Copy Load 
 
With an existing load selected in the left hand wheel load area, clicking 
‘Copy Load’ will prompt for a new name for the copied load. The new load 
will be created and displayed in the left hand wheel load area. It may be 
edited to your requirements. The copied load will be of the same fixture 
type as the original load. 
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Rename Load 
 
With an existing load selected in the left hand wheel load area, clicking 
‘Rename Load’ will prompt for a new name for the load.  
 

Editing Wheel Loads. 
 
With a particular wheel selected in the upper left hand wheel load area, 
gobos or colours can be dragged directly from the Gobo Library in to the 
various wheel positions. The wheel load list in the lower left hand area will 
be updated accordingly. 
 
If the gobo has a size specified, this will only work if the gobo size 
matches the gobo aperture size in the wheel. 
 
For example, it is possible to drag a Martin 43036004 ‘Flames’ Gobo in to 
a MAC 700 gobo wheel because although the 43036004 gobo is E size, the 
gobo is also defined within the Gobo Library as a 43076067 Martin 
(27.9mm) size, which is the correct size for the gobo wheel. 
 

 
Two different sizes 

 
It is not, however, possible to add a Martin 43035016 ‘Soft Breakup’ gobo 
to the wheel as this gobo is only defined as E size in the Gobo Library, the 
wrong size for this wheel. 
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If a gobo has no defined sizes within the Gobo Library, it may be dragged 
in to any size gobo position. 
It is never possible to drag a gobo or colour in to a wheel position defined 
as ‘open’ for that fixture within the Manage->Fixture Profile Library menu. 
 
 
It is possible to edit a gobo or colour by typing the reference  number 
and/or the catalog name directly in to the wheel load list. Individual gobos 
or colours can be removed from the wheel by deleting the reference 
number and pressing the Enter key. Gobos can be moved from position to 
position within the wheel by dragging the position number in the wheel 
load list. 
 
A standard or default gobo wheel, with standard gobos loaded in standard 
positions will show the gobos in the wheel load list in standard type face. 
Standard gobos, but in non-standard positions will be shown in italic 
typeface. Non Standard gobos will be shown in bold typeface. 
 

 
Different Typefaces. 

 

Printing Wheel Loads. 
 
The Wheel load graphic can be dragged directly in to another application 
such as a word processor document. 
 
Alternatively, Wheel Load reports can be generated in the ‘Report Preview’ 
window by selecting the WheelLoad_list or WheelLoad_ListWithImages 
templates. 
 
See the ‘Report Preview’ chapter for more information on printing reports. 
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PRESET DOCUMENTATION. 
 
The Preset Documentation view is for documenting preset or palette data 
relating to a show. It is selected by clicking on the Preset Documentation  
Tab on the ribbon toolbar across the top of the screen, or by pressing 
numeric key 3 on the keyboard. 
 
 

 
Preset Documentation main window. Preset View. 

 
Preset documentation can be viewed in two ways, Preset View or Fixture 
View. The two ‘View’ toolbar buttons select the view. 
 

 
View Toolbar Buttons. 

 
Preset View lists all the presets (Palettes), and the fixtures in those 
presets. Fixture View allows individual channels or fixtures to be selected, 
and all the presets that involve that channel will be shown. Both views will 
display relevant photographs and graphics where available. It is only 
possible to edit data in the Preset View, not in the Fixture View. 
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Fixture View is particularly useful when swapping out fixtures and knowing 
which presets will need to be checked and updated. 
 

Working in Preset View. 
 
The Preset View screen is divided in to three areas.  
 
On the left is a list of all the presets. Individual presets maybe selected 
here. 
In the centre are photographs and notes relevant to the selected preset, if 
available, along with explanatory text notes. 
On the right is a list for channels in the preset, with relevant information 
for each fixture.  
 
There is a horizontal drag handle to change the relative sizes of the left 
hand preset list and central and right hand photographs and channel list 
areas. 
 
 

Preset List. 
 

 
Preset List  

 
The preset list contains a list of all the documented presets or palettes in 
a show. There are five columns of information: Type, ID, Name, Cue and 
Set. The headings may be dragged to change their widths. 
Type, ID and Name are either imported from console data, or added 
manually. See Add Presets for more information on these fields. Cue and 
Set can only be entered manually in the central ‘Preset’ information area 
below the image. 
 
Type, ID, Name and Cue can also be edited directly in the preset list by 
double clicking on the relevant cell. Exercise caution when editing these 
fields when the preset data has been imported from console data, as 
obviously the preset data will no longer tally with the console data. 
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A Tick adjacent to the preset name indicates the update status of the 
fixtures in that preset. A grey tick indicates that some, but not all fixtures 
within the preset have been updated (‘Focussed’). A green tick indicates 
that all the fixtures within the preset have been updated. This status 
information is derived from the ‘Focused’ check box against the fixtures in 
the Channel List area. 
 
In the bottom left hand corner of the Preset List, an ‘Order by’ button 
allows the list to re-ordered by Preset ID, Focus Cue, Set or Focussed. 
 

Photographs. 
 
The centre area of the screen displays any photographs or images 
associated with the selected preset. Images may be added and removed 
from presets, edited and zoomed using the buttons below the image area. 
 
For more information on Photographs and Images, see Adding 
Photographs and Images and Working with Photographs. 
 

Preset Information. 
 
The Preset Information area is in the centre of the screen, below the 
image area. 
 
Preset information is additional information about a preset which is not 
available from imported console data. 
 

 
Preset Information 

 
The ‘Focus Cue’ field is a cue which best shows the selected preset. If 
console data has been imported and a cue list is available, select a cue 
number from the drop down list of cues, or alternatively, enter a cue 
number by typing directly in to the Focus Cue box. 
 
If a set has already been defined for a cue in Cue List view, when that cue 
is selected as a Focus Cue, the corresponding Set information will 
automatically be added in Preset Documentation. (To enable this 
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functionality, the Main Cue List or Sequence must first have been defined 
in File->Preferences->Console.) 
 
The ‘Set’ drop down list allow you to document any scenery that is 
required to update the selected preset. Either select an existing piece of 
scenery from the list, or enter a new scenic piece. 
 
‘Notes’ is a text area which allows free entry of any relevant notes 
regarding the preset. 
 
The ‘Ignore’ check box, when ticked, will stop the selected preset from 
being printed when Preset Reports are generated. The selected preset will 
be dimmed in the Preset List when it is being ignored. 
 

Channel List. 
 

 
Channel List 

 
The right hand side of the screen shows a list of the channels within the 
selected preset. Information displayed in this list includes Channel 
Number, Fixture Number, Fixture Type, Notes, Focus Cue, Image Number 
and check boxes for ‘Focussed’ and ‘Auto’. 
Channel, Fixture and Fixture Type information is either entered manually 
or derived from console data. See ‘Add Channels’. 
‘Notes’ and ‘Focus Cue’, along with the two check boxes, can be entered 
and edited directly in the Channel List. 
 

• Notes. 
 
A short text note to describe the individual fixture. 
 

• Focus Cue. 
 
Enter a cue number that is best used to focus the fixture. 
Alternatively a toolbar button can set this to be the first cue in 
which that fixture is used (Intensity above zero), as derived 
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from console data. 
 

• Focussed Check Box. 
 
Use these check boxes to keep track of your progress whilst 
updating (‘Focussing’) the fixtures within the preset. As each 
fixture is updated, tick the relevant check box. When some, 
but not all, the fixtures have been updated a grey tick will 
appear next to the preset name in the preset list. When all the 
fixtures have been updated, the tick will turn to green. A 
toolbar button exists to clear the focus state of either 
individual presets, or all presets within the show. 
 

• Auto Check Box. 
 
A tick in this box will determine if the channel is to have its 
photo taken if the automated photograph taking function is 
used. (To be implemented.) 
 

• Image. 
 
Each preset can have up to 4 images associated with it. 
Alternatively, individual channels can have a single unique 
image associated. The image number shows which image is 
relevant to the particular channel. If a Channel image exists 
for that channel, ‘CHAN’ will be displayed. See Preset and 
Channel Images. 
 

Clear Focussed and Set First Used Cue Toolbar Buttons. 
 

 
Toolbar Buttons. 

 
Two toolbar buttons are relevant to the Preset Documentation Channel 
List. 
 

Clear Focussed. 
 
The ‘Clear Focused’ toolbar button allows you to clear the focus state of 
the fixtures of either the selected preset, or the entire show 
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Set First Cue Used. 
 
The ‘Set First Cue Used’ toolbar button will populate the ‘Focus Cue’ field 
with the first cue number where the selected channel or channels are 
above zero intensity. It is possible to apply this function to single or 
multiple fixtures, selected Preset or all Presets simultaneously. 
 
To use this functionality, the Main Cue List must be specified under the 
‘Console’ tab in the File->Preferences menu. 
 

 
Main Cue list in Console Preferences. 

 
 

Adding and Deleting Presets and Channels. 
 
Preset information can added from imported console data, or if this is not 
available, maybe entered manually. Preset information can only be added 
in Presets View, not Fixture View. 
 
Four Toolbar buttons allow adding and deleting Presets and Channels 
within presets. 
 

 
Preset Toolbar Buttons. 
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Add Presets. 
 
Clicking on the ‘Add Presets’ button will bring up the following window: 
 

 
Add Preset Window. 

 
Presets may be added manually, or from console data. 
 

Manually Create Preset. 
 
Select ‘Manually Create Preset’. 
 
Enter a Preset Type from the drop down list, or enter a new type. New 
preset types entered will be available in the drop down list for later use. 
Suggested preset types include Pan&Tilt, Beam, Edge, Colour etc. 
 
Enter a unique number for the Preset ID. Decimal numbers are accepted. 
A suggested numbering scheme could be x.y, where x is a number 
representing the Preset Type, and y is a unique number. For example, if 
you had 7 beam presets, they could be numbered 5.1 to 5.7 
 
Enter a name for the Preset. 
Any descriptive name you choose. 
 
Generally, the preset type and number should follow the convention used 
by the control console in use, whilst the preset name should match the 
name entered in the console. 
 
Click ‘Add’ to create the new preset (s). The preset will be added to the 
preset list. 
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Create Preset from Console Data. 
 
If console data has been imported, Moving Light Assistant can extract 
preset information automatically from that data. 
 
Select ‘Add from console data’ 
 
In the Preset Type drop down list, select the type of preset to be added.  
 
A list of all the available presets of that type will be shown. If some 
presets have already been imported or manually added in to Preset 
Documentation, there is a check box to only show new (undocumented) 
presets. 
 
Using the check boxes against each preset, select the presets to import. 
Alternatively, use the ‘All’ or ‘None’ button to select all and clear all. 
 
If you wish to import a list of all the channels that relate to each preset, 
check the ‘Add Channels’ check box. This is the default operation. 
 
Click ‘Add’ to create the new preset (s). The presets will be added to the 
preset list. 
 

Delete Presets. 
 
The ‘Delete Presets’ toolbar button will delete the selected preset, after 
confirmation. 
 

Add Channels 
 
Once presets have been entered, or imported, the relevant channels need 
to be added to the presets, unless they have been automatically imported 
with the preset data. 
 
Clicking the ‘Add Channels’ tool bar button will bring up the following 
window: 
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Add Channels Window. 

 
Just as with presets, channels may be added manually, or from console 
data. 
 

Manually Add Channels. 
 
Select ‘Manually Add’ 
 
Select a channel or range of channels to be added. Although it is possible 
to enter any range of channels, only those channels that exist in the rig 
data will be added. If required, enter a range of fixture numbers. 
Alternatively, if the fixture number is the same as the channel number, 
check the box ‘Fixture number is same as Channel’. 
 
Select the fixture type from the drop down list, or type in a new fixture 
type. Alternatively you can set the fixture type from the rig data, or from 
the console patch data by checking the appropriate boxes. 
 
Click ‘Add’ and the channels will be added to the selected preset. 
 

Add Channels from Console Data. 
 
If Console data has been imported, Moving Light Assistant can extract 
channels used in presets automatically from that data. 
 
Select ‘From Console Data’. 
 
Click ‘Add’ and the channels will be added to the selected preset. 
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Delete Channels. 
 
The ‘Delete Channels’ toolbar button will delete the selected channel, or 
range of channels from the selected preset, after confirmation. 
 

Adding Photographs and Images. 
 
The buttons below the central image area control the taking of, adding, 
deleting, zooming and editing photographs and images. Images can be 
attached to presets as a whole, as well as to individual channels. The 
‘Preset’ and ‘Channel’ radio buttons determine whether the image 
currently displayed is a Preset Image or a Channel Image. (See Preset 
and Channel Images.) 
 
Up to four images may be added to each preset, and an unlimited number 
of channel images, up to the number of channels in the preset. Only one 
channel image can be attached to any one channel. If more than one 
preset image is available for the current preset, the left and right arrow 
buttons will step through the multiple images. 
 
 

 
Image Control Buttons. 

 
Clicking the ‘+’ button will open a file browser window to select a 
photograph or image to add. Files must be in jpeg or png format. If 4 
images have already been attached, the ‘+’ button will be greyed out and 
it will not be possible to attach any more photographs until an existing 
photograph has been removed. 
 
Clicking the ‘-‘ button will delete the current image from the show file. 
Confirmation will be requested before the operation completes. 
 
Clicking on the Camera button will take a photograph using the attached 
camera and add it to the show file. See Taking Photographs for more 
information.  
 
The ‘Preset’ and ‘Channel’ radio buttons determine whether the image is 
added as a Preset Image or a Channel Image. To be added as a Channel 
Image, a channel must first be selected in the channel list.  
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Whilst navigating through the channels in channel list, the image mode 
defaults to Preset. To remain in Channel Image mode, hold down the Alt 
key whilst using the cursor keys, or mouse, to step through the channels. 
 
The channel list shows the number of photographs available for each 
channel within a preset. ‘CHAN’ represents a Channel Image. 

 
Channel List. 

 

Preset and Channel Images. 
 
Within Preset Documentation, photographs and images can be defined as 
either ‘Preset Images’ or ‘Channel Images’. 
 
A Preset Image shows the focus of 2 or more fixtures together on the 
same photograph. Graphics overlaid on the photograph may show the 
purpose of individual fixtures within the preset. 
 

 
Preset Photo Example. 

 
A Channel Image is a different photograph and accompanying graphics, 
generally showing the purpose of just one fixture within the preset. It is 
generally a different photograph to a general preset photograph, and one 
which better shows the focus of a particular fixture. 
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Channel Photo Example. 

 
In the example above, the preset image shows the focus of 3 fixtures, 
channels 5, 15 and 14, which work together forming a corridor of light 
along the floor. Within the same preset, channel 69 projects a moon gobo. 
Whilst all 4 fixtures share the same preset, channel 69 performs a unique 
purpose within the preset, and there is no 1 photograph which clearly 
shows the purpose of all fixtures. For this reason, channel 69 has a 
channel preset photograph.  
 

Copying Images between Presets and Channels. 
 
With both a preset and a channel selected, the Copy button will be 
functional, and allows images to be copied between preset and channel. 
 

 
Copy Image Options 

 
• Copy whole Preset Image to Channel. 

 
Takes the entire image associate with a preset, photograph and any 
overlaying drawing and text, and copies it to the individual channel, 
or group of channels. 
 

• Copy only Preset photo to Channel. 
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Copies just the Preset Photograph, not the drawing and text, to the 
individual channel, or group of channels. 
 

• Copy only Preset Drawing to Channel. 
 
Copies just the drawing and text, not the under laying photograph, 
to the individual channel, or group of channels. 
 

• Copy Channel Info/Images to Channels. 
 
With a target channel, or range of channels selected, this option will 
copy information form a source channel. Selecting this option brings 
up the following window. 

 

 
Copy Channel Info Window. 

 
Enter the source channel or fixture number and select which 
information you want to copy to the selected target channels. 
 

• Copy Channel Image to Preset. 
 
Copies a Channel image from the selected channel back to the 
selected Preset. 
 

Highlighting and Hiding Image Graphics 
 
Three toolbar buttons  allow the highlighting and hiding of graphics drawn 
on photographs. 
 

 
Toolbar Buttons. 
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For this function to work, the graphics drawn must be associated with 
channels using the ‘Channel ID’ function when editing the graphics. 
 

 
Photograph with 6 ‘pools’ of light and associated channel numbers 

 
 

 
Channels 11 & 12 selected in the Channel list and Highlighted. 

The Highlight colour can be changed using the ‘Highlight Colour’ 
Toolbar Button. 

 

 
Channel 13 selected in the Channel List and ‘Hide Others’ selected. 

 
With one channel selected in the Channel List and highlighted, or the 
other channels hidden, the up and down keyboard cursor keys will step 
through the channels and the relevant graphics.  
 

Zoom 
 
Images can be zoomed bigger by clicking on the ‘Zoom’ button, or by 
pressing ‘Z’ on the keyboard. A larger version of the photograph will open 
in a new window. If more than one photograph is available for the preset 
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they may be stepped through using the left and right arrow buttons at the 
bottom of the window.  
 
A reduced channel list is shown to the right of the photograph. If 
‘Highlight’ or ‘Hide Others’ is active on the toolbar, selecting a channel 
from the channel list will highlight or hide the appropriate graphic. The 
displayed image will change to show preset or channels images as 
appropriate. 
 
 

Working in Fixture View. 
 
 

 
Preset Documentation – Fixture View 

 
Fixture View takes all the information entered via the Preset View, and 
displays it by fixture. It does not allow the editing of any data. It is a view 
only mode. 
It is particularly useful when swapping out a fixture, and needing to see 
which focuses and presets will need to be checked and updated. 
Fixtures are selected by their Channel or Fixture number. Click ‘Display’ or 
press ‘Enter’ on the keyboard to display the preset information. 
Information displayed for the selected Channel or Fixture includes Preset 
ID, Preset Name, Cue, Set and a check box for ‘Focussed’. These are the 
same data types as Presets View. 
It is possible to change the Focussed state by clicking the check box. A 
change of state here will be reflected in Preset View, and visa versa. 
There is a drop down list to change the order by which information is 
displayed. 
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Focus Order – The order the presets are listed in Preset View. 
Preset ID – In numerical preset ID order. 
Focus Cue – In numerical order of the focus cue number. 
Set – In alphabetical order of required scenery. 
 

 
The ‘Hide Ignored’ Check Box relates to the ‘Ignore’ check box in Preset 
View. If both check boxes are ticked, the relevant preset will not appear in 
Fixture View. If ‘Hide Ignored’ is not checked in Fixture View, all presets 
will be displayed, irrespective of the ignore state set in Preset View. 
 
By selecting individual presets (by clicking on them), any images 
associated with that preset will be displayed in the Focus Notes area to 
the right hand side of the screen. I multiple images are available, they 
may be selected using the cursor buttons below the image area. 
The ‘Highlights’ and ‘Hide Others’ toolbar functions are available in this 
view. 
 

Printing Preset Documentation. 
 
Preset Images (Photographs and graphics) can be dragged directly in to 
another application such as a word processor document. 
 
Alternatively, Preset reports can be generated in the ‘Report Preview’ 
window by selecting the PresetDoc template. 
 
See the ‘Report Preview’ chapter for more information on printing reports. 
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CUE LIST. 
 
The Cue List view displays cue list information derived from imported 
console data. In addition it allows extra cue information such as notes and 
photographs to be attached to each cue. 
The Cue List screen can be enabled, via MIDI Show Control, to track the 
current console cue. 
It is selected by clicking on the Cue List  Tab in the Ribbon Toolbar across 
the top of the screen, or by pressing numeric key 4 on the keyboard. 
 

 
Cue List. ‘List’ View 

 
The Cue list can be viewed in two formats, ‘List View’ and ‘Cue View’, 
controlled by the View toolbar buttons. 
 

 
View Toolbar Buttons 

 
The main ‘List View’ screen is divided in to two areas. The left hand larger 
area of the screen is the Cue List, and displays the Cue information in a 
spreadsheet layout style, with one row per cue. Columns of information 
may be displayed or hidden as desired. The right hand side of the screen 
is the Cue Information area, where additional cue notes and photographs 
may be added, edited and viewed. 
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The Cue List. 
 
The Cue List displays all the Cue information derived from the imported 
console data. 
 
Cue information cannot be edited within this spread sheet. 
 
There are two ‘special’ columns which do not show information derived 
from the console, but indicate the presence of additional user entered cue 
information. 
The ‘Has Info’ column will show a blue circular ‘i’ icon if additional cue 
information has been entered for the cue, whilst a camera icon in the ‘Has 
Photo’ column indicates the presence of one or more photographs 
attached to that cue. 

Working with Columns. 
 
The Columns toolbar button controls which columns are displayed, and in 
which order. 

 
Columns Toolbar Button. 

 
Clicking on this button will bring up the Cue List Columns window. 
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Cue List Columns window. 

 
 
The right hand list shows all the columns currently displayed, whilst the 
left hand list displays the columns still available, but not currently 
displayed. Some columns are relevant to only one, two or all consoles, 
and the ‘console’ column in each list reflects this information. 
There are ‘Add’, ‘Add All’, ‘Remove  and ‘Remove All’  buttons to aid the 
adding and removing of columns. Columns may also be dragged from one 
list to the other. 
Alternatively, clicking on the ‘GrandMA’, ‘EOS’ or ‘Whole Hog 2’ buttons 
will automatically add all the columns relevant to that console, and 
remove any irrelevant columns. 
It is possible to include user entered cue information in  columns in the 
Cue List view. Selecting to display the columns ‘Info Act’, ‘Info Notes’, 
‘Info Scene’, ‘Info Scene Num’ and ‘Info Set’ will display the respective 
information. 
All columns can be removed with the exception of the ‘Has Info’, ‘Has 
Photo’ and ‘Cue’ columns. 
Columns can be dragged within a list to alter the order in which they are 
displayed. 
Favourite custom display layouts can be saved for easy later recall. To 
save a layout, click on the small ‘+’ button and enter a name to identify 
the layout. 
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Previously saved layouts can be deleted by clicking on the small ‘-‘ button. 
Layouts are recalled by clicking on the ‘Custom’  button and selecting the 
layout from the drop down list. 
Finally, Click OK to close the window and return to the Cue List view.  
 
The Cue List spreadsheet display will now show the selected columns. 
Columns may be re-sized by dragging the column headers. There are 
scroll bars for moving around the spreadsheet in the usual fashion. 
 

Adding Cue Information. 
 
With a cue, group of cues or range of cues selected, additional ‘Cue 
Information’ can be entered in the Cue Information area on the right hand 
side of the screen. 
To select a cue, simply click anywhere on the relevant spreadsheet row. 
Groups of cues may be selected by clicking rows with the CTRL key 
depressed, a range of cues by selecting the first and last row with the 
SHIFT key depressed. Selected cues will be highlighted in yellow. 
Images can only be viewed, added or edited when a single cue is selected. 
 
Information which may be added includes: 
 

• Act number and Scene number. 
• Scene description. 
• Set. 
• Text Notes. 
• Up to four images. 

 
The Images can be zoomed bigger by clicking on the ‘Zoom’ button, or by 
pressing ‘Z’ on the keyboard. 
 
It is possible to edit photographs and draw graphics and ‘focus pools’ just 
as it is in Preset Documentation. In the Photo Edit window, the Channel ID 
drop down list will display all the channels which are active (above zero 
intensity) in the cue. Likewise, clicking the ‘Add Chan’ button can be used 
draw focus pools for all the active channels. 
 
For full details on adding images and taking photographs, see the chapter 
Working with Photographs and Images. 
 
Although Cue Information is associated with Cues, Moving Light Assistant 
does not store the information with the cue data. This means that if a cue 
is deleted from the show, although the cue information will become 
inaccessible, it will not itself be deleted. If the cue is subsequently 
recreated, the cue information will re-appear. 
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Similarly, if the console data is re-imported, maybe during the production 
process because more cues have been recorded in the console, the 
existing cue information will be retained. 

Selecting Cue Lists. 
 
It is possible your show may contain more than one cue list, although 
generally there will be only one ‘Main’ cue list. (Depending on the lighting 
console, the term ‘Sequence’ may be used instead of ‘Cue List’.) The Cue 
list to display is selected by the ‘Cue List’ toolbar button which opens a 
drop down list of all the available lists. 
 

 
Cue List toolbar button. 

 
If a particular cue list or sequence appears not to be listed, it is possible it 
wasn’t selected at the time of importing the console data. 
 
By default, the first cue list in the list will be displayed. 
 

Follow Console. 
 
It is possible for the Cue List to dynamically track the lighting console if 
the computer running Moving Light Assistant and the lighting console are 
connected using MIDI Show Control (MSC). 
 
This will generally require the use of an external USB MIDI interface. 
 
This functionality is controlled via the MSC toolbar button. 
 

 
MSC Toolbar Button. 

 
This button toggles on and off. When the button is highlighted in yellow 
MSC is on, and the cue list will tack the lighting console. 
 
With ‘Follow Console’  enabled the second line of the Cue List spreadsheet 
will be the current console cue, and will be highlighted. The top line will be 
the previous cue in the cue list. As the Cue List is following the console, 
additional Cue Information, including any photographs, will also change to 
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reflect the current cue. (Follow Console will not work if the cue 
information photograph is in Edit or Zoom mode.) 
 
 

Configuring MIDI Show Control. 
 
The MIDI Show Control is configured in the Setup->MIDI Show Control 
menu. 
 

 
MIDI Show Control configuration. 

 
In the MIDI port drop down list, select the MIDI interface to use. 

 

 
USB MIDI interface. 

 
If your MIDI interface is an external device, and it was connected after the 
configuration window was opened, it may be necessary to close the 
window and re-open it before the device is recognised. 
 
Device ID. Enter a numeric value in the rage 0-111. Each MIDI receiving 
device should have its own ID number so the controlling device (lighting 
console) can send specific commands to individual devices. 
 
Group ID. Enter 1-15, or leave as none. This value must be the same as 
the lighting console. 
 
Command Format. This should be set to ‘Lighting’, and should match the 
command format sent by the lighting console. If this doesn’t work, set the 
format to ‘All Call’. 
 
For information on configuring the lighting console for MIDI Show Control, 
refer to the console’s manual. 
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Cue View. 
 
When viewing the Cue List in Cue View mode, the display changes to 
place greater emphasis on the cue photographs. 
 

 
Cue List. Cue View. 

 
The Cue List is restricted to  just 4 lines to provide maximum screen space 
for any photographs, irrespective of how big or small the application 
window is. Additional cue information is shown to the right hand side of 
the screen. Multiple photographs can be stepped through, but no Cue 
Information  can be edited in this mode. 
 

Printing Cue Lists. 
 
Cue List reports can be generated in the ‘Report Preview’ window by 
selecting one of the various CueList report templates. 
 
Upon selecting a report format from the drop down list, the Cue List 
Report Options window will be displayed. 
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Cue List Report Options. 

 
Select the Cue List to be printed from the drop down list of Cue Lists. 
 
 

CueList_EOS report template. 
 

 
Example EOS Cue List Report. 
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CueList_MA report template. 
 

 
Example MA Cue List Report. 

 
Report templates CueList_MA 1 Image and CueList_MA 4 Images will 
produce cue list reports complete with photographs. Either just the first 
Photograph, or up to all 4 photographs if available. 
 

 
Example Cue List Report with 1 Image. 

 
Cue List Reports can run to many hundreds of pages if there are lots of 
photographs involved. This area is currently under development. 
 
See the ‘Report Preview’ chapter for more information on printing reports. 
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TAKING PHOTOGRAPHS. 
 
Moving Light Assistant supports three automated ways of transferring 
photographs from an attached camera into the application. 
 

Direct control of Camera.  
 
If you have a compatible Canon camera (See Appendix 1), or other 
supported DSLR camera, the camera shutter can be triggered directly by 
clicking on the camera button from within the application (Preset 
Documentation and Cue List). The resultant photograph will then be 
imported directly in to the application. 
To enable this functionality the camera must first be enabled in the menu 
Setup->Camera. 
 

 
Camera Setup 

 
Camera Control. Select a control module to match your make of camera. 
 
Port.  The computer port the camera is connected to. Most 

commonly USB. 
 
Device. Typically The camera make and model. 
 
Tether. Must indicate ‘Yes’ if the camera is to be remotely 

controlled by Moving Light Assistant. If the camera 
cannot Tether, Moving Light Assistant will be unable to 
control the shutter release, but the camera may still be 
able to download pictures automatically after  you push 
the shutter release manually on the camera. 

 
Session. Will display the status of the camera connection. 
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To use the camera it is first necessary to select the camera control from 
the drop down list of camera manufacturers. When the camera is now 
connected and turned on, it should appear in the list of available cameras. 
Select your camera (by clicking on its name), and then connect to it using 
the ‘Connect’ button. If the connection is successful, ‘Open’ will appear in 
the session column besides the camera. 
 
Once connected pictures may be taken and imported directly in to Preset 
Documentation or Cue List by clicking on the camera icon button.  
 
As each photograph is taken, a copy is also saved in a backup folder called 
‘cameradownloads’. This folder is created in the same folder as the Moving 
Light Assistant application when the camera setup window is opened. 
(Some cameras, when operated in ‘Tethered Mode’, do not store a copy of 
each photograph on the camera memory card. The cameradownloads 
folder may be the only repository of these photographs. Once a 
photograph has been imported in to the show file, the copy in the camera 
download folder can be deleted if required,) 
 
There is a check box option in the setup window to preview each 
photograph taken before deciding whether or not to include it in the show 
file. 
 
The Camera setup window must remain open for as long as the camera is 
required. The window will ‘float’ on top of all other windows. At the end of 
the photography session, click ‘Disconnect’ and close the window. 
 
The camera must be setup to take photographs in jpeg format. A low 
resolution will usually be adequate, and will help to keep the overall show 
file size down. 
The camera should not auto power off or go in to sleep mode, so as to be 
always available to Moving Light Assistant. 
 

Via ‘Image Watch Folder’ 
 
If you are unable to use the above method, but you do have a camera 
which can automatically transfer new photographs to your computer, you 
may be able to employ an ‘Image Watch Folder’. 
 
The Image Watch Folder is a special folder which is constantly monitored 
by Moving Light Assistant for the arrival of new files. Whenever the 
camera places a new photograph in this folder, Moving Light Assistant will 
import the photograph. The shutter release must be manually activated 
on the camera. 
The Image Watch Folder must be setup in the menu Setup->Image Watch 
Folder. 
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Image Watch Folder Setup. 

 
Click the ‘Choose’ button and browse to a folder to monitor for new files. 
If ‘Preview Image’ is selected you will have the option to preview the 
image before importing it, otherwise the image will be imported directly. 
 
For this functionality to work the Image Watch Folder window must 
remain open, and only closed at the end of the photography session. The 
folder to be watched must be chosen afresh at the start of every new 
session. 
 

Auto Photograph. 
 

 
Auto Photograph Button. 

 
Within the Cue List View, there is the ability for Moving Light Assistant to 
connect to a lighting console and automatically take photographs of every 
cue, or selected cues, in an imported cue list.  
 
The Moving Light Assistant Cue List is synchronised to the lighting console 
by MSC via a MIDI interface, and this feature must be configured. See 
Follow Console – Configuring Midi Show Control for more information. 
 
Both the ‘Follow Console’ and ‘Auto Photograph’ toolbar buttons must be 
selected to enable automatic photography. 
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Buttons Enabled. (highlighted yellow) 

 

Selecting Cues to Photograph. 
 
The ‘Auto’ column in the cue list controls which cues will be photographed. 
Check the column for each cue you want to be photographed. (If the 
‘Auto’ Column is not visible, use the ‘Columns’ button to display it). 
 
Contiguous or non-contiguous ranges of cues may be selected in the cue 
list using the CTRL  and SHIFT keys, and checking just one Auto box 
within the selected range. All the Auto boxes will be checked in the 
selected cues. 
   
To select or deselect all cues for photographing, select any cue in the cue 
list table and use the ‘Select All’ or ‘Deselect All’ commands in  the Edit 
menu. 
 
It is not possible to select individual parts of an Eos multipart cue, and the 
Auto checkbox is disabled for parts other than part 0. It is possible to take 
photographs of follow on cues. 
 
The state of the Auto checkboxes is saved in the Moving Light Assistant 
show file, and will be preserved if the show file is closed and subsequently 
re-opened. 
 
 

 
Cue List Auto Column. 
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Taking Automatic Photographs. 
 
Ensure the lighting console and Moving Light Assistant are both correctly 
configured and linked via MSC over MIDI. 
 
Ensure the camera is connected and configured for automatic shutter 
control. 
 
Select the cues to be photographed in the imported cue list by checking 
the relevant ‘Auto’ boxes. 
 
Enable ‘Follow Console’ and ‘Auto Photograph’  on the Cue List view 
toolbar. 
 
Run the cue or cues on the lighting console. 
 
The Moving Light Assistant  cue list will synchronise to the current cue on 
stage. A cue progress task bar in the Cue List view will show the progress 
of the cue based upon the cue timing information held in the show file. 
When the cue is complete, the photograph will be taken. Continue to run 
cues on the lighting console to take more cue photographs.  

 

Camera Setup. 
 
When taking automated photographs it is advisable to setup the camera   
to take photographs as fast as possible, with the minimum of delay. ‘Slow’ 
cameras may struggle to keep up in fast cue sequences, leading to 
photographs being associated with the wrong cues. 
 

• Use manual focus rather than automatic focus. 
 

• Set shutter and exposure manually, rather than automatically. 
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WORKING WITH PHOTOGRAPHS. 

Photo Edit Window. 
 
It is possible to draw graphics and text on to a photograph in both Preset 
Documentation and Cue List Views to more clearly explain what the 
photograph is showing. 
 
For example, a photograph of a lighting cue onstage can have graphics 
drawn on top to indicate the role individual fixtures have in contributing to 
the overall stage look. 
 
Photo editing is available in both Preset Documentation and Cue list views. 
The functionality is very similar within both views, with some minor 
differences. 
 

 
The Photo Edit Window. 

 
When a preset or cue photograph or image is displayed, clicking on the 
‘Edit’ button below the photograph will open the Photo Edit window. 
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Drawing Graphics. 
 
The tools down the left hand side of the Photo Edit window provide basic 
drawing functions: 
 

 
Drawing Toolbar 

 
Rectangle, oval, line and freehand line drawing tools are provided, along 
with a text insertion tool. Once drawn, the shapes may be moved to 
different locations, and dragged and rotated in to different shapes as 
required. 
 
Holding down the Shift key whilst drawing an oval or a rectangle will lock 
the aspect ratio so that a circle or square will be drawn. 
 
Holding down the Shift key whilst selecting graphics will enable multiple 
graphics to be selected at once for easy editing. 
 
With a drawn line selected, arrow heads may be added by clicking on the 
left or right arrow head buttons. The drop down menu adjusts the arrow 
head size, and the buttons determine at which ends of the line the arrow 
head is drawn. Alternatively, with an arrow head button selected, the line 
drawing tool will automatically include an arrow head. 
 

 
Arrow Head Insertion 

 
There are options to adjust the line weight and colour, along with ability to 
fill shapes with a solid colour. The Text size can be changed. 
 
Tip. Select the line colour before drawing graphics, otherwise the graphic 
will be drawn in the default colour of black, which may make it difficult to 
see against a dark photograph. 
 
Drawings on top of a photograph are stored in a separate ‘layer’ and may 
always be removed by clicking ‘Clear’. The photograph itself is not 
affected.  
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Channel ID. 
 
The ‘Channel ID’ function allows a drawn shape or text to be linked with a 
particular channel within the selected preset or cue. Select the drawn 
shape and text  to be linked and select the appropriate channel number 
from the drop down list. The channels in the drop down list are the 
channels used in the selected preset (Preset Documentation view), or 
channels above zero intensity in a cue (Cue List view). 
  
Linking graphics objects and channels allows the objects to be highlighted 
when the particular channel is selected and is useful in highlighting the 
position of particular channels within the overall preset or cue photograph. 
(Preset Documentation view only. See Highlighting and Hiding Image 
Graphics. 
 
If the ‘Select Group by Channel ID’ check box is ticked, selecting one 
object will automatically select all objects with the same Channel ID. This 
can be useful when moving ‘pools’ of light, and their respective channel 
number together. 
 

Add Channels. 
 
The ‘Add Channel’ button provides a shortcut method of adding ‘pools’ and 
channel numbers, along with automatic channel ID association, to a 
photograph. Clicking on the ‘Add Chan’ button will bring up the following 
window: 
 



106	
   MOVING	
  LIGHT	
  ASSISTANT	
  
 

 
 Adding Channels to Image. 

 
From here it is possible to automatically add channel number text and a 
‘pool’ for every channel within the preset (Preset Documentation view) or 
every channel with intensity above zero in the Cue (Cue List view). 
Alternatively, select just the channel numbers and text and pools you wish 
to include. By default, the drawn pool will be an oval. If a circle is 
required, un-check the ‘Pool is oval’ check box. Click ‘Add’ to continue. 
 
The selected channel text and pools will be drawn, ready to be dragged in 
to the correct positions. 
 

 
Automatically added channels and pools. 
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Deleting Drawn Graphics. 
 
Graphics drawn on top of photographs are held on a separate layer to the 
photograph. The photograph itself is not changed. 
 
Clicking ‘Clear’ will delete all the graphics on an individual photograph. 
This action cannot be undone and confirmation is required before the 
operation proceeds. 

Photo Adjust. 
 
Along the bottom of the Photo Edit window are sliders to adjust the 
brightness and contrast of the photograph. There is the option to change 
the photograph to greyscale. All adjustments can be reset if required. 
 
At the very bottom of the Photo Edit window there is the option to add 
descriptive text for each photograph. 
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Viewing Photographs with ‘Zoom’. 
 
Images can be zoomed bigger by clicking on the ‘Zoom’ button, or by 
pressing ‘Z’ on the keyboard. A larger version of the photograph will open 
in a new window. If more than one photograph is available for the preset 
or cue, they may be stepped through using the left and right arrow 
buttons at the bottom of the window. 
 
In Preset Documentation view, a reduced channel list is shown to the right 
of the photograph. If ‘Highlight’ or ‘Hide Others’ is active on the toolbar, 
selecting a channel from the channel list will highlight or hide the 
appropriate graphic. 
 
In Cue List view, the channel list is not displayed, and the highlight and 
hide functionality is not present. 
 

 
‘Zoomed’ Photograph Preset Documentation view. 
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CONSOLE DATA. 
 
The Console Data view provides ways of organising and inspecting 
imported console data. 
It is selected by clicking on the Console Data  Tab across the top of the 
ribbon toolbar, or by pressing numeric key 5 on the keyboard. 
 

 
Console Data Toolbar. 

 
The Buttons on the Console Data toolbar provide access to the different 
data views. The views are: 
 

• Cue Data. 
• Channel Data. 
• Preset Data. 
• Patch Data. 
• Cue Linked Commands. (GrandMA only) 
• Channel Usage. 

 
Additionally, the import log file generated when console data is imported, 
can be viewed. 
 
Before console data can be inspected, it must first be imported via the 
menu File->Import Console Data. Refer to the chapter ‘Importing Console 
Data’ for more information. Currently console data can be imported from 
GrandMA series 1, Eos Family consoles, and to a lesser extent Whole Hog 
2 consoles.  
 
The exact information which can be imported and inspected, and the 
layout of the spreadsheets, will vary depending on the console. The 
spreadsheet column headings will also vary to more closely reflect the 
nomenclature of the console. 
 
It is not possible to edit any of the displayed data. The Columns displayed 
are imported from the console data, and cannot be changed. The column 
order is locked, but their widths can be changed by dragging the 
boundaries of the column headings. 
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Cue Data. 
 

 
Console Data – Cue Data View. GrandMA Data 

 
The Cue Data View inspects all the imported channel information in a 
selected cue. 
Before any data can be displayed it is first necessary to select the desired 
sequence or cue list from the ‘Sequence’  drop down list. After selecting a 
sequence to view, select a cue number either by directly typing in to the 
data field to the left of the Sequence, or by scrolling through the imported 
cue list using the associated up and down scroll buttons. As cues are 
selected or scrolled through, the cue name will appear below the cue 
number. 
 
If desired, it is possible to filter the range of fixtures for which data is 
displayed by entering a start and end channel, or fixture number, and 
clicking ‘Apply’. 
 
To revert to displaying data for all fixtures, clear both start and end fields 
and click ‘Apply.’ 
 
Only fixtures which have data in the selected cue will be displayed. If none 
of a fixtures parameters have any data in the selected cue, the fixture will 
not be displayed.  
The number of channels in the selected cue (Whose intensity is above 
00%) is displayed at the bottom of the screen. 
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Fixture parameters which have explicit values will be displayed in a black 
type face, parameters which have ‘tracked through’ data will be displayed 
in a grey type face, other cells will be left blank if they contain no data.  
 

Show Labels (EOS) 
 
By default, preset or palette labels will be displayed in the spreadsheet. 
When viewing EOS data, it is possible to view the EOS internal preset 
identifiers (i.e. Preset 4) instead of the label by un-checking Show Labels 
(EOS). 
 

 
EOS Cue Data – Show Labels Unchecked. 

 

Highlighting Data. 
 
Different types of data can be highlighted to aid identification via a series 
of check boxes: 
 

Absolute Values. 
When this is checked any data (other than intensity data) 
which is programmed with absolute, or hard values (values 
not derived from a preset) will be highlighted in red. 
 

Absolute Intensity. 
When Absolute Values and Absolute Intensity are both 
checked, any intensity data which is programmed with an 
absolute or hard value will be highlighted in red. 
 

Live Moves and Redundant Moves 
Highlighting of live and redundant moves is only available in 
Channel Data view. 
 

The number of highlighted cells is displayed at the bottom of the screen. 
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Channel Data. 

 
Console Data – Channel Data View. GrandMA Data. 

 
The Channel Data View inspects all the imported  information for a 
selected channel, cue by cue. 
Before any data can be displayed it is first necessary to select the desired 
sequence or cue list from the Sequence  drop down list. After selecting a 
sequence to view, select a channel or fixture number, either by directly 
typing in to the data field to the left of the Sequence, or by scrolling 
through the imported list of channel/fixture numbers using the associated 
up and down scroll buttons. As channels or fixtures are selected or 
scrolled through, the channel/fixture label will appear below the 
channel/fixture number. 
 

Show All Cues. 
 
Only cues which contain explicit data for the selected channel will be 
shown by default. Such data will be shown in a normal black type face in 
the appropriate cell in the spreadsheet. Data which has tracked through 
from a previous cue (has not changed) will be displayed in grey text. If a 
cue contains no new data for the selected channel, it will not be displayed. 
To display all cues in the sequence/Cue List, irrespective of whether they 
contain new data or not, check Show All Cues. 
 

Preset Values. 
 
By default, the spreadsheet displays preset or palette labels. To display 
absolute values, as a percentage, check Preset Values. Whereas preset 
labels are ‘tracked through’ in the spreadsheet, preset values are only 
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shown for the parameters that change in a particular cue, and the value is 
not shown as tracked through. 
 

 
Channel Data as Preset Labels. 

 

 
Channel Data as Preset Values. 

 

Labels Show (EOS) 
 
By default, preset or palette labels will be displayed in the spreadsheet. 
When viewing EOS data, it is possible to view the EOS internal preset 
identifier (i.e. Preset 4) instead of the label by un-checking Show Labels 
(EOS). 
 

Highlighting Data. 
 
Different types of data can be highlighted to aid identification via a series 
of check boxes: 
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Absolute Values. 
 
When this is checked any data (other than intensity data) which is 
programmed with absolute, or hard values (values not derived from a 
preset) will be highlighted in red. 
 

Absolute Intensity. 
 
When Absolute Values and Absolute Intensity are both checked, any 
intensity data which is programmed with an absolute or hard value will be 
highlighted in red. 
 

Live Moves. 
 
When Live Moves is checked, any fixtures whose parameter values change 
while its intensity is above zero will be highlighted in cyan. 
 

Redundant Moves. 
 
When Redundant Moves is checked, any fixture which changes position ( 
or other non intensity parameter), and then changes position again 
without its intensity raising above zero, will be highlighted in magenta.  
 
The number of highlighted cells is displayed at the bottom of the screen. 
 
Care should be taken when interpreting Live and Redundant Moves. The 
identifying of either does not necessarily indicate a programming error, or 
sloppiness on behalf of the programmer. Live moves, for example, may be 
entirely intentional, or the highlighted cues part of a rig check sequence! 
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Preset Data. 
 

Console data – Preset Data View. By Preset. 
 

The Preset Data view allows the inspection of imported console preset 
data searched for either by preset, or by channel. The left hand pane 
displays a collapsible and expandable menu tree allowing the user to ‘drill 
down’ to an individual preset/ palette by either preset type or by channel. 
 
Each preset type is represented by an icon, along with its description. 
 

 
Preset Icons. 
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Preset Data by Preset. 
 
Expanding the ‘By Preset’ tree in the left hand pane will display all the 
preset types imported from the console. The number of individual presets 
of each type will be shown against each type. Further expanding a 
particular type of preset will display all the individual preset labels. 
Selecting a particular preset label will display, in the right hand 
spreadsheet, a list of channels which use that particular preset. 
 
A green progress bar at the top of the screen will show the progress of the 
data retrieval and organisation. 
 
Selecting a particular channel (so long as it is ‘used’) will display the 
sequences and cue numbers in which that preset is used by that channel. 
 

The Spreadsheet. 
 
The spreadsheet is divided vertically in to two halves. The top half shows 
all the channels which are recorded in the selected preset. The 
channel/Fixture number is displayed along with other console specific 
information. 
 
The ‘Used’  column displays ‘yes’ if the fixture has an intensity level above 
zero whilst in the selected preset. If a channel is recorded in a cue in the 
selected preset, but the intensity never raises above zero, then ‘=0’ will 
appear in the Used column.  
If the selected preset is only used in a cue defined as a rig check cue, the 
word ‘Rig’ will be displayed in grey text in the Used column. Rig Check 
cues are specified in the menu Manage->Console Data. 
 
Selecting a channel will populate the lower half of the spreadsheet with a 
list of all the sequences and cue numbers involving the selected channel 
(in the selected preset), along with associated data. The selected preset 
will be highlighted in cyan. 
 

Show Parameters. 
 
If checked, Show Parameters will display the actual parameter level, as a 
percentage for the preset parameter being displayed. For example, if a 
pan and tilt preset is being inspected, enabling Show Parameters will show 
the actual levels of the pan and tilt parameters for that channel. 
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Preset Data by Channel. 

 
Console data – Preset Data View. By Channel. 

 
Expanding the ‘By Channel’ tree in the left hand pane will display all the 
Channel/Fixture numbers imported from the console data. The number of 
presets of each type used by each channel will be shown. Expanding a 
particular channel will display the preset types used for that channel.  
 
Selecting a particular preset type will display, in the right hand 
spreadsheet, a list of all the presets of the selected type for the selected 
channel. 
 
Selecting a particular preset, so long as it is ‘used’, will display in the 
lower half of the spreadsheet, all the sequences and cues in which the 
selected channel is used in the selected preset. The selected preset will be 
highlighted in cyan. 
 
The ‘Used’ column will display ‘Yes’ if the preset is used in cues with an 
intensity above 00% by that channel. If it is used by the channel, but the 
channel intensity never raises above 00%, ‘=0’ will be displayed. If the 
channels is only used in a cue defined as part of the rig check, then ‘Rig’ 
will be displayed. If the fixture never uses the preset, the ‘Used’ cell will 
be empty. 
 
Care should be exercised in determining whether presets or sequences are 
truly not used. Depending upon the programming, it may be possible to 
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have sequences with no intensity which Moving Light Assistant may 
interpret as not being used, but in fact are.   
 

Patch Data. 
 

 
Console data – Patch Data View. GrandMA Data 

 
The Patch Data view displays all imported patch information, ordered by 
channel/fixture number. Depending upon the console, different associated 
data may be also be shown. 
The lower section of the screen is where Fixture Profiles for importing 
patch data in to Rig Data are defined. See Console Fixture Profiles. 
 

 
Console data – Patch Data View. EOS Data 
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It is not possible to display any Patch Data from Whole Hog 2 console 
data, as the Whole Hog 2 does not export patch information. 
 

Console Fixture Profiles. 
 
Console Fixture Profiles control how imported Console patch Data is 
mapped in to Rig Data when the ‘Update From Console Patch’ feature is 
used from the Rig Data toolbar. 
 
Console Fixture Profiles are created from the ‘Patch Data’  view within the 
Console Data view. 
 

 
Patch Data Button. 

 

 
Console Fixture Profiles – Patch Data View. 

 
Towards the bottom of the screen is displayed a list of existing profiles. 
Small ‘+’ and ‘-‘ buttons allow the creation of new profiles, or the deletion 
of an existing profile, whilst existing profiles can be edited via the ‘Edit’  
button. 
 

Creating a New Console Fixture Profile. 
 
Click on the ‘+’ button to create a new Console Fixture Profile. 
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Add Console Fixture Profile. 

 
Enter a descriptive name for the new profile. 
 
In the Console Fixture Profile drop down list, select the fixture to create a 
profile for. The drop down list is populated with fixtures derived from the 
imported console data. 
 
In the Number of Patch Points  field, enter the number of DMX parameters 
(‘Patch points’) for that fixture. This can be gathered from examining the 
Console Patch Data to see how many DMX addresses are patched to that 
fixtures channel number. 
 
In order to link the imported fixture type with the corresponding fixture in 
the fixture library, select the manufacturer, fixture and DMX mode for the 
fixture from the drop down lists. Ensure the ‘Assign Rig Data to Fixture 
Profile’ check box is checked. 
 
The ‘Addresses are a List’ checkbox should be checked if the fixture profile 
has multiple patch points 
 
Define the different patch points. The order and format in which the DMX 
addresses appear in the console patch data,  will vary depending upon the 
console used and the fixture profile used for patching. 
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GrandMA Console Data Patch Points. 
 

 
 

MA Console Patch Data as a list. 
 

GrandMA console patch data is presented as a list of DMX addresses, one 
after the other. In the example above, VL5’s appear with two patch points 
each. It can be surmised that the first DMX address is the external 
intensity address, while the second address is the fixture address. 
 
Check the box ‘Addresses are a list’  and enter a 1 in the Intensity field 
and a 2 in the Fixture field. 
 

EOS Console Data Patch Points. 
 

 
Eos Console Patch Data. 

 
Eos console patch data is presented as separate rows, one row for each 
DMX addresses.  
 
Check ‘Addresses are a list’  and enter the order in which the patch points 
appear in the relevant address fields. 
 
In the example above, the first row represents the fixture address, the 
second row the external dimmer and the third row the colour address. 
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Cue Linked Commands. 
 

 
Console data – Cue Linked Commands View 

 
 
This data is specific to GrandMA console data. 
 
The Cue Linked Commands view displays which executors and macros are 
referenced by cues, and in which sequences. The left hand list displays all 
referenced executors and macros. Selecting one of the entries will display 
a list of all references in the right hand list. It shows the sequence and 
cue from which the executor or macro is referenced from, and the 
complete link command from that cue.  
 
This data is useful in determining which executors are used in the show in 
the event you wish to move or delete an executor or macro.  
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Channel Usage. 
 

 
Console data – Channel Usage View (GrandMA Data) 

 
The Channel Usage view details how often a channel, or range of 
channels, is used within a given range of cues. A channel is considered to 
be used if its intensity is above 00%. The intensity level does not have to 
be explicitly programmed in a particular cue for it to be considered ‘used’. 
Tracked levels from previous cues are also counted.  
 
At the bottom of the screen a message will display how many fixtures 
have no intensity (i.e ‘are not used’) within the selected cue and channel 
ranges. 
 
A specific Cue list, or sequence can first be specified. Select the cue list to 
inspect from the drop down list. If desired, specify a range of cues, and/or 
a range of channels or fixtures by entering the start and end numbers in 
to the relevant fields. A ‘Fixture’ check box  alternates between channel 
numbers and fixture numbers. 
 
To interrogate the console data, and display the results, click the large 
‘Process’ button. A progress bar will be displayed while the console data is 
searched. 
 
The spreadsheet displays the channel and fixture number, the fixture 
type, the number of cues within the search range where the intensity is 
above 00% (‘I Cues’), the maximum intensity within the range of selected 
cues (‘I Max’), and the 1st cue within the selected range where the 
channel is used. 
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Ignore Unused. 
 
By default, if a channel is unused in the specified range of cues, it will be 
displayed with the word ‘Unused’, in red, in the ‘I Cues’ column. If 
preferred, unused channels can be ignored (not displayed) by checking 
the ‘Ignore Unused’ check box. Upon changing the state of this checkbox, 
it is necessary to click ‘Process’ for the function to take effect and the 
spreadsheet to update. 
 

Preset Check. 
 
Selecting the ‘Preset Check’ check box will examine the selected range of 
console data for Focus (Position), Colour and Gobo presets (Palettes), as 
well as Intensity information. It is necessary to click ‘Process’ for the 
function to take effect and the spreadsheet to update. 
 

 
Channel Usage – Preset Check. (GrandMA Data) 

 
The spreadsheet will now display the number of each preset type each 
fixture has within the selected cue range where the intensity is greater the 
00%. 
By selecting an individual fixture, the individual preset information will be 
displayed in the window to the right of the spreadsheet. Three tabs switch 
between Position, Colour and Gobo Presets. 

Filter By Act and Scene. 
 
If Act and Scene cue information has been entered in the Cue List view, it 
is possible to use this information as search filters. Simply select the Act 
and Scene number from the drop down lists and click ‘Process’.  The cue 
number range will be updated to reflect the Act and Scene numbers. The 
start cue number will be the first cue number corresponding to the Act 
and Scene number, the end cue number will be the last cue number 
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corresponding. All cues in between will be searched, regardless of whether 
they explicitly have the Act and Scene numbers associated with them. 

Import Log. 
 
An Import Log is maintained and updated after every Console Data Import 
operation. The log file may be viewed by clicking on the ‘Import Log’ 
button on the toolbar. The import log is always displayed by default after 
every import operation.  
 
The import log is appended to after every import operation. To clear the 
log file, click the ‘Clear’ button. 
 

 
Log File – EOS Import. 
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IMPORTING CONSOLE DATA. 
 
Moving Light Assistant can import data exported from the GrandMA (Series 
1), Whole Hog 2 and EOS lighting consoles. Below is information on how 
to export the data in the format required from each type of console, and 
then importing console data in to Moving Light Assistant. 
 

Exporting GrandMA Series 1 data. 
 

Console setup. 
 
To export the data from the GrandMA Series 1, you will need to use the 
‘Report’ command. 
 
If you don’t already have a quick key for this, you will need to create one. 
On the GrandMA: 
 

• Enter the command:  Report Channel <Enter> 
 

• A window will appear with report data. Click the ‘Save’ 
button.You will be prompted to a location to save the report 
file (tested on GrandMA OnPC). 

 
• You will find a ‘report.tar.gz’ file in the location you specified. 

 
• Save this file to a USB memory stick (or if using a virtual 

machine such as Parallels, drag it to the Mac OS Finder). 
 

• The report file is now ready for importing into the application. 
 
Note. 
 
The report.tar.gz file is an archive containing .csv ( comma separated 
value ) files. On Mac OS X you can uncompress the archive by double 
clicking on it and a folder containing the file will be extracted. It is 
possible to import these files one at a time in the application, but 
importing the archive is much faster and easier. 
 

Exporting Whole Hog 2 data. 
 
Only the cue list data can be exported from the Whole Hog 2, as a text 
file. To export the cue list data, on The Hog 2 console,  open the cue sheet 
window for a cue list and press the ‘Dump Text’ button on the tool bar at 
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the top of the window. The console will then dump the cue list data as a 
‘.txt’ file into the folder containing your show file. It will be called 
something like ‘L0.txt’. The ‘0’ will be the list number of the exported cue 
list. 
 

Exporting EOS data. 
 
To export from Ion or Eos on to a USB memory stick, load the showfile in 
to either console or the offline software. Select the Browser/CIA, then File, 
Export, CSV, select the inserted USB stick (e.g. f drive). Make sure all tiles 
are highlighted, click 'ok' and name your file. 
 

Importing GrandMA Series 1 data 
 
After creating a new show document, select File->Import Console Data-
>GrandMA. 
 
A dialog will appear that allows you to import a report archive (.tar.gz)  or 
individual report csv files. It is recommended, that unless you have a 
reason to import a single file, that importing an archive is the best 
practice. 
 

 
GrandMA Console Data Import. 

 
If you wish to import an archive, click the ‘Choose…’ button in the archive 
area. You will be presented with a standard dialog to choose the archive 
(.tar.gz) you wish to import the files from. Once you have selected the 
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archive it will be decompressed. Once uncompressed, all the files from the 
archive that the application can import will appear in the left hand table. 
Only the files listed in the right hand column will actually be imported. You 
must now select which files from the folder you wish to import. To move 
an individual file, you can simply click (to select a file) and drag it to the 
right hand column, or click the ‘Add>>>’ button. You can remove files 
from the right hand column, by clicking on the file and clicking the 
‘Remove’ button. You can add all the files by simply click the ‘Add All’ 
button. Clicking on the ‘Remove All’ button will do as you expect and 
remove all the files from the right hand column. Once you are happy with 
which files you wish to import, click the ‘Import’ button. 
 
If you wish to import a single file, click on the ‘Single File’ radio button. 
Click the ‘Choose…’ button in the single file area and then select the csv 
file you wish to import using the standard ‘Open’ dialog. Once that is 
complete, click the ‘Import’ button to start the import. At present, only 
Device, Preset and Sequence files can be imported. If you try to import 
any other type, nothing will actually be imported. Note that if you import 
a sequence file that has the same name as an already previously imported 
sequence file, you will be prompted with dialog warning that the imported 
data will overwrite the data already held in the database. 
 
Note that during the import if a sequence file has the same name as an 
already previously imported sequence file, you will be prompted with 
dialog warning that the imported data will overwrite the data already held 
in the database. Click ‘Cancel’ to not import that file. In the dialog, 
clicking the ‘Yes to All’ button will continue overwriting without prompting 
for each conflict it finds. 
 
Importing Preset and Device data will remove preset or device data of the 
same type automatically. If this has occurred it will be logged in the 
import log. 
 
There are two check boxes towards the bottom of the dialog which control 
the logging operation. 
 
Only Log Errors.   Only errors will be logged. 
Open Log after import. Will automatically open the log after the 

import is completed. 
 
During the import a progress window will appear show the progress of the 
import. Depending on the size of the show, the import may take several 
minutes. Large shows with thousands of channels can take a considerable 
amount of time. 
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Importing Whole Hog 2 Data. 
 
After creating a new show document, select  File->Import Console Data-
>Whole Hog 2. 
 
You will be presented with a file browser window to choose the .txt file 
you wish to import. If you do not create a new document and the 
database already contains the sequence being imported from a previous 
Whole Hog 2 data import, after selecting the file to import you will be 
presented with a dialog warning you that this import will overwrite the 
existing data. 
 
Click the ‘OK’ to continue with the import, or cancel to stop the import. If 
you continue with the import, the previous data for the sequence will be 
removed. 
 
If continuing with the import, Moving Light Assistant will read the channel 
numbers used in the sequence. The Whole Hog 2 sequence export file is 
not formatted with unique channel numbers, but is in the format of the 
channel number and fixture type. 
 
For example… 
 
Channel  Type 
1  VL5 
2  VL5 
3  VL5 
1  MAC600 
2  MAC600 
 
This is because the Whole Hog 2 allows identical channel numbers for 
different fixture types. Moving Light Assistant must have a unique channel 
number for every fixture, and so it is necessary to map the imported 
channels and fixture types to unique Moving Light Assistant ‘user’ 
numbers. 
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Whole Hog 2 data import. 

 
Once the channel numbers and fixture types have been read, a dialog will 
appear allowing the user to enter the user numbers manually. 
 
Double click on a cell to enter the user number. Pressing <Return> will 
move to the next cell. Channels that are not assigned will be highlighted 
in red (a value of 0). Channels must be assigned a unique User Number. 
Any channels not assigned will not be imported. 
 
Once user numbers have been entered, click OK to proceed with the 
import. Click ‘Cancel’ if you wish to abort. The user numbers will be 
remembered for further imports in this show document. 
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Importing EOS Data. 
 
After creating a new show document, select  File->Import Console Data-
>EOS CSV.  
 
You will be presented with a dialog to choose the .csv file you wish to 
import. If you do not create a new document and the database already 
contains data from a previous EOS data import, after selecting the file to 
import you will be presented with a dialog to decide on how to import the 
data. 
 
You have two options, Replace or Merge. Replace will remove all the 
previously imported EOS console data and then import the new data. 
Merge will remove only the data types present in the imported file. For 
example if the imported file contains only cue data, then only the cue data 
will be deleted from the database. 

 
Console Data – Replace or Merge.
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REPORT PREVIEW. 
 
Report Preview provides the means to preview and print reports from 
Moving Light Assistant.  
 
It is selected by clicking on the Report Preview Tab across the top of the 
ribbon toolbar, or by pressing numeric key 6 on the keyboard. 
 
Reports may be either printed to a connected printer, or saved as a pdf 
document using the incorporated pdf generator. 
 

 
Report Preview – Main Screen. 

 
 

The report to be generated is selected from the ‘Report’ drop down list.  
 
This contains a list of all the available report templates to choose from. 
Report templates may either be embedded in the show file, prefixed 
‘Show’, or be resident on the user’s computer, prefixed ‘File’. 
 
For layout files to be present in the File- list they must be stored in the 
‘Report Layout Templates’ folder in the application folder. 
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Select Report. 

 
If the chosen report is based upon Rig Data or Cue Lists, Moving Light 
Assistant provides options to print a full report containing all the data, or 
a smaller report containing a chosen sub set of data. 
 

Rig Data Report Options. 
 

 
Rig Data Report Options. 

 
Specify in what order the data is to be reported. For example, by channel 
number if a channel hook-up or patch is required, or by position if an 
instrument schedule type report is required. 
 
Optionally, a filter may be applied so that only data matching the filter 
criteria will be output. For example, filter by position and select ‘FOH 
truss’, or filter by fixture type and select ‘VL3500Q spots’. 
 
If a filter is not required, select ‘Show All’. 
 
Alternatively, it is possible to use the current Rig Data views sort and filter 
options. 
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Cue List Report Options. 
 

 
Cue List Report Options. 

 
Select a particular cue list or sequence to print. 
 
The check box ‘Report only cues with Info/Photo  is self explanatory. 

 
By default, when a report is produced that includes cue photographs, 
space is left on the page for photographs regardless of whether or not a 
photograph, or photographs, exist for that cue. This can lead to a lot of 
empty ‘dead’ paper space. 
 
With ‘Compact Empty Row Images’ checked, this dead space is removed, 
so that consecutive cues with no associated photographs are printed on 
consecutive rows. 

Preset Documentation Reports. 
 
Preset documentation reports produced as pdf files will be produced as 
individual pdfs, one pdf per preset. After all the pdf’s have been generated 
you will be prompted for a location in which to save them. They are 
written to a folder named ‘Preset Documentation PDF Folder.’ 
 
If desired, a third party pdf combiner may be used to subsequently 
combine them in to a single pdf file. 
 

Printing. 
 

 
Print Toolbar Buttons. 

 
Use the appropriate toolbar buttons to print the entire document, print 
only the current page, or save the document as a pdf. 
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Document Navigation. 
 
 
 
 
 
 
 
 

Page Navigation. 
 

Various options are provided to navigate around reports. Zoom options 
consist of 50%, 75% and 100%, as well as Page Width and Full Page. 

Refresh Preview. 
 

 
 
Once a report has been generated, the data it contains ceases to be 
dynamically linked to the Moving Light Assistant show file. If subsequent 
changes are made to the show file, they will not be reflected in the report. 
Use ‘Refresh Preview’  to update the report. 
 
Similarly, if the report template is changed, Use ‘Refresh Preview’, to 
update the report to the new layout.  
 

Edit Template. 
 

 
The ‘Edit Template’ toolbar button opens the Report Designer with the 
layout template for the selected report loaded for editing. 
 
This allows for quick changes to the layout of the report.  
 
When the layout has been amended, save the layout in Report Designer, 
and exit to return to Report Preview. Refresh the preview to incorporate 
the layout changes. 
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APPLICATION PREFRENCES. 
 

 
Preferences – Setup. 

 

Setup Tab 

DMX Format 
 
These options allow you to specify the display format for DMX addresses. 
An example of an address is displayed at the bottom in the format 
selected by the current options. 
 
Letter 
 
Letters ‘A’ to ‘Z’ ( also ‘a’ to ‘z’  ) can be used to specify the universe. 
Double letters can also be used allowing a maximum of 702 DMX 
universes to be specified, ‘A’ to ‘Z’ and ‘AA’ to ‘ZZ’. 
 
Number 
 
The DMX universe number is simply placed before the DMX address. It is 
best used with the separator character otherwise it will be a little 
confusing. 
 
Absolute 
 
This is the absolute DMX address, which is a combination of the DMX 
universe number, multiplied by 512 and added to the DMX address. 
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Example 
 
DMX Universe = 2 
DMX Address = 5 
Absolute address = 517 
 
Separator 
 
This is a character (or several characters) used to separate the universe 
letter or number from the DMX address. Common separators are ‘.’ or ‘/’. 
This is an optional field. It is recommended that ‘,’ (comma) characters 
are not used as this will cause issues with importing/exporting. 
 
3 Digit Address 
 
With this checkbox checked, the DMX address will be forced to 3 digits 
padding with ‘0’ characters as required. 
 
Examples 
 
A1 - Letter, No Separator, 2 Digit Address OFF 
A001 - Letter, No Separator, 3 Digit Address ON 
A.001 - Letter, ‘.’ Separator, 3 Digit Address ON 
5.1 - Number, ‘.’ Separator, 3 Digit Address OFF 
5.001 - Number, ‘.’ Separator, 3 Digit Address ON 
 
Universe number from 0 
 
This option is used to indicate numeric universe identifiers are numbered 
from zero as opposed to one. 
 

Units 
 
To select how weights and measurements are displayed within the 
application. Metric will show ‘kg’ and ‘m’, where as Imperial will display 
‘lbs’ and ‘ft’. Note that feet are decimal feet, not feet and inches. 
 

User Column Headings 
 
There are 6 columns in the main rig window that the user can use as they 
like. It is possible to set the column headings here for these user fields. 
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Image Import Size 
 
When adding images to Presets or Cues, either by importing a file, using 
Camera Capture or though the Image Watch Folder, the size of the image 
stored in the database is set here. As images are stored in the database 
and not a separate file, the bigger the image, the bigger the database will 
grow. The options are…. 
 
Source Resolution 
 Images will be imported at the resolution they came in as. 
 
High Resolution 
 Images will be scaled to 75% of their original resolution. 
 
Medium Resolution 
 Images will be scaled to 50% of their original resolution. 
 
Low Resolution 
 Images will be scaled to 25% of their original resolution. 
 
It is worth noting the resolution of the images you will be importing from 
decent DSLR cameras can be very high ( i.e. 3504 × 2332 pixels ), so a 
Low Resolution setting may sometimes be applicable. Medium is the best 
default setting. 
 

Console Tab 
 

 
Preferences – Console. 

 
These options are specific to imported console data. 
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Round Intensity Value 
 
This feature is not yet implemented. It is designed to round intensity 
values to whole numbers. 
 

Rig Check 
 
When this checkbox is enabled, the specified rig check sequence and cues 
will be omitted from preset use checking in the Preset Data view and 
channel usage in the Channel Usage view. 
 
Rig Check cues and sequences can be specified in Manage->Console 
Data… menu. 
This feature is useful to truly find out what is actually used in the show. 
For example, commonly there may be a frame by frame scroller rig check 
in a show. Normally this would then flag that all scroller frames are used. 
By specifying where the rig check is and enabling  this feature, only 
scroller frames outside of the rig check will be shown as used. 
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IMPORTING and EXPORTING DATA. 
Importing Rig Data. 
 
The menu File->Import->Text File... can import rig data from any other 
application which can export data as a text file. Many file types are 
supported, with types .txt and .csv (comma separated file) being the most 
common. 
 
Upon selecting Import->Text File... a browser window will open allowing 
you to choose the relevant text file to import. Upon selecting a suitable 
file, the Import Rig window will open. 
 

 
Import Rig Window. 

 
This windows allows you to match the imported file fields, listed in the left 
hand pane, to the internal Moving Light Assistant Rig Data fields shown in 
the right hand pane. Simply select a field in the right hand pane and drag 
it to a field in the left hand pane to make the import association. 
 
The file fields are in fact the first row of the imported data, if the data 
export is set to include field headings as first row. 
If a mistake is made, ‘Reset Fields’ will clear all the associations allowing 
you to start again. 
 
Two buttons ‘Lightwright’ and ‘Suggested’ will automate this process. 
‘Suggested’ will make general obvious associations whilst ‘Lightwright’ will 
make suggestions based specifically on the data fields likely to be found in 
data exported from Lightwright. 
A series of check boxes at the bottom of the window allow you to adjust 
the import process. 
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• The ‘Ignore First Record’ check box will discard the first line of 

imported data. This should be checked if the first line of data 
contains column headings rather than real data. 
 

• The ‘Lightwright Field Formatting’ should be checked when the 
imported data is from Lightwright. 

 
• The ‘Field Separator’ and ‘Tab Delimiter’ check box select which 

character is used to separate the imported data fields from each 
other. By Default, the data is assumed to be comma separated. If 
however the data fields are all run together, with no breaks, then it 
is likely the data is tab delimited, in which case the ‘Tab Delimiter’ 
check box should be selected. Very occasionally, another character 
is the delaminating character, in which case that character may be 
entered in the ‘Field Separator’ box. 

 
Example of Incorrect Delimiter. 

 
The ability to export column headings as the first row of data, and to 
select the delimiting character are usually available in the exporting 
application under the export settings. 
 
Moving Light Assistant import settings should match these export settings. 
Occasionally, some experimentation is required. 
 
Rig Data that has been imported is flagged in the Rig Data View with a 
small magenta triangle in the corner of each field. The flags can be viewed 
or hidden from the ‘Edit’ menu. 
 

 
Magenta Flags 
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The menu File->Import->Lightwright 5...  is specifically designed to 
import rig data from Lightwright. It will automatically map imported data 
to rig data, making some logical assumptions in the process. 
 

Exporting from Lightwright 5. 
 
Data export from Lightwright 5 is found under the Menu File->Export 
Data->Data. 
 

 
Lightwright 5 Export Options. 

Suggested Export Settings. 
 

• Select the data fields to be exported. 
The Lighwright ID field MUST be exported, otherwise it will be 
impossible to import the data back in to Lightwright. 

 
• Select the delimiter (separator). Tab is recommended. 
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• Choose to sort exported data by Instrument Type. 
• Check ‘Export field labels as first record.’ 
• Check ‘Strip channel parenthesis()’ 
• Check ‘Use Plain Wattages’. Although ‘Moving Light Assistant’ does 

not currently handle wattages, this option is best checked. 
• Un-check ‘Fill blank fields with’. 
• Un-check ‘For Lights with attributes, export only the first row.’ 
• ‘Only items marked on Light plot’ can be checked or not, depending 

on what you want to export. 
• Un-check ‘Use Macintosh line endings.’ 

 

Automated Import / Export with Lightwright 5. 
 
Moving Light Assistant  includes two files for automated  importing to, and 
exporting from, Lightwright 5. The files are named ImportMLA.lwa and 
ExportMLA.lwa, and are located in the ‘Lightwright Automated Actions’ 
folder in the Moving Light Assistant  installation folder. 
 
To use them, they must first both be copied to the ‘Automated Actions’ 
folder in the Lightwright 5 installation folder. 
 
Once copied, the automated actions will appear in the Lightwright File-
>Automated menu. 
 

 
Lightwright 5 Automated Import / Export. 

 
It is then only necessary to select the ‘ExportMLA’ or ‘ImportMLA’ menu 
options in Lightwright, select the relevant file, and the process is 
complete. 
 
The default import and export filenames are LW Import.txt and LW 
Export.txt. They are both tab delimitated files containing the following 
core Lightwright data fields, in the following order: 
 

Lightwright ID 
Channel 
Position 
Unit No. 
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Instrument Type 
Purpose 
Dimmer 
Accessory 
Circuit Name 
Circuit No. 
System 
Device Type 

 

Lightwright 5 Attributes. 
 
Moving Light Assistant treats moving lights with mulitiple attributes as 
single entities, not as a series of individual attributes. Consequently, when 
Lightwright data with attributes is imported, the attributes are discarded, 
and only the ‘root’ fixture is imported. 
 
There is an exception where Lightwright data includes fixtures requiring 
external dimmers. This is commonly found in some tungsten moving lights 
where the fixture will have one DMX footprint, with another DMX address 
for an external dimmer. As long as the external dimmer attribute in the 
Lightwright data has the purpose ‘External Dimmer’, the import process 
will insert the DMX address of the external dimmer in to the Rig Data 
‘External Dimmer’ field.  
 
In the example below, a VL5 in Lightwright has a base DMX address of 1/1 
and an external dimmer, DMX address 2/123, is imported in to Moving 
Light Assistant. 

 
Lightwright 5 data with External Dimmer. 

 

Exporting Data. 
 
There are two options for exporting Rig Data from Moving Light Assistant, 
selected via the menu File->Export. Text File or Lightwright 5. 
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Export Menu. 

Text File. 
 

 
Rig Text Export Window. 

 
Selecting the text export option opens the Rig Text Export window. 
The left hand pane shows all the available data fields in Rig Data. The 
right hand pane shows the fields to be exported. Drag fields from the left 
hand pane to the right in order to include them in the export. 
Alternatively, select ‘Add All’ to include all fields. The order data fields 
appear in the exported text file can be changed by dragging the field 
names within the right hand pane. 
 
‘Remove’  will remove the selected field from the export list. ’Clear’ will 
remove all the fields from the export list. 
 
Clicking ’Lightwright’ will automatically add the most common fields to be 
exported to Lightwright, including the Lightwright ID, if the data has 
previously been imported from Lightwright. 
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Lightwright Export Fields. 

 
There are check boxes to include the field names as the first record, and 
to change the delimiter from comma to tab. 
Selecting comma as the delimiter will produce a file with the extension csv 
(Comma Separated Values), whilst selecting tab will produce a txt file. Tab 
is often best as other characters can lead to export confusion if the 
character also appears in a data item. 
 
Checking ‘Lightwright Field Formatting’ will format the data specifically for 
import in to Lightwright. See ‘Notes on Exporting to Lightwright’ 
Finally, selecting ‘OK’ will open a browser window to select a file name and 
location in which to save the file. 

Importing and Exporting DMX addresses. 
 
Moving Light Assistant supports up to five DMX addresses (‘patch points’) 
per fixture: Fixture, Intensity, Colour, Beam and Supply. These addresses 
are viewed in Rig Data in a formatted form as set in File->Preferences, 
DMX format. For example 3/045, where 3 is the universe number, and 45 
is the DMX address within the universe. 
 
When exporting formatted DMX addresses, there exists the option to split 
the DMX address to separate fields, one for the universe identifier and 
another for the address, as well as to export the formatted address. 
Consequently, there are 3 address fields for each function,  DMX Universe, 
DMX Address and DMX Universe/Address formatted. 
 
So, using the example above of DMX 3/045, if all three fields are selected 
for export, DMX Universe will contain the number 3, DMX address will 
contain the number 45, and DMX Universe/Address formatted will contain 
3/045, as a text string. 
 
Similarly, when importing data, if your data source contains separate 
fields for Universe and Address, these may be imported in to 
corresponding fields in Moving Light Assistant.  The DMX addresses will 
only ever be displayed in a single Universe/Address formatted form in Rig 
Data.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    
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Importing and Exporting ‘System’ Information. 
 
Lightwright supports six systems, labelled A-F. Moving Light Assistant 
supports more systems, and labels them by name, as set in Manage-
>Systems.... 
 
During data export, the first six system names will be mapped to letters 
A-F for import in to Lightwright. During data import from Lightwright the 
system names A-F will be mapped to the first six system names if they 
exist in Moving Light Assistant. 
 

Channel Numbers in Import and Export Operations. 
 
Moving Light Assistant uses channel numbers as its primary means of 
identifying which fixtures are which during import and export operations. 
If fixtures are missing channel numbers, this can cause confusion during 
importing and exporting. 
 
For example, if a fixture with no channel number is exported, and 
subsequently re-imported, Moving Light Assistant will have no means of 
recognising the data as being the same fixture, and a duplicate fixture will 
erroneously be created. 
 
A special case exists when exchanging data with Lightwright, where 
Moving Light Assistant can use the Lightwright Unique ID number for each 
fixture to keep track of data. 
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MENU FUNCTIONS. 
 
Note: 
Keyboard short keys differ slightly between Mac OSX and Windows 
versions of Moving Light Assistant. For Windows, the Ctrl key is used in 
combination with the letter key, and for Mac OSX, the Cmd key is used. 

File Menu. 

 
File Menu Items. 

 

New Show. Ctrl+N 
 
Opens a new ‘blank’ show file with the name ‘Untitled’. 
 
If an existing show file is open with unsaved changes you will be 
prompted to save the changes before the new show file is created. 
 

Open Show. Ctrl+O 
 
Opens a file browser window to browse for a new show file with the file 
extension .mla.  
 
Once a new show file has been selected, If an existing show file is open 
with unsaved changes you will be prompted to save the changes before 
the new show file is opened. 
 
If a show file was created in an earlier version of Moving Light Assistant,  
it will be converted to the latest file format at the time of opening. 
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It is only possible to have one show file open at any time. 
 

Save. Ctrl+S 
 
Saves the current open show file with the same filename and in the same 
location. 

Save As. Ctrl+Shift+S 
 
Saves the open show file with a new name, and, or, in a new location. 
 
Opens a file browser window to browse for an alternative existing filename 
or location, or to enter a new file name. If an attempt is made to save to 
an existing file, a warning will be displayed before the operation can 
proceed. 
 

Internal File Handling. 
 
Whilst a show file is open and being edited, Moving Light Assistant 
constantly keeps track of changes by background saving to a 
temporary file. This temporary show file is deleted every time a user 
closes a document or quits the application. 
 
Should Moving Light Assistant unexpectedly terminate without the 
user saving the show file, the presence of the backup file will be 
detected next time the application starts, and you will be given the 
opportunity to save the recovered data. 

Clean Up Show Document. 
 
Purges the Moving Light Assistant show file of deleted data and images. 
  
As Clean Up Show Document will reduce the size of a show file, 
particularly if a lot of photographs or imported console data has been 
deleted, it may be used before emailing the show file to colleagues. 
 
Typically used as a final ‘tidying up’ of a finalised show document. 
 
(Use of this command does not impact the ability to undo deleted data 
using Edit->Undo.) 

Import. 
 
Imports Rig Data from Lightwright or other 3rd party application. See 
chapter Importing and Exporting Data. 
 
Importing data from Vectorworks is not currently supported. 



150	
   MOVING	
  LIGHT	
  ASSISTANT	
  
 

 
Importing Moving Light Assistant console, fixture and gobo libraries is not 
yet implemented. 
 

Import Console Data. 
 
Imports Console Data. See chapter Importing Console Data. 
 
Moving Light Assistant can import console data from GrandMA 1, EOS 
family, and Whole Hog 2. 
 
Importing from USITT ASCII files is not currently supported. 
 

Export. 
 
Exports Rig Data to Lightwright or other 3rd party application. See chapter 
Importing and Exporting Data. 
 

Page Setup. 
 
Currently performs no function. Page setup is performed within Report 
Designer. 
 

Print 
 
Currently performs no function. Printing takes place through Report 
Preview. 

Preferences. 
 
Options to set various preferences. See Chapter on ‘Application 
Preferences.’  
 

About Moving Light Assistant. 
 
Displays the Moving Light Assistant About Screen. 
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About Screen. 

 
 

Registration. 
 
Opens the Moving Light Assistant Licence Key window. 
 

 
Licence Key Window. 

 
See Licence/Registration for more information. 
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Deregistration. 
 
Every installation of Moving Light Assistant requires a unique licence key 
to be fully enabled. 
 
If you wish to install Moving Light Assistant on another computer, and 
have already used your allotted number of licence keys then you must 
first de-register one of the existing installations. 
 
See Licence/Registration for more information. 
 

Exit/Quit. Ctrl+Q 
 
Exits Moving Light Assistant.  
 
If you have an open show file with unsaved work you will be given the 
option to save the work first 

Edit Menu. 

 
Edit Menu Items. 

 

Undo / Redo. Ctrl+Z / Ctrl+Shift+Z 
 
Moving Light Assistant supports multiple levels of undo and redo for many 
operations. The menu titles will change their name to indicate the 
operation about to be undone, or redone. If the most recent operation 
cannot be undone, the menu will display ‘Can’t undo’. 
 

Clipboard functions.  
 
Standard clipboard operations. Cut, Copy, Paste and Delete.  
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Select All / Deselect All. Ctrl+A / Ctrl+Shift+A 
 
Whilst editing in a text field, Select All will highlight all the text within that 
field for deletion or over writing. Deselect All does not function in this 
mode, and is greyed out. 
 
Whilst in Cue List view, Select All, will select all the cues in the cue list, 
primarily for setting the 'Auto’ photo flag for all cues. In Cue List view 
Deselect All will deselect all the cues in the cue list. 
 
Whilst in Preset Documentation view, Select All will select all the channels 
in the channel list. 
 

Clear / Hide / Show Changed Flags. 
 
Clears or hides the Rig Data ‘Changed Flags’. If the changed flags are 
already hidden, the menu item will change to ‘Show Changed Flags’. 
These menu options only relate to Rig Data, and are greyed out in all 
other views. Clearing changed flags cannot be undone, and you will be 
asked for confirmation before proceeding. See Rig Data – Data Change 
Flags for more information. 
 

Add Fixtures. 
 
Opens  the ‘Add Fixtures’ window. Allows fixtures to be added to Rig Data.  
Unlike the Rig Data toolbar button which performs the same function in 
the Rig Data view, Edit->Add Fixtures is available no matter what view is 
open in the main screen. For example, fixtures can be added whilst 
viewing console data. Use of  Edit->Add Fixtures does not change the 
current view to Rig Data.   

Show Menu. 
 
The menu->Show->Production allows information regarding the 
production, and those working on it, to be documented. 

 
Show Menu Items. 
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Production Information – Show. 

 
A show logo may be added. Jpeg, png and bmp file formats may be 
imported. The paperwork may be date stamped, and the ‘Stage’  drop 
down list can define the paperwork as Design, Pre-Production, Production, 
or Final. Alternatively, another description may be entered. 
 
If console data has been imported, the name of the file imported is saved 
in the show file, and is displayed at the bottom of the ‘Show’ tab. It may 
also be edited in this field if desired. 
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Production Information – Creative Team. 

 

 
Production Information – Lighting Team. 

 
Under the ‘Lighting Team’ tab, the lighting designer may enter a 
disclaimer and copyright notice. Clicking on  either button will open a 
simple editor in which to enter the text. A logo may also be added. 
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Production Information – Programmers. 

 

 
Production Information – Technical Team. 
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Production Information – Suppliers. 

 

Setup Menu. 
 

 
Setup Menu Items. 

 

Manage Menu. 
 
The Manage menu contains the following menu options: 
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Manage Menu Items. 

 

Manage Fixture Profile Library. 
 
The Manage->Fixture Profile Library allows new fixture profiles to be 
created, and existing fixture profiles to be edited or deleted. Many 
functions within Moving Light Assistant gain their ‘intelligent’ operation by 
referring to the Fixture Profile Library. 
 

 
Manage Fixture Profiles. 

 
To Edit, Duplicate or Delete an existing profile, select the manufacturer 
from the drop down list, followed by the required fixture. If you are 
deleting a profile a warning dialog will ask you to confirm your actions, 
whereas if you wish to create a duplicate profile, you will be prompted for 
a new name for the duplicate. (The ‘Duplicate’ function exists to allow the 
creation of a new profile when it is often easiest to modify an existing 
profile.) 



MOVING	
  LIGHT	
  ASSISTANT	
   159	
  
 

 
Selecting New or Edit will open the Edit Profile window. If editing an 
existing profile, the Profile attributes will contain the pre-existing fixture 
profile data, otherwise the fields will be blank. 
 
 
Creating a new Fixture Profile. 
 

 
Edit Profile – Physical Tab. 

 
The Edit Profile Window contains several tabs for different types of 
information: 

 
Physical. 
Electrical. 
Control. 
Optical. 
Options. 
Gobos. 
Colours. 
Effects. 
Bays/Slots. 
 

Begin by entering a name for the fixture profile, and the fixture 
manufacturer. If you wish the fixture to be added to an existing 
manufacturer group, be sure to spell the manufacturers name exactly as it 
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is already spelt. Select a type for the fixture from the drop down list of 
types. Options include: 
 
 

Conventional. 
Moving Light (Head). 
Moving Light (Mirror). 
Accessory (Colour). 
Accessory (Beam). 
Accessory. 
LED. 
Media Server. 
Strobe. 
 

Under the Physical Tab, enter a weight for the fixture, either in Kilograms 
or Pounds, or both. (Moving Light Assistant  does not automatically 
convert between units). This weight is used to calculate the total rigging 
position weight in Manage->Positions. If the fixture has a separate ballast 
which is rigged adjacent to the fixture then it is advisable to include the 
ballast weight here to ensure the total rigging weight is accurate. 
 
Electrical Tab. 
 

 
Edit Profile – Electrical Tab. (VL3500 spot example) 
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Enter the electrical power consumption of the fixture in watts. If the 
fixture uses a separate supply for the lamp power, you may enter 
individual values for the fixture power consumption and the lamp power 
consumption.  
If the fixture is powered through a repeater (Such as a VL5) or an 
external power supply (such as a scroller), check the ‘Powered through 
Repeater/PSU’  box. 
Likewise, if the fixture derived it’s lamp power from an external ballast or 
dimmer, check the ‘Lamp power from a remote ballast/dimmer’ box. 
 
Control Tab. 
 

 
Edit Profile – Control Tab. (VL5 example) 

 
This tab relates to the DMX control modes, functions of individual control 
slots, and the method by which the fixture is addressed. 
 
In the DMX Mode area, enter details of the various DMX operating modes 
the fixture supports, along with how many DMX slots each mode uses. 
Use the radio buttons to select the fixture’s default DMX mode. This is the 
mode which will be selected by default when adding the fixture in Rig 
Data. Beside each defined DMX Mode, the ‘Params’  button will allow the 
definition of each individual DMX control slot. 
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Individual parameters can be defined from scratch for each mode, or 
copied and edited from existing modes for that fixture using the ‘Copy 
From’ function. 
 
 

 
DMX Mode Parameters. 

 
If the fixture requires control for an external dimmer (in the case of a VL5, 
for example), an external colour function (in the case of a scroller, for 
example), or an external beam control device (a drop in gobo rotator, for 
example), then check the relevant boxes and define how many DMX 
control slots the external function requires. 
 
In the ‘Address Selection’ area, define how the DMX Address is set on the 
fixture. Available options are: 
 

Menu – Some form of menu system displayed on a screen. 
Thumb wheels. 
Dip Switches. 
Repeater – Vari-lite Series 300 systems, for example. 
Other. 
 

If ‘Dip Switch’  is selected, define how the DIP switches function. 
 

All off is One  
Check this box if DMX address 001 is set by 
setting all the DIP switches off. 

 
Is Fixture Number. 
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Check this box if the number set on the DIP switch 
is not a DMX address, but some other kind of 
fixture identification number. 
 
 

Off is On. 
Check this box if the operation of the DIP switches 
is inverted. 
 

Define the total number of DIP switches present on the fixture, and how 
many of those DIP switches are DMX address switches using the 
appropriate drop down values. 
 
This information will be used when printing reports containing DIP switch 
graphics. 
 
Optical Tab. 
 

 
Edit Profile – Optical Tab.(VL5 example) 

 
Define front lens and internal lens options, along with lamp and wattage 
variants. Use the radio buttons to define a default option in each category. 
This information is used when Adding Fixtures in Rig Data, under the 
‘Optical’ tab. 
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Options Tab. 
 

 
Edit Profile – Options Tab. 

 
Define fixture options such as DMX Lamp Off, Pan/Tilt Invert and ‘Studio 
Mode’, for example. Additionally specify whether the option is set via a 
menu, or a dip switch. 
Buttons allow the adding of new options and editing or deleting existing 
options. 
Conformation will be requested before an option can be deleted. 
 

 
Edit Profile – options Edit. 
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To add a new option, enter a name for the option (typically the menu path 
as it appears on the fixture), and then the option choices, along with a 
description for each choice. Use the associated radio buttons to select the 
default choice for that option.  
By default it is assumed the options are set via a menu system. If the 
option is set by a dip switch, check the ‘DIP Switch’  box. Enter the 
corresponding switch number. If the switch is part of the DMX addressing 
block of switches, check the ‘Address DIP’  box. For example. Under the 
control tab, 12 DIP switches could be defined, of which only the first 9 
may be address switches, with switches 10, 11 and 12 being option 
switches. 
This information is used in Rig Data, under the Menu/DIP toolbar button. 
 
 

 
Example of DIP Fixture Options in Rig Data, defined in Fixture Profiles. 

 



166	
   MOVING	
  LIGHT	
  ASSISTANT	
  
 

Gobos Tab. 
 

 
Edit Profile – Gobos Tab. 

 
Define the fixture’s gobo wheels. Up to 3 gobo wheels may be defined per 
fixture. 
Enter the number of positions, including open, in the wheel, and select the 
gobo size from the drop down list. New, custom sizes, may also be 
entered directly in to this box. Define whether the wheel is fixed or 
rotating using the radio buttons. 
If the wheel in question is an interchangeable option that fits in to a bay 
or slot within the fixture, then check the relevant  box and select the 
module name from the drop down list. The bay or slot modules must first 
be defined under the ‘Bays/Slots’  tab. 
The Layout button defines the wheel graphic which will be used when 
viewing Wheel Loads. 
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Wheel Layout. 

 
Wheel Layout. 

 
Wheel Layout graphics consist of 2 parts. A graphic of the wheel itself 
(wheel image), and a mask the same size as the positions in the wheel. 
Both graphics should be in jpeg format. 
 
The Wheel image should be 1500x1500 pixels, with the wheel itself being 
approximately 1300 pixels in diameter. This allows room around the 
perimeter of the wheel for the position numbers to be shown, if selected 
to do so in the Wheel loads view. Ensure the centre of the wheel image is 
at 750,750 pixels. 
 
The Position Mask should be a black circle (or other shape if the gobo 
position is not circular) and the same size as the positions in the main 
wheel image. 
 
Specify the number of pixels between the centre of the gobo wheel and 
the optical centre of the gobo positions.  
 
Open Position. Specify, using the radio buttons where about 

on the wheel the open position is. 
 
Clockwise check box. Check this box if the positions are numbered 

clockwise from the open position. Leave un-
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checked if they are number counter 
clockwise. 

 
Wheel to side check box. Check this box if the wheel sits to the side of 

the optical path in the fixture. Leave un-
checked if the wheel sits above or below the 
optical path. This ensures that gobos that 
have a specific orientation will be displayed 
correctly in Wheel load view. 

 
Position Offset Angles. By default, Moving Light Assistant assumes 

the gobo positions are equally spaced 
around the wheel, and this field may be left 
empty. Occasionally, wheels may be 
encountered where this is not true, in which 
case, specific angles between the positions 
may be specified as a series of comma 
separated values, starting at the open 
position, and working up through the 
position numbers. 

 

 
Example of asymmetric gobo slot positions. 

 
View Notes. A text field for entering any relevant notes. 

Most commonly used for describing which 
side of the wheel the layout is representing. 
For example, ‘Viewed from front of fixture’. 
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The Default Gobo Load drop down list defines the default gobo load for 
each wheel. The Options are None (Empty Wheel by default), 
Manufactured Standard or Edit... If other default loads have been defined, 
they will also be available in this list. 
 
Select Edit to define a new default gobo load, or edit an existing one. 
 

 
Edit and existing default load, or create a new one. 

 
To define a new default gobo load, click ‘New’, or to define a new default 
gobo load based upon an existing load, select ‘Duplicate’.  You will be 
asked for a new name for the new or duplicate load.  
 

 
Defining a new default gobo load. 

 



170	
   MOVING	
  LIGHT	
  ASSISTANT	
  
 

Enter a name for the new load, and define which wheel the load applies 
to. The number of positions already defined for that wheel will be 
displayed as a list. Enter the gobo catalog name, reference number and 
Title for each position, remembering not to populate the ‘open’ position. 
The name, number and title should correspond to the Gobo Library 
nomenclature if the default wheel loads are to display correctly in Wheel 
Loads. 
 
Remember this is not where you define gobo wheel loads for shows. This 
is just for defining the default gobo loads per fixture type, which are then 
modified as required, show by show in ‘Wheel Loads’. 
 
Colours Tab. 
 

 
Edit Profile – Colours Tab. 

 
Define the fixture’s colour wheels. Up to 3 colour wheels may be defined 
per fixture. This is functionally the same as the Gobo Tab. Scrollers may 
also be defined in this window. To accommodate scroller gel strings, 
Moving Light Assistant allows up to 32 positions in the ‘wheel’. Check the 
‘Is a scroller’  check box. 
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Effects Tab. 
 

 
Edit Profile – Effects Tab. 

 
Define the fixture’s effects wheels. Two effects wheels and one animation 
wheel may be defined per fixture. This is functionally the same as the 
Gobo Tab. 
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Bays/Slots Tab. 
 

 
Edit Profile – Bays/Slots Tab.(ETC Revolution example.) 

 
If a fixture includes ‘bays’ or ‘slots’ which allow modules to be added and 
removed, define the bays, and available module options here. Up to two 
bays/slots may be defined, with 6 available modules in each.  
Module descriptions may be selected from the drop down list, or new 
modules described by typing directly in to the box. 
It is also possible to define an internal media frame, and the media it is 
fitted with. Usually, but not exclusively, a frost. 
The Bays/Slots functionality is very much geared around the ETC 
Revolution fixture. 
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Manage Positions. 
 

 
Manage Positions. 

 
Rigging positions can created, edited and deleted here. Single or multiple 
trim heights, along with a short note, can be defined for each position. 
 
To create a new position, click on the small ‘+’ button. A ‘New Position’ 
line will be created, where upon it can be edited to the desired name. To 
remove a position, click on the small ‘-‘ button. Confirmation is required 
before a position can be deleted. It is not possible to delete a position 
containing fixtures in Rig Data. 
 
Position can also be defined from the ‘Add Fixtures’  facility in Rig Data. 
Positions added in Rig Data will be added to the Positions List. 
 
Positions can be dragged in to any order within the positions list. This 
order defines the order positions will appear in the ‘Positions’ filter in Rig 
Data. 
 
The Manage Positions window calculates and displays the number of 
fixtures each positions contains in Rig Data, and the total weight of the 
rigged fixtures, derived from weight data in the fixture profiles. 
 
If all the fixture profiles within a position contain weight data, then the 
total weight can be certain, and the weight figure is displayed in black. If 
any of the fixture profiles are missing weight data, then the total weight 
will not be correct, and the calculated value will be displayed in red. 
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The Manage Positions window can display one trim height per position. 
Clicking the ‘Additional Trims’  button will open a fly out panel allowing 
additional trims to be documented. Clicking the button again will close the 
panel. 

 

 
Manage Positions – Additional Trims. 

 
Weights and Trim heights are displayed in either metric or imperial units, 
as defined in File->Preferences. Values are not converted  between 
systems, so if the display metric is changed, the values will be incorrect in 
the new units.  
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Manage Systems. 
 

 
Manage Systems. 

 
By default, Moving Light Assistant assumes your show exists as one 
system, controlled by one lighting console. This system is given the name 
‘Main’, but it may be re-named by simply clicking on the name and 
entering a new one.  
 
Additional systems may be created and deleted by clicking on the small 
‘+’ and ‘-‘ buttons respectively. It is not possible to remove a system 
which contains patched fixtures. 
 
The Manage Systems window will display the number of DMX universes 
each system contains, along with the number of fixtures patched, 
information derived from ’Manage Universes’ and Rig Data. 
 
The ’Lightwright ID’  provides compatibility with Lightwright, which does 
not support named systems.  
 
‘Systems’ exist as a way to document large shows running on multiple 
consoles, but the concept may also be used even on small productions.  
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Manage Systems – Large Show Example. 

 
Patching on Multiple Systems. 
 
Once multiple systems have been defined in Manage->Systems, fixtures 
may be patched to different systems in Rig Data. Ensure the ‘Systems’ 
column is visible, then select the desired system from the ‘Edit’ drop down 
list and patch the fixture in the normal way. 
 
Each system has it’s own DMX address space, so fixtures with the same 
DMX address but are on different systems will not show up as a DMX 
address conflict. 
 

Manage Universes. 
 

 
Manage Universes. 
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Manage Universes  displays information about the DMX universes in a 
show, and the fixtures patched to them. 
 
The window is divided in two halves, with the left hand side showing a list 
of universes, and the right hand side showing details of an individual 
universe. There is a drag handle between the two panes to adjust their 
relative widths. 
 
Beyond adding DMX Universes, no information can be edited in this 
window. The window reflects patch information from Rig Data. 
 
The Universe list shows the following information: 
 
• ID. 

 
The universe identifier. This may either be a letter (or letters), or a 
number, as defined in the menu File->Preferences->DMX Format. 
 

• System. 
 
A System is a logical group of DMX universes, generally controlled by 
one console. Shows with multiple consoles are described as having 
multiple systems. The system identifier can be a name or a number 
and is defined when universes are added, or via the menu Manage-
>Systems. By default, DMX universes are added to the ‘Main’ system. 
 

• Device. 
 
Describes the node, gateway or NSP producing the DMX universe. For 
future use. 
 

• Output. 
 
Describes the device port on which the DMX universe appears. For 
future use. 
 

• Fixtures. 
 
The number of fixtures in Rig Data patched to the universe. 
 

• Used DMX. 
 
The total number of DMX slots used by patched fixtures based upon 
their DMX footprint. 
 

• Free DMX. 
 



178	
   MOVING	
  LIGHT	
  ASSISTANT	
  
 

The total number of free DMX slots in the DMX universe. Moving Light 
Assistant assumes all DMX universes have 512 slots. 
 

• Free Block. 
 
The largest number of free DMX slots in a single contiguous block. 
 

• Block Start. 
 
The first DMX slot of the largest free contiguous block. 

 
The right hand universe view displays the usage of each DMX slot within 
the selected DMX universe. It shows the channel number and the fixture 
type the slot is patched to, along with the individual fixture parameter.  
External Intensity, Colour and Beam parameters are also displayed. 
Fixtures will be colour coded alternately cyan and magenta to indicate 
blocks of DMX slots. If there are overlapping DMX addresses, they will be 
highlighted in Red.  
Finally, the rigging position of the fixtures is displayed. 
 
Adding DMX Universes. 
 
DMX universes must be manually added using the ‘Add’ button. Moving 
Light Assistant will not derive the presence of DMX universes based upon 
Rig Data patch information. 
 

 
Add Universe. 

 
The Universe ID can be entered either as a letter or a number, but the 
format will be converted to reflect the global DMX format as defined in the 
menu File->Preferences->DMX Format. 
By default, ‘Main’ will be offered as a system name. If other systems have 
been defined, they will be available to select via the drop down list. It is 
possible to have DMX universes with the same ID if they exist in different 
systems. 
 
Once a DMX universe has been added, its usage will be displayed. 
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Removing DMX Universes. 
 
DMX universes can be removed at any time by selecting the required 
universe and clicking ‘Remove’. Deleting a universe does not un-patch or 
delete any fixtures that may be patched to it. 
 

Manage Fixture types. 
 
Manage Fixture types allows fixtures imported from console patch 
information, Lightwright or other application to be associated with fixtures 
in the Moving Light Assistant fixture library. 
 
Only when fixtures are associated with fixtures in the library can the full 
power of the fixture profile be leveraged within Moving Light Assistant. 
 

 
Manage Fixture Types. 

 
If an exact match can be found between an imported fixture, and a fixture 
in the profile library, an association will be created automatically, and the 
DMX mode and configuration options set to the default profile options. If 
any of these assumptions are incorrect, adjust the values as necessary 
and click ‘Assign’. The association will be updated. 
 
If no matches can be found, the fixture must be selected manually by 
selecting the manufacturer and fixture type, and setting the DMX mode 
and other relevant options. click ‘Assign’ and the association will be 
created. 
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Manage Fixture Types – No associations. 

 
Initially upon creating an association the Fixture Type will remain 
unchanged, but the ‘Current’  field will reflect the associated Fixture Type. 
Upon clicking ‘OK’, the Fixture Type in Rig Data will change to show the 
associated fixture. 
 
Selected Channels Only. 
 
With ’Selected Channels Only’ checked, only the highlighted channels in 
Rig Data will accept the new association. Un-selected channels will remain 
un-associated, and their original name will continue to appear in italics in 
the Manage Fixture Types window, along with the new associated fixture 
name.  
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Manage Console Data. 
 

 
Manage Console Data. 

 
The ‘Manage Console Data’ window displays all the console data currently 
in the show document. Cue Lists and Sequences can be deleted from the 
Moving Light Assistant show document by checking the ‘delete’ box and 
clicking OK. This action cannot be undone, and the data can only be 
retrieved by re-importing the data. 
Cue Lists or Sequences may be defined as rig check cues, and ignored in 
channel and preset usage. This allows a channel or preset that is only ever 
used in a rig check cue to be correctly reported as un-used. Additionally, a 
range of cues within a list or sequence may be defined as rig check cues 
by entering the start and end cue numbers, and ticking the ‘Rig Check’ 
check box. 
For the rig check ignoring functionality to work, it must be globally 
enabled in File->Preferences, Console Tab. 
 

 
Globally enable Rig Check Cues in File->Preferences. 
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Console Menu. 
 
Enables the 2D and 3D locations on a PRG Vx76 console to be set from 
the Moving Light Assistant  location X, Y, Z columns in Rig Data. 
 
This feature is only available on systems running Mac OSX. 
 

 
Console Menu Items. 

Reports Menu. 
 

 
Reports Menu Items. 

 
Report Designer opens the Report Designer. See the chapter on ‘Report 
designer’ 
 

Manage Report Templates. 
 

 
Manage Reports. 
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Manage Report Templates controls which report templates are included in 
the Moving Light Assistant show file. This may be useful if a user had 
designed a custom report template which they wish to make available to a 
collaborator. By default, no report templates are included within the show 
file, and all users have access to the same standard set of templates 
installed with the application. 
 
Installed Report Templates are stored in the Report Layout Templates 
folder, a sub-folder of the main application installation folder, and have 
the file extension lhf. 

 
Refresh Reports List. 
 

 

Utilities Menu. 
 

 
Utilities Menu Items. 

 

 
DIP Switch Calculator. 

 
The DIP Switch calculator is a handy binary DIP switch to decimal DMX 
convertor. It is a standalone utility and has no linked functionality to the 
main application. (Although similar functionality does exist within the main 
application if a fixtures DMX addressing is set to ‘DIP Switch’ within its 
fixture profile.) 
 
DMX addresses may either be entered as a numeric value in the ‘Number’ 
field, or by clicking on the individual switches to set a binary number. In 
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either case, the corresponding number or switch positions will 
automatically change. 
 
The number of switches displayed, along with the number of those 
switches which are address switches can be selected using the drop down 
lists. Switches which are not address switches will be displayed greyed 
out. 
 

All off is one. Check this box if a fixture uses all switches set to 
off to set DMX address 001. I.e., the set DMX 
address is one less than the actual number 
converted from binary. 

 
Off is On. Check this box if the logical operation of the 

switches is physically inverted.  
 
Show Values. Check this box to display the binary values above 

the individual switches. 
 

 
‘Off is On’ and ‘Show Values’ selected. 

 
 
 

Help Menu. 
 

 
Help Menu Items. 

 
Displays the Moving Light Assistant user manual and help information, as 
pdf documents. 
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REPORT DESIGNER. 
 
Before any report can be produced, a report layout file must exist 
describing what data is to be reported, and how and where the data is to 
be displayed upon the page.  
 
Moving Light Assistant includes a range of pre-defined templates covering 
common report types. These reports may be modified by changing the 
report layout file, or entirely new reports designed, using the Report 
Designer. 
 
The Report Designer is accessed through the menu Reports->Report 
Designer, or if in the Report Preview View, clicking on ‘Edit Template’. 
 
In either case, the report designer opens in a new window on top of 
Moving Light Assistant. 
 

 
Report Designer – Main Window – No Template. 

 
 

 
Report Designer has its own menu and toolbar structure. 
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Report Designer Toolbar. 
 
New Report Opens the Report Preferences window in 

preparation for creating a new report. 
 
Open Report Opens a file browser window to search for and 

open a layout file with the extension .lhf. 
The pre-defined Moving Light Assistant report 
templates are stored in the ‘Report Layout 
Templates’ folder in the application folder. 

 
Save  Saves a layout file. 

There is no ‘Save As’ function. Use you computers 
regular file handling to create copies of layout files 
and give them alternate names if required. 

 
Report Preferences If a report layout is open for editing, opens the 

report preferences. If no report is open this button 
performs no function. Use ‘New Report’ to reach 
the same window. See ‘Report Preferences’. 

 
New Page If a report layout is open for editing, Adds a new 

page to the report. You will be given the option of 
starting the new page as a copy of the existing 
page, or as a blank page. Two page reports are 
typically used where the report contains a cover 
page before the main body of the report. 

  
 Note. You do not use this feature to add new 

pages where a long report will naturally run in to 
several pages. The report generation process 
automatically creates as many pages as required. 

 
Copy and Paste Standard clipboard operations. 
 
Print and Print Current Prints the report template to the selected printer. 

This does not print the reports themselves. That is 
performed through ‘Report Preview’ Tab in the 
main Moving Light Assistant  toolbar. 

 
Close Designer Closes the report designer. If changes have been 

made to the template, you will be prompted to 
save the changes. 

 
Report Designer Menu. 
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File Menu Provides the same options as the toolbar buttons. 
 
Edit Menu Provide cut, copy, paste clipboard functions. 
 
View Menu->Grid Displays or hides a grid to assist in the layout of 

the template. The grid size may be changed 
between 1mm, 5mm and 10mm. 

 
View Menu->Zoom Adjusts the zoom scale of the template, between 

75% and 200%. 
 
View Menu->Units Adjusts the measurement units used by the report 

designer. Mm, pixels or inches. 
Note these units are independent of the metric or 
imperial preferences set within Moving Light 
Assistant. 

 
Options selected in the View menu are also available as a toolbar along 
the bottom of the report designer window. 
 

 
Grid and Zoom control toolbar. 

 
Drawing Toolbar. 
 

 
Text and graphical elements are added to a report template using the 
drawing toolbar situated down the left had side of the screen.  
Text added using the text tool will not have any borders. Squares and 
ovals may also contain text within them, effectively creating bordered 
text. 

Selection Tool. 

Text Tool. 

Rectangle Tool. 

Line Tool. 

Oval Tool. 

Checkbox Tool. (Not currently supported) 

Insert Picture. 
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If a grid is displayed, text and graphics will snap to the grid when being 
inserted, moved or re-sized. 
 
Text and graphics properties are controlled in the properties pane down 
the right hand side of the screen as  elements are added or subsequently 
selected. 
 
Typically, font, size and colour can all be changed. Line thickness, colour 
and fill colour can also be adjusted for graphical elements. 
 
The position co-ordinates are in the chosen units, and measured from the  
top left hand corner of the page. (0,0) 
 

 
Text Properties. 

 
Rectangle Properties.  

Oval Properties. 
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Report Preferences. 
 

 
Report Preferences – General. 

 
The fields ‘Title’  and ‘Internal name’ are in bold and are the only 
mandatory fields in this window.  
Title A Descriptive name for the report. This name will be 

suggested as a file name when the template is saved, 
but the suggestion does not have to be accepted, and 
any file name can be chosen. 

 
Internal Name Must contain one of the following phrases, exactly as 

written (without the bullet points), depending on what 
type of report is being produced: 

  
• Rig Data 
• Cue List 
• Wheel Load 
• Channel Usage 
• Preset Doc 
• Cue Moves 

 
This field is a pointer to the report designer as to where 
about in Moving Light Assistant it should look for the 
data, and provides some ground rules on how it should 
be handled. 
 

Other fields in this window are not obligatory, and may be used or ignored 
as desired. 
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Report Preferences – Page Tab. 

 
Enter details of the page size and orientation. Define the borders. Report 
designer will display the paper area as a white background, and the area 
defined by the borders by a blue square. If the grid is enabled, it will only 
be displayed within the border area. 

 
Report Preferences – Picture Tab 

 
The check box should be checked. 
 

 
Report Templates. 
 
Report templates (layouts) consist of text and graphical elements placed 
upon a page.  
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Text entered inside square brackets act as ‘placeholders’ for data within 
the ‘Moving Light Assistant’ show file.   
 
For example, placing the text “ProdInfo_Title” in a template (without the 
quotation marks) will produce the exact same text in the generated 
report, where as placing [ProdInfo_Title] in the template will produce the 
show title in the generated report. 
 
A complete list of placeholders is contained in Appendix 2. The text within 
the square brackets must match the placeholder text exactly.  
 

 
Simple Template Example. 

 
Adding Elements. 
 
Text, placeholders and graphics added to a report template are 
collectively known as elements. 
 
Elements are added to a template by clicking on a drawing toolbar button, 
and then clicking on the desired location on the report template paper 
space. Every time a new element is added, it is given a unique internal 
name, such as ‘Text1’ or ‘Rectangle3’. This name may be edited to 
something more descriptive in the Internal Name field under Properties, 
but must remain unique. 
 

 
Internal name. 
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Elements can be preceded with a special prefix which controls how often 
that text will appear on a page, and subsequent pages, and endows the 
text with special functionality. 
 
The prefix is added to the element internal name. Every prefix ends in an 
underscore character. In the example below, an element with the internal 
name ‘Text1’ is prefixed with Row_.  
 
See ‘Prefixes’ for information on the Row_,  and other prefixes. 
 

 
Prefix example. 

 
The text or placeholder to be printed is entered in to the text box in 
properties. It may also be edited by double clicking on any element in the 
report template. 
 
In the simple report template example below, every channel in Rig Data 
will be printed, one below another, each on a separate row. 

 

 
Example. 

 

Prefixes. 
 
General Purpose Prefixes. 
 
Header_ Any element prefixed with Header_ will appear on 

every page of a report. There can be more than 
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one Header_ on a page. It’s position is determined 
by its actual placed position on the template page. 
It does not necessarily have to be used at the top 
of a page.  It does not define the top of the page, 
and text can be printed above the top Header_ . 

 
Footer_ There can only be one Footer_  element per page. 

It need not necessarily be at the bottom of the 
page, its position is determined by its actual 
placed position on the template page. However, 
(unlike Header_)  it is used during report 
generation to define the bottom of the printable 
page (rather than the paper bottom itself), and 
nothing can be printed below it with the exception 
of a PageInfo_ element. 

 
PageInfo_ A PageInfo_ element is the only element which 

can appear below a Footer_. Only one PageInfo_ 
element can appear on any page. It is most 
commonly used with the element 
[report.page_counter] to produce a report page 
number at the very bottom of the report page. 

 
Row_ Any element prefixed with Row_ will appear 

multiple times, once for every data of the chosen 
type. For example, if the element internal name is 
Row_Text, and the Text is itself [Channel], then a 
row will be printed for every channel in the show 
file.  

 
RowHeader_ Any element prefixed with RowHeader_ will appear 

once, on every page of a report. It is most 
commonly used to produce column headings in 
reports 

 
FirstPageHeader_ Similar to RowHeader_ but appears only on the 

first page of a report, after a cover page. 
 
 
Cover_ Use on page 1 of a report template to create a 

cover page. Place the normal report template on 
page 2. Cover pages are optional, and will only 
appear once at the beginning of a multi page 
report. 

 
 
Rig Data Specific Prefixes. 
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(See RigData_FixtureCards.lhf for example of usage.) 
 
 
Label1_ Extracts Rig Data, but rather than displaying it in 

consecutive rows, displays it where labels_ are 
located on the template page. Typically used to 
generate fixture cards. Each label position must 
have a unique number, starting at 1. For example, 
when used with [Channel], Label1_, Label2_, 
Label3_ and Lable4_ placed on a template page 
will extract the first 4 channel numbers for page 1, 
the next 4 for page 2, and so forth.  

 

 
Fixture Card Report. 

 
 
Wheel Load Specific Prefixes. 
 
LoadHeader_ Similar to RowHeader_, but  automatically repeats 

itself for every gobo load on the report page. 
 
WheelHeader_ Similar to RowHeader_, but  automatically repeats 

itself every wheel load on the report page. 
 
WheelRow_ Similar to Row. 
 
WheelImage_ Inserts Wheel Load Images. 
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Example of a Wheel Load Report. 

  
Preset Specific Prefixes. 
 
PresetHeader_ 
 
Channel Usage Specific Prefixes. 
 
RowLayout_ 
 
HRowHeader_ 
 
Column Layout_ 
 
Column_ 
 
Entry_ 
 
Intensity Moves Specific Prefixes. 
 
(See IntensityCueMoves.lhf for example of usage.) 
 
UpHeader_ Provides a single title to the left of a list of 

channels which are increasing in intensity in a cue. 
Allows the list to expand and contract, with more 
and less rows, as required. 

 
DownHeader_ Provides a single title to the left of a list of 

channels which are decreasing in intensity in a 
cue. Allows the list to expand and contract, with 
more and less rows, as required. 
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TrackHeader_ Provides a single title to the left of a list of 
channels which are not changing intensity 
(‘tracking’) in a cue. Allows the list to expand and 
contract, with more and less rows, as required. 

 
UpRowLayout_ Provides for a text box to expand and contract as 

necessary to contain all the channels increasing in 
a cue. 

 
DownRowLayout_ Provides for a text box to expand and contract as 

necessary to contain all the channels decreasing in 
a cue. 

 
TrackRowLayout_ Provides for a text box to expand and contract as 

necessary to contain all the channels not changing 
in a cue. 

 
UpColumnText_ Extracts data for all channels which are increasing 

in intensity in a cue. Typically used with [Chan] 
and [Level]. 

 
DownColumnText_ Extracts data for all channels which are decreasing 

in intensity in a cue. Typically used with [Chan] 
and [Level]. 

 
TrackColumnText_ Extracts data for all channels which are 

unchanging in intensity in a cue. Typically used 
with [Chan] and [Level]. 

 

 
Example of Intensity Moves report. 
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APPENDECIES. 
 

Appendix 1. 
 

Camera Compatibility. 
 
Many cameras which support remote shutter release may be capable of 
working with Moving Light Assistant on Mac OS X 10.6 or later. Such 
cameras are generally higher end DSLR models. Currently, only Canon 
cameras will work under Microsoft Windows 7. 
 
Supported Cannon Cameras: 
 
(Camera should be compatible, but support cannot be guaranteed.) 
 
EOS-1D Mark III 
EOS 40D 
EOS-1Ds Mark III 
EOS DIGITAL REBEL Xsi/450D/Kiss X2 
EOS DIGITAL REBEL XS/1000D/KISS F 
EOS 50D 
EOS 5D Mark II 
EOS Kiss X3/EOS REBEL T1i/EOS 500D 
EOS 7D 
EOS 1D Mark IV 
EOS Kiss X4/EOS REBEL T2i/EOS 550D 
EOS 60D 
EOS Kiss X5/EOS REBEL T3i/EOS 600D 
EOS Kiss X50/EOS REBEL T3/EOS 1100D 
 
The following cameras should work, but compatibility cannot be 
guaranteed in the future. 
 
EOS-1D Mark II 
EOS 20D 
EOS-1Ds Mark II 
EOS Kiss Digital N/350D/REBEL XT 
EOS 5D (Cannot be used with Mac OS X 10.5.1, 10.5.2) 
EOS-1D Mark II N 
 
Nikon D5100 
 
(List as of June 2012) 
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Appendix 2. 
 

Report data place holders. 
 

Production Information Placeholders. 
 
May be used in any report. 
 
[ProdInfo_Title] 
[ProdInfo_Venue] 
[ProdInfo_City] 
[ProdInfo_Country] 
[ProdInfo_PaperworkDate] 
[ProdInfo_PaperworkRevision] 
[ProdInfo_PaperworkStage] 
[ProdInfo_PremiereDate]  
[ProdInfo_ShowImage]  
[ProdInfo_ImportFileName] 
 
[ProdInfo_Producer] 
[ProdInfo_Director] 
[ProdInfo_SetDesigner] 
[ProdInfo_CostumeDesigner] 
[ProdInfo_ProjectionDesigner] 
[ProdInfo_CreativeTeamMisc1Title] 
[ProdInfo_CreativeTeamMisc1Name] 
[ProdInfo_CreativeTeamMisc2Title] 
[ProdInfo_CreativeTeamMisc2Name]  
 
[ProdInfo_LD] 
[ProdInfo_LDEmail] 
[ProdInfo_LDTel][ProdInfo_LDCopyright] 
[ProdInfo_LDDisclaimer]  
[ProdInfo_AssocLDName] 
[ProdInfo_AssocLDEmail] 
[ProdInfo_AssocLDTel]  
[ProdInfo_AssistLDName] 
[ProdInfo_AssistLDEmail] 
[ProdInfo_AssistLDTel]  
[ProdInfo_LDImage]  
 
[ProdInfo_LightingProgrammer] 
[ProdInfo_LightingProgrammerEmail] 
[ProdInfo_LightingProgrammerTel]  
[ProdInfo_ProjectionProgrammer] 
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[ProdInfo_ProjectionProgrammerEmail] 
[ProdInfo_ProjectionProgrammerTel]  
[ProdInfo_ProdLX] 
[ProdInfo_ProdLXEmail] 
[ProdInfo_ProdLXTel]  
[ProdInfo_LightingSupervisor] 
[ProdInfo_LightingSupervisorEmail] 
[ProdInfo_LightingSupervisorTel]  
 
[ProdInfo_LightingSupplier] 
[ProdInfo_LightingSupplierContact] 
[ProdInfo_LightingSupplierEmail] 
[ProdInfo_LightingSupplierTel]  
[ProdInfo_ProjectionSupplier] 
[ProdInfo_ProjectionSupplierContact] 
[ProdInfo_ProjectionSupplierEmail] 
[ProdInfo_ProjectionSupplierTel]  
 
[report.now] Today’s date in dd/mm/yyy format. 
[report.page_counter] Calculates and returns page numbers as the 

report is generated 
 
 

Cue List Report Placeholders. 
 
[SelectedSequence] Name or ID of Cue List/Sequence being 

reported 
[SequenceID] Name or ID of Cue List/Sequence (All) 
[CueNumber] Cue Number (All) 
[Name] Cue Name (All) 
[Part] Cue Part (EOS) 
[MIB]  Moving in Black/Mark (GMA:MIB, EOS:Mark) 
[Trigger]  Cue Trigger (GMA : Trig) 
[FadeTime]  Cue Fade Time (GMA:Fade, EOS:Time) 
[OutfadeTime]  Cue Out Time (GMA:Outfade, 

EOS:Down_Time) 
[Snap] Cue Snap (GMA:Snap) 
[IndependentFade]  Ind. Fade Time (GMA:I.Fade) 
[IndependentDelay]  Ind. Delay Time (GMA:I.Delay) 
[Loop] Cue Loop (GMA:Loop, EOS:Loop) 
[LoopDelay]  Loop Delay (GMA:Lo.Delay) 
[Link] Cue Link (GMA:Link, EOS:Link) 
[LinkDelay] Link Delay (GMA:Li.Del) 
[Effects]  Linked Effect (GMA:Effects, EOS:Effects) 
[DelayTime]  Delay Time (GMA:Delay) 
[OutdelayTime]  Out Delay (GMA:Outdelay,EOS:Down_Delay) 
[InfoText] Cue Information Text (GMA:Info) 
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[DimPath] Dimmer Path (GMA:Dim Path) 
[MovePath] Movement Path (GMA:Move Path) 
[UpTime] Up Fade Time (ASCII) 
[DownTime]  Down Fade Time (ASCII) 
[FocusTime]  Focus Fade Time (EOS) 
[FocusDelay]  Focus Delay Time (EOS) 
[ColourTime]  Colour Fade Time (EOS) 
[ColourDelay]  Colour Delay Time (EOS) 
[BeamTime] Beam Fade Time (EOS) 
[BeamDelay]  Beam Delay Time (EOS) 
[EOSUpTime]   
[EOSDownTime]  
[EOSFocusTime]  
[EOSColorTime]  
[EOSBeamTime]  
[Rate] Cue Rate (EOS) 
[Wait] Cue Trigger (Hog 2) 
[Info_Notes]  Documentation - Notes 
[Info_ActNumber]  Documentation – Act Number 
[Info_SceneNumber]  Documentation – Scene Number 
[Info_SceneText] Documentation – Scene Name 
[Info_Scenery] Documentation – Set 
 
[Info_Image1Caption] Documentation – Photo 1 Caption 
[Info_Image1FileName] Documentation – Photo 1 File Name 
[Info_Image2Caption] Documentation – Photo 1 Caption 
[Info_Image2FileName] Documentation – Photo 1 File Name 
[Info_Image3Caption] Documentation – Photo 1 Caption 
[Info_Image3FileName] Documentation – Photo 1 File Name 
[Info_Image4Caption] Documentation – Photo 1 Caption 
[Info_Image4FileName] Documentation – Photo 1 File Name 
[Info_Image1] Documentation -  Photo 1 (Photo + Drawing) 
[Info_Image1Photo] Documentation -  Photo 1 (Photo Only) 
[Info_Image2] Documentation -  Photo 2 (Photo + Drawing) 
[Info_Image2Photo] Documentation -  Photo 2 (Photo Only) 
[Info_Image3] Documentation -  Photo 3 (Photo + Drawing) 
[Info_Image3Photo] Documentation -  Photo 3 (Photo Only) 
[Info_Image4] Documentation -  Photo 4 (Photo + Drawing) 
[Info_Image4Photo] Documentation -  Photo 4 (Photo Only) 
 
 

Rig Data Report Placeholders. 
 
[Channel] Channel number. 
[FixtureType] Fixture Type name. 
[FixtureNumber] Fixture number ( as used by GrandMA ). 
[ConsoleID] ID consoles uses to identify the channel ( i.e. 

Combines the delay time with the 
function time. E.g Delay =3, Time =2 
returns 3 2. If delay =0, just the time 
is returned. (EOS) 
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Hog 2 files ). 
[ConsoleFixtureProfile] Name of fixture profile that console uses. 
[Position] Position fixture is mounted on. 
[UnitNumber] Position unit number. 
[Mounting] How the unit is mounted. 
[Orientation] Connector orientation. 
[Purpose] purpose of fixture (i.e. focus ). 
[InstrumentType] Used mainly by Lightwright should be.. 

"Light", "Moving Light","Device", 
"Accessory","Power" or "Other". 

[DMXMode] Name of DMX fixture mode ( From fixture 
profile ). 

[NumDMXChans] Number of DMX channels ( From fixture 
Profile). 

[WheelLoad] Name of gobo wheel load. 
[ColourFilter] Colour filter attched to fixture. 
[Accessory] Name of accessory i.e. Top hat. 
[Baffle] Is sound baffle attached. 
[Lamp] Name of lamp installed ( selected from fixture 

profile ). 
[FrontLens] Type of lens installed ( selected from fixture 

profile ). 
[InternalLens] Type of internal lens installed ( selected from 

fixture profile ). 
[Bay1Option] Optional feature bay installed. 
[Bay2Option] Optional feature bay installed. 
[FrostInstalled] Frost fitted. 
[DMXAddress] DMX address of fixture 1 – 512 
[DMXUniverse] DMX universe of fixture as a number. Starts at 

1. 
[IntensityDMXAddress] DMX address of intensity accessory 1 - 512. 
[IntensityDMXUniverse] DMX universe of intensity accessory as a 

number. Starts at 1. 
[ColourDMXAddress] DMX address of colour accessory 1 - 512. 
[ColourDMXUniverse] DMX universe of colour accessory as a 

number. Starts at 1. 
[BeamDMXAddress] DMX address of beam accessory 1 - 512. 
[BeamDMXUniverse] DMX universe of beam accessory as a 

number. Starts at 1. 
[DMXSystem] DMX system patched to as a number. Starts 

at 1.  
[SupplyCircuit] Generic power supply circuit identifier 
[SupplyDMXAddress] DMX address of power supply circuit 1 - 512. 
[SupplyDMXUniverse] DMX universe of power supply circuit as a 

number. Starts at 1. 
[SupplyMulti] Multicore identifier 
[SupplyMultiWay] Way number used on multicore. 
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[FixtureID] RDM fixture ID. 
[SerialNumber] Serial number of fixture currently rigged. 
[ExternalID] External ID from applications such as 

LightWright or Vectorworks. 
[LightwrightID] Lightwright ID 
[DeviceType] Lightwright DeviceID, should be.. "Light", 

"Moving Light", "Device","Accessory","Power" 
or "Other" 

[CaseColour] Exterior case colour.[UserField1] = User 
defined field. 

[UserField2] User defined field. 
[UserField3] User defined field. 
[UserField4] User defined field. 
[UserField5] User defined field. 
[UserField6] User defined field. 
[LocationX] Fixture X location. 
[LocationY] Fixture Y location. 
[LocationZ] Fixture Z location. 
[RotationX] Fixture X Rotation. 
[RotationY] Fixture Y Rotation. 
[RotationZ] Fixture Z Rotation. 
[Repeater] Repeater identifier. i.e. Sr1. 
[RepeaterPort] Port number fixture is connected to on 

repeater as a number.  
[Addr] This is the DMX address formatted as it 

appears in the main rig data window               
( i.e.A/01). The application preferences define 
the format that will be displayed. 

[IAddr] Intensity Address formatted as described for 
[Addr]. 

[CAddr] Colour Address formatted as described for 
[Addr]. 

[BAddr] Beam Address formatted as described for 
[Addr]. 

[NumDMXSlots] Number of DMX slots. It is really just a 
renamed access variable tothe NumDMXChans 
database field. This is consistent with the 
naming convention used inthe main rig 
window. 

[FixtureOptionState] Returns ʻDefaultʼ if fixture options are default, 
ʻCustomʼ if they are not.  

[DIPImage] DIP Switch Image. 
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Console Data Report Placeholders. 
 
[UsageCueRange] Will only return a result if Channel Usage has been 

performed in Console Data view. 
[UsageAct] Will only return a result if Channel Usage has been 

performed in Console Data view. 
[Imax] 
[ICues] 
[Chan] 
[Level] 
 
  

Wheel Load Report Placeholders. 
 
[WheelLoad_Name] 
[WheelLoad_profileName] 
[WhType] 
[WhNum] 
[WhPosition] 
[WhCatalog] 
[WhReference] 
[WhTitle] 
[WheelImage] 
[ViewNote] 
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Appendix 3. 

Reports and the Report Designer Tutorial. 
 
Before any paper (or PDF) reports can be generated from Moving Light Assistant, 
we need to define what information we want the report to show, and the how we 
want that information laid out. 
 
This information is held in layout files. Before any report can be generated, an 
appropriate layout file must first be loaded. Moving Light Assistant comes with 
several layout files which may be loaded to provide some basic reports, and a 
powerful graphical report designer which allows you to design your own custom 
report layouts. 
 
At first sight, the lack of any inbuilt reporting ability may seem a drawback, and 
the process of building and loading custom layouts laborious and cumbersome. 
However once the process is understood and one is familiar with the function of 
the report designer, the power and versatility of the system becomes apparent. 
 
It is worth pointing out that a report design will typically only have to be 
undertaken once, after which the same layout file can be used with different 
show files over and over again. 
 
In this tutorial we will look at producing a layout file for a simple instrument 
schedule containing the following information: Unit# / Position / channel / DMX 
address / Fixture type  

Open the Report Designer. 
 
From the main menu bar, select Reports, then ‘Report Designer’. 
 
The Report Designer window will open. 
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Report Designer Window. 
 

Select the ‘New Report’ icon, or File->New Report from the menu bar. 
 
The New Report Settings window will open. 
 
There are only 2 mandatory fields to fill in at this stage (Bold Headings): 
 

Title. Enter a title of your choice for the report. In this 
example, enter Inst. Schedule. 
When you come to save the layout, this title will be 
offered as a file name, but this can be changed to any 
other file name you choose at the time. The Title in the 
report settings will not change, even if you choose to 
use another file name. 

 
Internal name. This field is a pointer to the type of information the 

report will contain. The field must contain one of the 
following phrases, exactly as typed here: 

 Rig Data 
Cue List 
Wheel Load 
Channel Usage 
Preset Doc 
Cue Moves 

 The names are pretty self descriptive. As we are 
creating an Instrument Schedule in this tutorial, we 
need to use ‘Rig Data’. 

 
Other fields are available if you wish to enter further information, but their use is 
not compulsory. 
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These settings can always be re-visited by clicking on the ‘Report Preferences’ 
icon, but for the moment, click ‘OK’ to close the window and move on. 
 

 
Report Preferences. 

 
Upon closing the settings window you will be presented with the Report Designer 
main layout window. Initially this represents a blank sheet of paper, as we have 
not yet told the layout designer what information we want to display, and 
whereabouts on the page we wish to display it. 
Down the right hand side of the screen, under the title ‘Properties’ is information 
about the paper size, orientation and border size. All this information can be 
changed by clicking back on ‘Report Preferences’. 
 
It is important to realise that the Report designer is a graphical layout 
tool, and the paper space being presented in front of you is a blank 
canvas on which on which information can be placed anywhere, in any 
order, in any colour and any font. It may be interspersed and combined 
with simple graphical shapes and imported pictures. 
 
Because we are working in a graphical environment, and are not limited to 
simple multiple rows of text, there is a grid to assist you in laying out and 
aligning your information. The grid size and it’s visibility are controlled by 
buttons along the bottom of the screen. The grid represents the printable area of 
the paper space, and does not include the margins. As various items are added 
to the page, their positions will ‘snap’ to the grid, ensuring easy uniform 
alignment. 

Adding Data. 
 
Click on the button labelled ‘T’ on the left hand side of the screen and click 
anywhere on the paper space to place a text block. Repeat the process 4 more 
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times. Each text block will eventually represent a piece of rig data, in this 
example, unit number, position, channel, fixture type and DMX address. 
Remember you can place the text blocks anywhere you wish on the paper, but 
because we are producing a simple instrument schedule where we probably want 
the information displayed in rows, place the text blocks one after the other in a 
single row. 
 

 
Positioning Textblocks in Report Designer. 

 
Each text block is a ‘place holder’ for the real data, and we now need to link each 
placeholder with the appropriate piece of data. Double click on the first place 
holder and type ‘[UnitNumber]’ in to the pop up text edit window. Be sure to 
include the opening and closing square brackets, and ensure the text is spelled 
correctly. If the spelling is incorrect, MLA will not understand what item of data 
you are trying to insert, and will be unable to find it.  Click OK to close the 
window. 

 
Edit Text – Option 1. 

 
Alternatively, edit the text in the text edit window to the right hand side of the 
screen. 

 
Edit Text – Option 2. 
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Repeat the process for the other 4 place holders, entering the data types 
[Position], [Channel], [FixtureType], [DMXAddress], in the order in which you 
wish the information to be displayed. 
 
Finally, because there are multiple fixtures in our rig data, we need to tell MLA to 
create a new row of information for every new set of data it finds. To do this we 
need to append ‘Row_’ (without the quotes) to the internal names . 
 
Select the first text block, which in our example is now displayed as 
‘UnitNumber’. On the right hand side of the screen, under the heading ‘Property’ 
you will find its ‘internal name’, ‘Text1’. The internal names are automatically 
derived from the order in which the text block was originally placed on the paper.  
 
Edit the internal name to ‘Row_UnitNumber’. The internal name can be anything 
you want so long as it is unique, and in this instance, preceded by ‘Row_’  

 
Editing internal names. 

 
Continue the process for the other 4 text blocks. 
 
We should now have the basis of a ‘rough and ready’ instrument schedule layout. 
 
Click on the ‘Save’ Icon to save this layout. Ensure the layout is saved to the 
default ‘Report Layout Templates’ folder in the Moving Light Assistant installation 
folder. 
 
Click on the ‘Close Designer’ icon, or use File >  Close designer to exit the Report 
Designer. 

Testing the Report Layout. 
 
Having designed your report layout, it is now time to produce an instrument 
schedule from real rig data. 
 
Open the show file in MLA from which you wish to produce the report, and click 
on the ‘Report Preview’ tab. The empty report preview window will open. 
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Report Preview Window. 

 
Select your report layout file from the drop down list of reports, and accept the 
rig data report default options. (Sort by position, Show All). 

 
If all is well, your report should now be generated based upon your layout. 

 
Generated Report. 

 
If some columns are overprinted on each other it may be necessary to go back in 
to the report designer and re-space the text blocks. This is easily achieved by 
simply dragging them further apart to a new position. 
 
Once you are happy with the layout of your basic Instrument schedule, it is a 
simple matter to either print to paper, or print directly to PDF by clicking on the 
appropriate icons. 
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A common error is shown below. In this case, a text block has been assigned an 
invalid data name, [DMXAdd], rather than the correct [DMXAddress]. This must 
be corrected by editing the layout file in Report Designer.  
 

 
Example of incorrect data place holder names. 

 
Although we now have the beginnings of an instrument schedule, there is still a 
lot we can do to tidy it up. In particular, two missing features are column 
headings and titles. 
 

Adding Column Headings and Titles. 
 
Re-open the layout file in the Report Designer. 
To get MLA to produce multiple rows, one for each fixture, we have already 
prefixed the internal name with ‘Row_’.  
There are 3 other prefixes that may be used. ‘RowHeader_’ ,‘Header_’ and 
‘FirstPageHeader’ 
Any text with an internal name prefixed with ‘RowHeader_’ will appear  on every 
page of the report. Similarly, any text with an internal name prefixed with 
‘Header_’ will appear only  on the first page of the report. Any text prefixed with 
‘FirstPageHeader_’ will only appear on the first page. 
Place 5 more text blocks above the existing 5 text blocks. Rename each block 
with whatever name you want the column heading to be called. In this case, do 
not use the square brackets as the text you are entering is purely text, and does 
not relate to any particular data. Similarly, the text does not necessarily have to 
be the same as the data placeholder. In the example below the data placeholder 
‘FixtureType’ is under the heading ‘Instrument’. 
Add a line underneath the headings and drag it out to the full width of the page. 
This will be  given the internal name of ‘Line 1’. Edit this to ‘RowHeader_Line 1’ 
to ensure the line appears on every page: 
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This new layout produces the following report layout  
 

 
 

To add a fixed title on the first page only, simply add the text in to the Layout, 
with an internal name preceded by ‘Header_’. 
For Example, too add the title ‘Instrument Schedule’, edit the layout file thus: 
 

 
In this example, the text ‘My Instrument Schedule’ is inserted as a text block, 
with the colour changed to red, and the text size increased. It’s internal name 
has been edited to ‘Header_Big Title’. 
 
As the phrase ‘My Instrument Schedule’ has been inserted as text (without the 
square brackets), it will never change , and will always be there every time this 
layout file is used. There is, however, much information which may belong in the 
title which we want to change from production to production. 
 
This information may include any data held by MLA  in File->Show->Production. 
This information includes such things as show title and venue, lighting designers 
name, date of opening night etc.. 
 
All this information can be included by using more data place holders, just as we 
used data place holders to add rig data. In the example layout file below, the 4 
new data place holders all have internal names prefixed with ‘Header_’, and 
display the name of the production, venue and production electrician, along with 
the date the paperwork was produced. The text ‘Production Electrician’ and 
‘Paper work date’ is raw text entered as text blocks to form ‘sub-titles’ 
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The above layout file produces the following report layout: 
 

 

 
End of Tutorial. 


